summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-02 18:48:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-02 18:48:26 +0000
commit030593248083e108ae23500d76436bdf7cd66b15 (patch)
tree1c5fb026366b347e1038f1a13a35a6e47f503dbc /media-libs
parentVersion bump. Cleanup old. (diff)
downloadgentoo-2-030593248083e108ae23500d76436bdf7cd66b15.tar.gz
gentoo-2-030593248083e108ae23500d76436bdf7cd66b15.tar.bz2
gentoo-2-030593248083e108ae23500d76436bdf7cd66b15.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lilv/ChangeLog7
-rw-r--r--media-libs/lilv/lilv-0.20.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/media-libs/lilv/ChangeLog b/media-libs/lilv/ChangeLog
index 7885d4996b0c..9748e7543826 100644
--- a/media-libs/lilv/ChangeLog
+++ b/media-libs/lilv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lilv
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/ChangeLog,v 1.13 2014/11/02 18:46:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/ChangeLog,v 1.14 2014/11/02 18:48:26 aballier Exp $
+
+*lilv-0.20.0 (02 Nov 2014)
+
+ 02 Nov 2014; Alexis Ballier <aballier@gentoo.org> +lilv-0.20.0.ebuild:
+ version bump
02 Nov 2014; Alexis Ballier <aballier@gentoo.org> -lilv-0.5.0.ebuild,
-lilv-0.14.2.ebuild, -lilv-0.14.4.ebuild, -lilv-0.16.0.ebuild,
diff --git a/media-libs/lilv/lilv-0.20.0.ebuild b/media-libs/lilv/lilv-0.20.0.ebuild
new file mode 100644
index 000000000000..6dc5813eaf5f
--- /dev/null
+++ b/media-libs/lilv/lilv-0.20.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/lilv-0.20.0.ebuild,v 1.1 2014/11/02 18:48:26 aballier Exp $
+
+EAPI=4
+
+inherit base waf-utils bash-completion-r1
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://drobilla.net/software/lilv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc +dyn-manifest static-libs test"
+
+RDEPEND="media-libs/lv2
+ >=media-libs/sratom-0.4.0
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.12.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --no-bash-completion \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static") \
+ $(use dyn-manifest && echo "--dyn-manifest")
+}
+
+src_test() {
+ ./waf test || die
+}
+
+src_install() {
+ waf-utils_src_install
+ newbashcomp utils/lilv.bash_completion ${PN}
+}