summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-19 17:16:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-19 17:16:55 +0000
commit06a2f4c8e479e380526bfbb41823ee584ef597a6 (patch)
tree25c5d40e25bed411b303fa94e4b3e5aae4706bf4 /media-libs
parentRevbump with no changes to get a gnome-2 version in ~arch with an unmasked in... (diff)
downloadgentoo-2-06a2f4c8e479e380526bfbb41823ee584ef597a6.tar.gz
gentoo-2-06a2f4c8e479e380526bfbb41823ee584ef597a6.tar.bz2
gentoo-2-06a2f4c8e479e380526bfbb41823ee584ef597a6.zip
new snapshot
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x264/ChangeLog7
-rw-r--r--media-libs/x264/x264-0.0.20111218.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index b814583c1083..bbca5ae73d32 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.62 2011/10/19 16:26:12 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.63 2011/12/19 17:16:55 aballier Exp $
+
+*x264-0.0.20111218 (19 Dec 2011)
+
+ 19 Dec 2011; Alexis Ballier <aballier@gentoo.org> +x264-0.0.20111218.ebuild:
+ new snapshot
*x264-0.0.20111017 (19 Oct 2011)
diff --git a/media-libs/x264/x264-0.0.20111218.ebuild b/media-libs/x264/x264-0.0.20111218.ebuild
new file mode 100644
index 000000000000..3ccb4f5cb714
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20111218.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20111218.ebuild,v 1.1 2011/12/19 17:16:55 aballier Exp $
+
+EAPI=4
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ V_ECLASS="git-2"
+else
+ V_ECLASS="versionator"
+fi
+
+inherit multilib toolchain-funcs ${V_ECLASS}
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ MY_P="x264-snapshot-$(get_version_component_range 3)-2245-stable"
+fi
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ EGIT_REPO_URI="git://git.videolan.org/x264.git"
+ SRC_URI=""
+else
+ SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+IUSE="debug +threads pic static-libs"
+
+RDEPEND=""
+ASM_DEP=">=dev-lang/yasm-0.6.2"
+DEPEND="
+ amd64? ( ${ASM_DEP} )
+ x86? ( ${ASM_DEP} )
+ x86-fbsd? ( ${ASM_DEP} )
+"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S=${WORKDIR}/${MY_P}
+fi
+DOCS="AUTHORS doc/*.txt"
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf+=" --enable-debug"
+ use static-libs && myconf+=" --enable-static"
+ use threads || myconf+=" --disable-thread"
+
+ if use x86 && use pic; then
+ myconf+=" --disable-asm"
+ fi
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} || die
+}