summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2010-12-27 11:37:51 +0000
committerMart Raudsepp <leio@gentoo.org>2010-12-27 11:37:51 +0000
commit082d05fe00dd0957b79d7b48c339d161f909723d (patch)
tree22ab142edfed67b2d4a0556c0b3a5eb52c5b2c8b /media-libs
parentMark as stable. (diff)
downloadgentoo-2-082d05fe00dd0957b79d7b48c339d161f909723d.tar.gz
gentoo-2-082d05fe00dd0957b79d7b48c339d161f909723d.tar.bz2
gentoo-2-082d05fe00dd0957b79d7b48c339d161f909723d.zip
Version bump with the following most noteworthy upstream changes compared to 0.10.13: Many bugfixes to asfdemux, including for gentoo bug 321745. Assorted fixes to rmdemux (realmedia) and mpegaudioparse.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-ugly/ChangeLog11
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild57
2 files changed, 67 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-ugly/ChangeLog b/media-libs/gst-plugins-ugly/ChangeLog
index c593f7ad92c6..f3994c00eb00 100644
--- a/media-libs/gst-plugins-ugly/ChangeLog
+++ b/media-libs/gst-plugins-ugly/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/gst-plugins-ugly
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.72 2010/08/05 20:05:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.73 2010/12/27 11:37:51 leio Exp $
+
+*gst-plugins-ugly-0.10.16 (27 Dec 2010)
+
+ 27 Dec 2010; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-ugly-0.10.16.ebuild:
+ Version bump with the following most noteworthy upstream changes compared
+ to 0.10.13:
+ Many bugfixes to asfdemux, including for gentoo bug 321745.
+ Assorted fixes to rmdemux (realmedia) and mpegaudioparse.
05 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
gst-plugins-ugly-0.10.13.ebuild:
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild
new file mode 100644
index 000000000000..82f1e8e111e5
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.16.ebuild,v 1.1 2010/12/27 11:37:51 leio Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-ugly gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.26
+ >=media-libs/gstreamer-0.10.26
+ >=dev-libs/glib-2.20"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.13"
+
+GST_PLUGINS_BUILD=""
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-ugly_src_configure
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ elog ""
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}