summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-02-21 04:06:50 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-02-21 04:06:50 +0000
commit24bd94d63469f323e0b74eae729f7d5697c75e7c (patch)
treefdcb067bd93b809428d38204401f55f41112e096 /media-libs
parentMarked ppc stable for bug #167816. (diff)
downloadgentoo-2-24bd94d63469f323e0b74eae729f7d5697c75e7c.tar.gz
gentoo-2-24bd94d63469f323e0b74eae729f7d5697c75e7c.tar.bz2
gentoo-2-24bd94d63469f323e0b74eae729f7d5697c75e7c.zip
Added largefile support patch for bug #118600.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/audiofile/ChangeLog10
-rw-r--r--media-libs/audiofile/audiofile-0.2.6-r3.ebuild37
-rw-r--r--media-libs/audiofile/files/audiofile-largefile.patch13
-rw-r--r--media-libs/audiofile/files/digest-audiofile-0.2.6-r33
4 files changed, 61 insertions, 2 deletions
diff --git a/media-libs/audiofile/ChangeLog b/media-libs/audiofile/ChangeLog
index 27e1a81b1371..b488ffe0bcad 100644
--- a/media-libs/audiofile/ChangeLog
+++ b/media-libs/audiofile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/audiofile
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/audiofile/ChangeLog,v 1.47 2006/10/20 21:38:18 kloeri Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/audiofile/ChangeLog,v 1.48 2007/02/21 04:06:50 josejx Exp $
+
+*audiofile-0.2.6-r3 (21 Feb 2007)
+
+ 21 Feb 2007; Joseph Jezak <josejx@gentoo.org>
+ +files/audiofile-largefile.patch, +audiofile-0.2.6-r3.ebuild:
+ Added largefile support patch for bug #118600.
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
audiofile-0.2.6-r2.ebuild:
diff --git a/media-libs/audiofile/audiofile-0.2.6-r3.ebuild b/media-libs/audiofile/audiofile-0.2.6-r3.ebuild
new file mode 100644
index 000000000000..452ae2fcb40e
--- /dev/null
+++ b/media-libs/audiofile/audiofile-0.2.6-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/audiofile/audiofile-0.2.6-r3.ebuild,v 1.1 2007/02/21 04:06:50 josejx Exp $
+
+inherit libtool eutils
+
+DESCRIPTION="An elegant API for accessing audio files"
+HOMEPAGE="http://www.68k.org/~michael/audiofile/"
+SRC_URI="http://www.68k.org/~michael/audiofile/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/sfcommands
+ epatch "${FILESDIR}"/sfconvert-eradicator.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}"/${P}-constantise.patch
+
+ ### Patch for bug #118600
+ epatch "${FILESDIR}"/${PN}-largefile.patch
+ elibtoolize
+}
+
+src_compile() {
+ econf --enable-largefile || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ACKNOWLEDGEMENTS AUTHORS ChangeLog README TODO NEWS NOTES
+}
diff --git a/media-libs/audiofile/files/audiofile-largefile.patch b/media-libs/audiofile/files/audiofile-largefile.patch
new file mode 100644
index 000000000000..a4bf4bf9e2aa
--- /dev/null
+++ b/media-libs/audiofile/files/audiofile-largefile.patch
@@ -0,0 +1,13 @@
+--- libaudiofile/audiofile.h 2006/10/05 22:05:50 1.1
++++ libaudiofile/audiofile.h 2006/10/05 22:06:00
+@@ -45,8 +45,8 @@ typedef struct _AFfilesetup *AFfilesetup
+ typedef struct _AFfilehandle *AFfilehandle;
+ typedef void (*AFerrfunc)(long, const char *);
+
+-typedef off_t AFframecount;
+-typedef off_t AFfileoffset;
++typedef int64_t AFframecount;
++typedef int64_t AFfileoffset;
+
+ #define AF_NULL_FILESETUP ((struct _AFfilesetup *) 0)
+ #define AF_NULL_FILEHANDLE ((struct _AFfilehandle *) 0)
diff --git a/media-libs/audiofile/files/digest-audiofile-0.2.6-r3 b/media-libs/audiofile/files/digest-audiofile-0.2.6-r3
new file mode 100644
index 000000000000..e156baf6cb44
--- /dev/null
+++ b/media-libs/audiofile/files/digest-audiofile-0.2.6-r3
@@ -0,0 +1,3 @@
+MD5 9c1049876cd51c0f1b12c2886cce4d42 audiofile-0.2.6.tar.gz 374688
+RMD160 b61fbc856768a5838ca5c0fad602f35205e8d037 audiofile-0.2.6.tar.gz 374688
+SHA256 4b6167b56e21556fb07c9ef06962fe32817064c62181ba47afd3322e0d0f22a9 audiofile-0.2.6.tar.gz 374688