summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-07-13 16:57:35 +0000
committerJohannes Huber <johu@gentoo.org>2012-07-13 16:57:35 +0000
commit270f3429070d85de98120396bf9603d6ce3f3edd (patch)
treec2726f5dc525a38e24818e6470c10c618aeab487 /media-libs
parentBuild fix for bug #415215. Thanks to Amadeusz Żołnowski for the report and ... (diff)
downloadgentoo-2-270f3429070d85de98120396bf9603d6ce3f3edd.tar.gz
gentoo-2-270f3429070d85de98120396bf9603d6ce3f3edd.tar.bz2
gentoo-2-270f3429070d85de98120396bf9603d6ce3f3edd.zip
Version bump.
(Portage version: 2.2.0_alpha117/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/phonon-gstreamer/ChangeLog8
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-4.6.1.ebuild50
2 files changed, 56 insertions, 2 deletions
diff --git a/media-libs/phonon-gstreamer/ChangeLog b/media-libs/phonon-gstreamer/ChangeLog
index 16b642c42d67..5c2f4ffbfbd9 100644
--- a/media-libs/phonon-gstreamer/ChangeLog
+++ b/media-libs/phonon-gstreamer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/phonon-gstreamer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/ChangeLog,v 1.19 2012/05/17 16:53:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/ChangeLog,v 1.20 2012/07/13 16:57:35 johu Exp $
+
+*phonon-gstreamer-4.6.1 (13 Jul 2012)
+
+ 13 Jul 2012; Johannes Huber <johu@gentoo.org> +phonon-gstreamer-4.6.1.ebuild:
+ Version bump.
17 May 2012; Alexis Ballier <aballier@gentoo.org>
phonon-gstreamer-4.6.0.ebuild, phonon-gstreamer-9999.ebuild:
@@ -101,4 +106,3 @@
+phonon-gstreamer-4.4.4.ebuild, +phonon-gstreamer-9999.ebuild,
+metadata.xml:
Add new package (phonon split), live ebuild from kde overlay
-
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.1.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.1.ebuild
new file mode 100644
index 000000000000..2fea9d91a65d
--- /dev/null
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon-gstreamer/phonon-gstreamer-4.6.1.ebuild,v 1.1 2012/07/13 16:57:35 johu Exp $
+
+EAPI=4
+
+[[ ${PV} == *9999 ]] && git_eclass="git-2"
+EGIT_REPO_URI="git://anongit.kde.org/${PN}"
+
+MY_PN="phonon-backend-gstreamer"
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils ${git_eclass}
+
+DESCRIPTION="Phonon GStreamer backend"
+HOMEPAGE="https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://kde/stable/phonon/${MY_PN}/${PV}/src/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~hppa ~x86 ~amd64-fbsd"
+fi
+SLOT="0"
+IUSE="alsa debug +network"
+
+RDEPEND="
+ media-libs/gstreamer
+ media-plugins/gst-plugins-meta[alsa?,ogg,vorbis]
+ >=media-libs/phonon-4.6.0
+ >=x11-libs/qt-core-4.6.0:4[glib]
+ >=x11-libs/qt-gui-4.6.0:4[glib]
+ >=x11-libs/qt-opengl-4.6.0:4
+ virtual/opengl
+ network? ( media-plugins/gst-plugins-soup )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/automoc-0.9.87
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ )
+ cmake-utils_src_configure
+}