summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-07 13:45:19 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-07 13:45:19 +0000
commit3d36789c3276b8dbc7938d5baa297e4b29176253 (patch)
tree4e5c10b9103e665d271939e6f398eb218babf321 /media-libs
parentStable on arm and hppa (#391567) (diff)
downloadgentoo-2-3d36789c3276b8dbc7938d5baa297e4b29176253.tar.gz
gentoo-2-3d36789c3276b8dbc7938d5baa297e4b29176253.tar.bz2
gentoo-2-3d36789c3276b8dbc7938d5baa297e4b29176253.zip
convert to waf-utils.eclass
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lilv/ChangeLog5
-rw-r--r--media-libs/lilv/lilv-0.5.0.ebuild28
2 files changed, 12 insertions, 21 deletions
diff --git a/media-libs/lilv/ChangeLog b/media-libs/lilv/ChangeLog
index 292aa18733af..a72d0b035cf4 100644
--- a/media-libs/lilv/ChangeLog
+++ b/media-libs/lilv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/lilv
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/ChangeLog,v 1.1 2011/12/07 13:39:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/ChangeLog,v 1.2 2011/12/07 13:45:19 aballier Exp $
+
+ 07 Dec 2011; Alexis Ballier <aballier@gentoo.org> lilv-0.5.0.ebuild:
+ convert to waf-utils.eclass
*lilv-0.5.0 (07 Dec 2011)
diff --git a/media-libs/lilv/lilv-0.5.0.ebuild b/media-libs/lilv/lilv-0.5.0.ebuild
index 0d3466d06e07..291a0c72457f 100644
--- a/media-libs/lilv/lilv-0.5.0.ebuild
+++ b/media-libs/lilv/lilv-0.5.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/lilv-0.5.0.ebuild,v 1.1 2011/12/07 13:39:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/lilv-0.5.0.ebuild,v 1.2 2011/12/07 13:45:19 aballier Exp $
EAPI=4
-inherit base multilib toolchain-funcs
+inherit base waf-utils
DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
HOMEPAGE="http://drobilla.net/software/lilv/"
@@ -23,29 +23,17 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
PATCHES=( "${FILESDIR}/ldconfig.patch" )
+DOCS=( "AUTHORS" "README" "ChangeLog" )
src_configure() {
- tc-export CC CXX CPP AR RANLIB
- ./waf configure \
- --prefix=/usr \
- --libdir="/usr/$(get_libdir)" \
- --mandir=/usr/share/man \
- --docdir=/usr/share/doc/${PF} \
+ waf-utils_src_configure \
+ "--mandir=/usr/share/man" \
+ "--docdir=/usr/share/doc/${PF}" \
$(use test && echo "--test") \
- $(use doc && echo "--docs") \
- || die
- #$(use dyn-manifest && echo "--dyn-manifest") \
-}
-
-src_compile() {
- ./waf || die
+ $(use doc && echo "--docs")
+ #$(use dyn-manifest && echo "--dyn-manifest") \
}
src_test() {
./waf test || die
}
-
-src_install() {
- ./waf install --destdir="${D}" || die
- dodoc AUTHORS README ChangeLog
-}