summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-03-28 04:38:44 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-03-28 04:38:44 +0000
commit5c278d7b85f51d3c6b99aecff2333996a93a2119 (patch)
tree10f79704a61384113cd3b40942dfe2085320e34b /media-libs
parentFix libdir in pkg-config file. Prevents bogus libtool warnings while building... (diff)
downloadgentoo-2-5c278d7b85f51d3c6b99aecff2333996a93a2119.tar.gz
gentoo-2-5c278d7b85f51d3c6b99aecff2333996a93a2119.tar.bz2
gentoo-2-5c278d7b85f51d3c6b99aecff2333996a93a2119.zip
Update the shipped version of ogg.m4 so that users of libflac don't get a ton of libtool warnings while linking.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/flac/ChangeLog11
-rw-r--r--media-libs/flac/files/flac-1.2.1-ogg-m4.patch67
-rw-r--r--media-libs/flac/flac-1.2.1-r4.ebuild70
3 files changed, 146 insertions, 2 deletions
diff --git a/media-libs/flac/ChangeLog b/media-libs/flac/ChangeLog
index 84895bb5c990..c3e1040fbe58 100644
--- a/media-libs/flac/ChangeLog
+++ b/media-libs/flac/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/flac
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/ChangeLog,v 1.149 2010/09/16 11:24:19 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/ChangeLog,v 1.150 2011/03/28 04:38:44 ford_prefect Exp $
+
+*flac-1.2.1-r4 (28 Mar 2011)
+
+ 28 Mar 2011; Arun Raghavan <ford_prefect@gentoo.org> +flac-1.2.1-r4.ebuild,
+ +files/flac-1.2.1-ogg-m4.patch:
+ Update the shipped version of ogg.m4 so that users of libflac don't get a ton
+ of libtool warnings while linking.
16 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> flac-1.2.1-r3.ebuild:
USE="static-libs" and punt .la files. Fix LICENSE. Remove USE="doc" as it
diff --git a/media-libs/flac/files/flac-1.2.1-ogg-m4.patch b/media-libs/flac/files/flac-1.2.1-ogg-m4.patch
new file mode 100644
index 000000000000..ed551d5f80f4
--- /dev/null
+++ b/media-libs/flac/files/flac-1.2.1-ogg-m4.patch
@@ -0,0 +1,67 @@
+diff -urNp flac-1.2.1-old/m4/ogg.m4 flac-1.2.1/m4/ogg.m4
+--- flac-1.2.1-old/m4/ogg.m4 2011-03-28 09:54:44.355000011 +0530
++++ flac-1.2.1/m4/ogg.m4 2011-03-28 09:54:55.721000010 +0530
+@@ -9,23 +9,29 @@ AC_DEFUN([XIPH_PATH_OGG],
+ [dnl
+ dnl Get the cflags and libraries
+ dnl
+-AC_ARG_WITH(ogg,[ --with-ogg=PFX Prefix where libogg is installed (optional)], ogg_prefix="$withval", ogg_prefix="")
+-AC_ARG_WITH(ogg-libraries,[ --with-ogg-libraries=DIR Directory where libogg library is installed (optional)], ogg_libraries="$withval", ogg_libraries="")
+-AC_ARG_WITH(ogg-includes,[ --with-ogg-includes=DIR Directory where libogg header files are installed (optional)], ogg_includes="$withval", ogg_includes="")
+-AC_ARG_ENABLE(oggtest, [ --disable-oggtest Do not try to compile and run a test Ogg program],, enable_oggtest=yes)
++AC_ARG_WITH(ogg,AC_HELP_STRING([--with-ogg=PFX],[Prefix where libogg is installed (optional)]), ogg_prefix="$withval", ogg_prefix="")
++AC_ARG_WITH(ogg-libraries,AC_HELP_STRING([--with-ogg-libraries=DIR],[Directory where libogg library is installed (optional)]), ogg_libraries="$withval", ogg_libraries="")
++AC_ARG_WITH(ogg-includes,AC_HELP_STRING([--with-ogg-includes=DIR],[Directory where libogg header files are installed (optional)]), ogg_includes="$withval", ogg_includes="")
++AC_ARG_ENABLE(oggtest,AC_HELP_STRING([--disable-oggtest],[Do not try to compile and run a test Ogg program]),, enable_oggtest=yes)
+
+ if test "x$ogg_libraries" != "x" ; then
+ OGG_LIBS="-L$ogg_libraries"
++ elif test "x$ogg_prefix" = "xno" || test "x$ogg_prefix" = "xyes" ; then
++ OGG_LIBS=""
+ elif test "x$ogg_prefix" != "x" ; then
+ OGG_LIBS="-L$ogg_prefix/lib"
+ elif test "x$prefix" != "xNONE" ; then
+ OGG_LIBS="-L$prefix/lib"
+ fi
+
+- OGG_LIBS="$OGG_LIBS -logg"
++ if test "x$ogg_prefix" != "xno" ; then
++ OGG_LIBS="$OGG_LIBS -logg"
++ fi
+
+ if test "x$ogg_includes" != "x" ; then
+ OGG_CFLAGS="-I$ogg_includes"
++ elif test "x$ogg_prefix" = "xno" || test "x$ogg_prefix" = "xyes" ; then
++ OGG_CFLAGS=""
+ elif test "x$ogg_prefix" != "x" ; then
+ OGG_CFLAGS="-I$ogg_prefix/include"
+ elif test "x$prefix" != "xNONE"; then
+@@ -33,7 +39,12 @@ AC_ARG_ENABLE(oggtest, [ --disable-oggt
+ fi
+
+ AC_MSG_CHECKING(for Ogg)
+- no_ogg=""
++ if test "x$ogg_prefix" = "xno" ; then
++ no_ogg="disabled"
++ enable_oggtest="no"
++ else
++ no_ogg=""
++ fi
+
+
+ if test "x$enable_oggtest" = "xyes" ; then
+@@ -62,9 +73,12 @@ int main ()
+ LIBS="$ac_save_LIBS"
+ fi
+
+- if test "x$no_ogg" = "x" ; then
++ if test "x$no_ogg" = "xdisabled" ; then
++ AC_MSG_RESULT(no)
++ ifelse([$2], , :, [$2])
++ elif test "x$no_ogg" = "x" ; then
+ AC_MSG_RESULT(yes)
+- ifelse([$1], , :, [$1])
++ ifelse([$1], , :, [$1])
+ else
+ AC_MSG_RESULT(no)
+ if test -f conf.oggtest ; then
diff --git a/media-libs/flac/flac-1.2.1-r4.ebuild b/media-libs/flac/flac-1.2.1-r4.ebuild
new file mode 100644
index 000000000000..2e0ae976ca59
--- /dev/null
+++ b/media-libs/flac/flac-1.2.1-r4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.2.1-r4.ebuild,v 1.1 2011/03/28 04:38:44 ford_prefect Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="free lossless audio encoder and decoder"
+HOMEPAGE="http://flac.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-embedded-m4.tar.bz2"
+
+LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="3dnow altivec +cxx debug ogg sse static-libs"
+
+RDEPEND="ogg? ( >=media-libs/libogg-1.1.3 )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ !elibc_uclibc? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-cflags.patch \
+ "${FILESDIR}"/${P}-asm.patch \
+ "${FILESDIR}"/${P}-dontbuild-tests.patch \
+ "${FILESDIR}"/${P}-dontbuild-examples.patch \
+ "${FILESDIR}"/${P}-gcc-4.3-includes.patch \
+ "${FILESDIR}"/${P}-ogg-m4.patch
+
+ cp "${WORKDIR}"/*.m4 m4 || die
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_enable sse) \
+ $(use_enable 3dnow) \
+ $(use_enable altivec) \
+ --disable-doxygen-docs \
+ --disable-xmms-plugin \
+ $(use_enable cxx cpplibs) \
+ $(use_enable ogg) \
+ --disable-examples
+}
+
+src_test() {
+ if [ $UID != 0 ]; then
+ emake check || die
+ else
+ ewarn "Tests will fail if ran as root, skipping."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc AUTHORS README
+ dohtml -r doc/html/*
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}