summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2008-05-05 09:38:58 +0000
committerChristian Parpart <trapni@gentoo.org>2008-05-05 09:38:58 +0000
commit79074056c1717f82bef2fe113ec5cded242d8004 (patch)
tree8f2b6c1e2588b825589977180f58211350caafb9 /media-libs
parentVersion bump (diff)
downloadgentoo-2-79074056c1717f82bef2fe113ec5cded242d8004.tar.gz
gentoo-2-79074056c1717f82bef2fe113ec5cded242d8004.tar.bz2
gentoo-2-79074056c1717f82bef2fe113ec5cded242d8004.zip
fixes bug 200039. thanks to David Leverton
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/capseo/ChangeLog8
-rw-r--r--media-libs/capseo/capseo-0.3.0_pre200712251-r2.ebuild114
2 files changed, 121 insertions, 1 deletions
diff --git a/media-libs/capseo/ChangeLog b/media-libs/capseo/ChangeLog
index cd803e0d6721..9883862848de 100644
--- a/media-libs/capseo/ChangeLog
+++ b/media-libs/capseo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/capseo
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/capseo/ChangeLog,v 1.6 2008/05/02 14:01:05 trapni Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/capseo/ChangeLog,v 1.7 2008/05/05 09:38:58 trapni Exp $
+
+*capseo-0.3.0_pre200712251-r2 (05 May 2008)
+
+ 05 May 2008; Christian Parpart <trapni@gentoo.org>
+ +capseo-0.3.0_pre200712251-r2.ebuild:
+ fixes bug 200039. thanks to David Leverton
02 May 2008; Christian Parpart <trapni@gentoo.org>
capseo-0.3.0_pre200712251-r1.ebuild:
diff --git a/media-libs/capseo/capseo-0.3.0_pre200712251-r2.ebuild b/media-libs/capseo/capseo-0.3.0_pre200712251-r2.ebuild
new file mode 100644
index 000000000000..56a5a844726b
--- /dev/null
+++ b/media-libs/capseo/capseo-0.3.0_pre200712251-r2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/capseo/capseo-0.3.0_pre200712251-r2.ebuild,v 1.1 2008/05/05 09:38:58 trapni Exp $
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="Capseo Video Codec Library"
+HOMEPAGE="http://rm-rf.in/captury/wiki/CapseoCodec"
+SRC_URI="http://upstream.rm-rf.in/captury/captury-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug theora"
+
+RDEPEND=">=media-libs/libtheora-1.0_alpha6-r1"
+
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/yasm-0.4.0 )
+ amd64? ( >=dev-lang/yasm-0.4.0 )
+ dev-util/pkgconfig"
+
+EMULTILIB_PKG="true"
+
+S="${WORKDIR}/captury-${PV}/${PN}"
+
+src_unpack() {
+ unpack ${A} || die
+
+ cd "${S}"
+ einfo "pwd: $(pwd)"
+ epatch "${FILESDIR}/no-cpsplay.diff" || die
+}
+
+src_compile() {
+ if [[ -z ${OABI} ]] && has_multilib_profile; then
+ use debug && append-flags -O0 -g3
+ use debug || append-flags -DNDEBUG=1
+
+ einfo "Building multilib ${PN} for ABIs: $(get_install_abis)"
+ OABI=${ABI}
+ for ABI in $(get_install_abis); do
+ export ABI=${ABI}
+ src_compile
+ done
+ ABI=${OABI}
+ return
+ fi
+
+ cd "${S}" || die
+
+ if [[ ! -f configure ]]; then
+ ./autogen.sh || die "autogen.sh failed"
+ fi
+
+ # obviousely in src_install() it is set to "default" on non-multilib hosts,
+ # but isn't in src_compile()
+ ABI=${ABI:-default}
+
+ mkdir abi-${ABI}
+ cd abi-${ABI}
+
+ local myconf=
+ case ${ABI} in
+ amd64|x86)
+ myconf="${myconf} --with-accel=${ABI}"
+ ;;
+ esac
+
+ if is_final_abi; then
+ myconf="${myconf} $(use_enable theora)"
+ else
+ # drop unnecessary theora dependency for secondary ABIs (as theora is
+ # only used for the cpsrecode tool anyway).
+ # see bug 200093.
+ myconf="${myconf} --disable-theora"
+ fi
+
+ ../configure ${myconf} \
+ --prefix="/usr" \
+ --host="$(get_abi_CHOST ${ABI})" \
+ --libdir="/usr/$(get_libdir)" \
+ || die "./configure for ABI ${ABI} failed"
+
+ emake || die "make for ABI ${ABI} failed"
+}
+
+src_install() {
+ for ABI in $(get_install_abis); do
+ make -C abi-${ABI} install DESTDIR="${D}" || die "make install for ABI ${ABI} failed."
+ done
+
+ rm "${D}/usr/bin/cpsplay" # currently unsupported
+
+ dodoc AUTHORS ChangeLog* NEWS README* TODO
+}
+
+pkg_postinst() {
+ einfo "Use the following command to re-encode your screen captures to a"
+ einfo "file format current media players do understand:"
+ einfo
+ einfo " cpsrecode -i capture.cps -o - | mencoder - -o capture.avi \\"
+ einfo " -ovc lavc -lavcopts vcodec=xvid:autoaspect=1"
+ einfo
+ einfo "or play in-place via mplayer:"
+ einfo
+ einfo " cpsrecode -i capture.cps -o - | mplayer -demuxer y4m -"
+ einfo
+ einfo "or if use-flag theora enabled, create your ogg/theora file inplace:"
+ einfo
+ einfo " cpsrecode -i capture.cps -o capture.ogg -c theora"
+ echo
+}
+
+# vim:ai:noet:ts=4:nowrap