summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-17 05:09:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-17 05:09:40 +0000
commit7fdec0f966d885411394ca42ba938fe72ee70187 (patch)
tree9d11848dde510c9b73bd60d56ab5211158c86729 /media-libs
parentKeyword ~x86 wrt #250973 (diff)
downloadgentoo-2-7fdec0f966d885411394ca42ba938fe72ee70187.tar.gz
gentoo-2-7fdec0f966d885411394ca42ba938fe72ee70187.tar.bz2
gentoo-2-7fdec0f966d885411394ca42ba938fe72ee70187.zip
Version bump wrt #251023, thanks to Lars for reporting.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openal/ChangeLog7
-rw-r--r--media-libs/openal/openal-0.0.8-r2.ebuild4
-rw-r--r--media-libs/openal/openal-1.6.372.ebuild39
3 files changed, 47 insertions, 3 deletions
diff --git a/media-libs/openal/ChangeLog b/media-libs/openal/ChangeLog
index 1cb7c59e7565..583ceb4535c2 100644
--- a/media-libs/openal/ChangeLog
+++ b/media-libs/openal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/openal
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.95 2008/12/16 17:14:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.96 2008/12/17 05:09:40 ssuominen Exp $
+
+*openal-1.6.372 (17 Dec 2008)
+
+ 17 Dec 2008; <ssuominen@gentoo.org> +openal-1.6.372.ebuild:
+ Version bump wrt #251023, thanks to Lars for reporting.
16 Dec 2008; Brent Baude <ranger@gentoo.org> openal-1.5.304.ebuild:
Marking openal-1.5.304 ~ppc for bug 245771
diff --git a/media-libs/openal/openal-0.0.8-r2.ebuild b/media-libs/openal/openal-0.0.8-r2.ebuild
index 4871d20ec09b..f165c6c07034 100644
--- a/media-libs/openal/openal-0.0.8-r2.ebuild
+++ b/media-libs/openal/openal-0.0.8-r2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-0.0.8-r2.ebuild,v 1.7 2008/12/07 11:55:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-0.0.8-r2.ebuild,v 1.8 2008/12/17 05:09:40 ssuominen Exp $
inherit autotools eutils
DESCRIPTION="an open, vendor-neutral, cross-platform API for interactive, primarily spatialized audio"
HOMEPAGE="http://www.openal.org"
-SRC_URI="http://www.openal.org/openal_webstf/downloads/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
diff --git a/media-libs/openal/openal-1.6.372.ebuild b/media-libs/openal/openal-1.6.372.ebuild
new file mode 100644
index 000000000000..424dd0629200
--- /dev/null
+++ b/media-libs/openal/openal-1.6.372.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.6.372.ebuild,v 1.1 2008/12/17 05:09:40 ssuominen Exp $
+
+inherit eutils cmake-utils
+
+MY_P=${PN}-soft-${PV}
+
+DESCRIPTION="A software implementation of the OpenAL 3D audio API"
+HOMEPAGE="http://kcat.strangesoft.net/openal.html"
+SRC_URI="http://kcat.strangesoft.net/openal-releases/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa oss debug"
+
+DEPEND="alsa? ( media-libs/alsa-lib )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="alsoftrc.sample"
+
+src_compile() {
+ local mycmakeargs=""
+
+ use alsa || mycmakeargs="${mycmakeargs} -DALSA=OFF"
+ use oss || mycmakeargs="${mycmakeargs} -DOSS=OFF"
+ use debug && mycmakeargs="${mycmakeargs} -DCMAKE_BUILD_TYPE=Debug"
+
+ cmake-utils_src_compile
+}
+
+pkg_postinst() {
+ einfo "If you have performance problems using this library, then"
+ einfo "try add these lines to your ~/.alsoftrc config file:"
+ einfo "[alsa]"
+ einfo "mmap = off"
+}