summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-10-19 16:32:45 +0000
committerMarkus Meier <maekke@gentoo.org>2009-10-19 16:32:45 +0000
commit87fde4ca478d4f2bd442c1ff46f7ba785d86ffbb (patch)
treeb13830c4cb2bf54c0d0ed4bef9b6b193a2ec555f /media-libs
parentAdd ~ia64/~sparc wrt #283065 (diff)
downloadgentoo-2-87fde4ca478d4f2bd442c1ff46f7ba785d86ffbb.tar.gz
gentoo-2-87fde4ca478d4f2bd442c1ff46f7ba785d86ffbb.tar.bz2
gentoo-2-87fde4ca478d4f2bd442c1ff46f7ba785d86ffbb.zip
version bump, bug #289454
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lensfun/ChangeLog7
-rw-r--r--media-libs/lensfun/lensfun-0.2.4.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-libs/lensfun/ChangeLog b/media-libs/lensfun/ChangeLog
index 81f21c06d6c8..9763c51851be 100644
--- a/media-libs/lensfun/ChangeLog
+++ b/media-libs/lensfun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lensfun
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.7 2009/10/05 21:56:16 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.8 2009/10/19 16:32:45 maekke Exp $
+
+*lensfun-0.2.4 (19 Oct 2009)
+
+ 19 Oct 2009; Markus Meier <maekke@gentoo.org> +lensfun-0.2.4.ebuild:
+ version bump, bug #289454
05 Oct 2009; Mounir Lamouri <volkmar@gentoo.org> lensfun-0.2.3.ebuild:
Keywording for ppc, bug 272088
diff --git a/media-libs/lensfun/lensfun-0.2.4.ebuild b/media-libs/lensfun/lensfun-0.2.4.ebuild
new file mode 100644
index 000000000000..3a5bdd7ac142
--- /dev/null
+++ b/media-libs/lensfun/lensfun-0.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.4.ebuild,v 1.1 2009/10/19 16:32:45 maekke Exp $
+
+inherit eutils
+
+DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens
+distortions"
+HOMEPAGE="http://lensfun.berlios.de/"
+SRC_URI="mirror://berlios/lensfun/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="
+ >=dev-libs/glib-2.0
+ >=media-libs/libpng-1.0"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.5.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.2.3-as-needed.patch
+ epatch "${FILESDIR}"/${PN}-0.2.3-glibc-2.10.patch
+
+ # disable stripping, remove ricer CFLAGS
+ sed -i \
+ -e 's:-s -O3 -fomit-frame-pointer -funroll-loops::g' \
+ -e 's:GCC.LDFLAGS.release = -s:GCC.LDFLAGS.release =:g' \
+ build/mak/compiler/gcc.mak
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="--mode=debug"
+ # econf does NOT work
+ ./configure --prefix=/usr ${myconf} || die
+ emake all V=1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ # TODO remove docs if ! use doc
+}