summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-18 22:06:38 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-18 22:06:38 +0000
commit897c41bf2d055140a12a257e6836594321b64465 (patch)
tree74963c17fc4a8997a0b828eeb5b034398e712820 /media-libs
parentBug #405887: fix for newer system headers; bug #405897: bump to 1.7.18. (diff)
downloadgentoo-2-897c41bf2d055140a12a257e6836594321b64465.tar.gz
gentoo-2-897c41bf2d055140a12a257e6836594321b64465.tar.bz2
gentoo-2-897c41bf2d055140a12a257e6836594321b64465.zip
Prefer gl over gles2 as the default driver, since that's what most users would want; thanks to Rafał Mużyło.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/ChangeLog9
-rw-r--r--media-libs/cogl/cogl-1.12.0-r1.ebuild103
2 files changed, 111 insertions, 1 deletions
diff --git a/media-libs/cogl/ChangeLog b/media-libs/cogl/ChangeLog
index 271ccd5c3ee2..58d602e19dd3 100644
--- a/media-libs/cogl/ChangeLog
+++ b/media-libs/cogl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/cogl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.17 2012/12/16 22:03:51 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.18 2012/12/18 22:06:38 tetromino Exp $
+
+*cogl-1.12.0-r1 (18 Dec 2012)
+
+ 18 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +cogl-1.12.0-r1.ebuild:
+ Prefer gl over gles2 as the default driver, since that's what most users
+ would want; thanks to Rafał Mużyło.
*cogl-1.12.0 (16 Dec 2012)
diff --git a/media-libs/cogl/cogl-1.12.0-r1.ebuild b/media-libs/cogl/cogl-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..351dc284c375
--- /dev/null
+++ b/media-libs/cogl/cogl-1.12.0-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.12.0-r1.ebuild,v 1.1 2012/12/18 22:06:38 tetromino Exp $
+
+EAPI="5"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+inherit eutils clutter gnome2 multilib virtualx
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.clutter-project.org/"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0/11"
+IUSE="doc examples +introspection +opengl gles2 +pango"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~x86"
+
+# XXX: need uprof for optional profiling support
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+ x11-libs/cairo:=
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm:=
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ virtual/glu
+ virtual/opengl
+ gles2? ( media-libs/mesa[gles2] )
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.13 )
+ test? ( app-admin/eselect-opengl
+ media-libs/mesa[classic] )"
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
+
+src_prepare() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/{*.c,*.jpg}"
+ # XXX: think about kms-egl, quartz, sdl, wayland
+ # Prefer gl over gles2 if both are selected
+ G2CONF="${G2CONF}
+ --disable-examples-install
+ --disable-profile
+ --disable-maintainer-flags
+ --enable-cairo
+ --enable-gdk-pixbuf
+ $(use_enable opengl glx)
+ $(use_enable opengl gl)
+ $(use_enable gles2)
+ $(use_enable gles2 cogl-gles2)
+ $(use_enable gles2 xlib-egl-platform)
+ "$(usex gles2 --with-default-driver=$(usex opengl gl gles2 ) "")"
+ --enable-glib
+ --enable-deprecated
+ $(use_enable introspection)
+ $(use_enable pango cogl-pango)
+ $(use_enable doc gtk-doc)"
+ # Really need --enable-gtk-doc for docs
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=684731
+ epatch "${FILESDIR}/${PN}-1.12.0-fix-experimental-doc-build.patch"
+ gnome2_src_prepare
+}
+
+src_test() {
+ # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
+ # NOTE: recheck if this is needed after every mesa bump
+ if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
+ ewarn "Skipping tests because a binary OpenGL library is enabled. To"
+ ewarn "run tests for ${PN}, you need to enable the Mesa library:"
+ ewarn "# eselect opengl set xorg-x11"
+ return
+ fi
+ LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa" Xemake check
+}
+
+src_install() {
+ clutter_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libcogl.so.9
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ preserve_old_lib_notify /usr/$(get_libdir)/libcogl.so.9
+}