summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-02-02 05:34:09 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-02-02 05:34:09 +0000
commit8a1cb8219e0d80d435184ae903e6cbfdc9589d15 (patch)
tree4ed0bbf7b4be05acc1cc6f2adfcff90735bac1bb /media-libs
parentInitial version of the package. (diff)
downloadgentoo-2-8a1cb8219e0d80d435184ae903e6cbfdc9589d15.tar.gz
gentoo-2-8a1cb8219e0d80d435184ae903e6cbfdc9589d15.tar.bz2
gentoo-2-8a1cb8219e0d80d435184ae903e6cbfdc9589d15.zip
Version bump.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libdvdcss/ChangeLog7
-rw-r--r--media-libs/libdvdcss/files/digest-libdvdcss-1.2.51
-rw-r--r--media-libs/libdvdcss/libdvdcss-1.2.5.ebuild70
3 files changed, 77 insertions, 1 deletions
diff --git a/media-libs/libdvdcss/ChangeLog b/media-libs/libdvdcss/ChangeLog
index 7ef67b25b151..e80f80bd553d 100644
--- a/media-libs/libdvdcss/ChangeLog
+++ b/media-libs/libdvdcss/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for media-libs/libdvdcss
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdcss/ChangeLog,v 1.12 2002/12/13 10:59:35 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdcss/ChangeLog,v 1.13 2003/02/02 05:34:09 agenkin Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*libdvdcss-1.2.5 (01 Feb 2003)
+
+ 01 Feb 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump. Fixed homepage and download URLs.
+
*libdvdcss-1.2.4 (20 Nov 2002)
20 Nov 2002; Martin Schlemmer <azarah@gentoo.org> :
diff --git a/media-libs/libdvdcss/files/digest-libdvdcss-1.2.5 b/media-libs/libdvdcss/files/digest-libdvdcss-1.2.5
new file mode 100644
index 000000000000..2e8b6438e776
--- /dev/null
+++ b/media-libs/libdvdcss/files/digest-libdvdcss-1.2.5
@@ -0,0 +1 @@
+MD5 e5f484b1ebce9f246b8dbacfb7707f49 libdvdcss-1.2.5.tar.gz 267699
diff --git a/media-libs/libdvdcss/libdvdcss-1.2.5.ebuild b/media-libs/libdvdcss/libdvdcss-1.2.5.ebuild
new file mode 100644
index 000000000000..713806f58ba3
--- /dev/null
+++ b/media-libs/libdvdcss/libdvdcss-1.2.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdcss/libdvdcss-1.2.5.ebuild,v 1.1 2003/02/02 05:34:09 agenkin Exp $
+
+IUSE=""
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A portable abstraction library for DVD decryption"
+SRC_URI="http://developers.videolan.org/pub/videolan/libdvdcss/${PV}/${P}.tar.gz"
+HOMEPAGE="http://developers.videolan.org/pub/videolan/libdvdcss/"
+
+SLOT="1.2"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ # Dont use custom optimiziations, as it gives problems
+ # on some archs
+ unset CFLAGS
+ unset CXXFLAGS
+ econf || die
+
+ make || die
+}
+
+src_install() {
+
+ einstall || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+
+ ##
+ ## 0.0.3.* and 1.0.0 compat
+ ##
+
+ # NOTE: this should be the last code in src_install() !!!
+
+ if [ -L ${D}/usr/lib/libdvdcss.so ]
+ then
+ # on some locales the name of the file a symlink points to, is in the
+ # tenth field, and not the eleventh (bug #2908)
+ LC_ALL='C'
+ local realname="$(ls -l ${D}/usr/lib/libdvdcss.so |gawk '{print $11}')"
+ [ -z "${realname}" ] && \
+ realname="$(ls -l ${D}/usr/lib/libdvdcss.so |gawk '{print $10}')"
+ [ -z "${realname}" ] && return 0
+
+ for x in libdvdcss.so.0 libdvdcss.so.1
+ do
+ dosym ${realname} /usr/lib/${x}
+ done
+ fi
+}
+
+pkg_preinst() {
+
+ # these could cause problems if they exist from
+ # earlier builds
+ for x in libdvdcss.so.0 libdvdcss.so.1
+ do
+ if [ -f /usr/lib/${x} ] || [ -L /usr/lib/${x} ]
+ then
+ rm -f /usr/lib/${x}
+ fi
+ done
+}
+