summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-07-21 14:42:00 +0000
committerDan Armak <danarmak@gentoo.org>2001-07-21 14:42:00 +0000
commit9a3d8f3fec2ec03d89bb0a737ebd70a9f2de9412 (patch)
treea2d0b1bc76bfb62530c3cef208f0fcffb1c5efb1 /media-libs
parentmodified zsh ebuild and removed old pur-ftpd and added new updated pure-ftpd ... (diff)
downloadgentoo-2-9a3d8f3fec2ec03d89bb0a737ebd70a9f2de9412.tar.gz
gentoo-2-9a3d8f3fec2ec03d89bb0a737ebd70a9f2de9412.tar.bz2
gentoo-2-9a3d8f3fec2ec03d89bb0a737ebd70a9f2de9412.zip
Two multimedia libs used by many games. Needed for some things I'll be adding soon.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/allegro/allegro-3.9.37.ebuild108
-rw-r--r--media-libs/allegro/files/digest-allegro-3.9.371
-rw-r--r--media-libs/plib/files/digest-plib-1.4.11
-rw-r--r--media-libs/plib/plib-1.4.1.ebuild28
4 files changed, 138 insertions, 0 deletions
diff --git a/media-libs/allegro/allegro-3.9.37.ebuild b/media-libs/allegro/allegro-3.9.37.ebuild
new file mode 100644
index 000000000000..cdccf69cdecf
--- /dev/null
+++ b/media-libs/allegro/allegro-3.9.37.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gantoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-3.9.37.ebuild,v 1.1 2001/07/21 14:42:00 danarmak Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Allegro is a cross-platform multimedia library"
+
+SRC_URI="http://prdownloads.sourceforge.net/alleg/${P}.tar.gz"
+
+HOMEPAGE="http://alleg.sourceforge.net/allegro/"
+
+DEPEND="X? ( virtual/x11 )"
+
+src_compile() {
+
+ confopts="--infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}"
+
+ # Static and shared libs can be build at the same time
+ confopts="${confopts} --enable-shared --enable-static"
+
+ # Always enable Linux console support and accompanying drivers
+ confopts="${confopts} --enable-linux --enable-vga"
+
+ # if USE static defined, use static library as default to link with
+ if [ "`use static`" ]
+ then
+ confopts="${confopts} --enable-staticprog"
+ fi
+
+ # Pentium optimizations
+ if [ ${CHOST} = "i586-pc-linux-gnu" -o ${CHOST} = "i686-pc-linux-gnu" ]
+ then
+ confopts="${confopts} --enable-pentiumopts"
+ fi
+
+ # Use MMX instructions
+ if [ "`use mmx`" ]
+ then
+ confopts="${confopts} --enable-mmx"
+ else
+ confopts="${confopts} --enable-mmx=no"
+ fi
+
+ # Have OSS support
+ if [ "`use oss`" ] ; then
+ confopts="${confopts} --enable-ossdigi --enable-ossmidi"
+ else
+ confopts="${confopts} --disable-ossdigi --disable-ossmidi"
+ fi
+
+ # Have ALSA support
+ if [ "`use alsa`" ] ; then
+ confopts="${confopts} --enable-alsadigi --enable-alsamidi"
+ else
+ confopts="${confopts} --disable-alsadigi --disable-alsamidi"
+ fi
+
+ # Have ESD support
+ if [ "`use esd`" ] ; then
+ confopts="${confopts} --enable-esddigi"
+ else
+ confopts="${confopts} --disable-esddigi"
+ fi
+
+ # Have X11 support
+ if [ "`use X`" ] ; then
+ confopts="${confopts} --with-x --enable-xwin-shm --enable-xwin-vidmode --enable-xwin-dga --enable-xwin-dga2"
+ else
+ confopts="${confopts} --without-x --disable-xwin-shm --disable-xwin-vidmode --disable-xwin-dga --disable-xwin-dga2"
+ fi
+
+ # Have SVGALib support
+ if [ "`use svga`" ] ; then
+ confopts="${confopts} --enable-svgalib"
+ else
+ confopts="${confopts} --disable-svgalib"
+ fi
+
+ # Have fbcon support
+ if [ "`use fbcon`" ] ; then
+ confopts="${confopts} --enable-fbcon"
+ else
+ confopts="${confopts} --disable-fbcon"
+ fi
+
+ # --------------
+
+ try ./configure ${confopts}
+
+ # emake doesn't work
+ try make
+
+ try make docs-ps docs-dvi
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr infodir=${D}/usr/share/info mandir=${D}/usr/share/man install install-gzipped-man install-gzipped-info
+
+ cd ${S}
+ # Different format versions of the Allegro documentation
+ dodoc allegro.dvi allegro.ps allegro.txt
+
+}
+
diff --git a/media-libs/allegro/files/digest-allegro-3.9.37 b/media-libs/allegro/files/digest-allegro-3.9.37
new file mode 100644
index 000000000000..b87d7f7904b1
--- /dev/null
+++ b/media-libs/allegro/files/digest-allegro-3.9.37
@@ -0,0 +1 @@
+MD5 3f930cd6277cf12397488dec0e5bb4d9 allegro-3.9.37.tar.gz
diff --git a/media-libs/plib/files/digest-plib-1.4.1 b/media-libs/plib/files/digest-plib-1.4.1
new file mode 100644
index 000000000000..4a56b187d05b
--- /dev/null
+++ b/media-libs/plib/files/digest-plib-1.4.1
@@ -0,0 +1 @@
+MD5 7db4037efad88cc1d765df00236b1e63 plib-1.4.1.tar.gz
diff --git a/media-libs/plib/plib-1.4.1.ebuild b/media-libs/plib/plib-1.4.1.ebuild
new file mode 100644
index 000000000000..8ba8f1345c43
--- /dev/null
+++ b/media-libs/plib/plib-1.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/plib/plib-1.4.1.ebuild,v 1.1 2001/07/21 14:42:00 danarmak Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="http://plib.sourceforge.net/dist/${P}.tar.gz"
+
+HOMEPAGE="http://plib.sourceforge.net"
+DESCRIPTION="plib: a multimedia library used by many games"
+
+DEPEND="virtual/x11 virtual/glut"
+
+src_compile() {
+
+ confopts=" --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}"
+
+ try ./configure ${confopts}
+
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+}