summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-28 21:58:18 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-28 21:58:18 +0000
commita42945c1b25447159839ea1a710808fda3227958 (patch)
tree012cacaabce5e50eb7fe5c178a66addd4cbebff6 /media-libs
parentFix for gcc-4.3. (diff)
downloadgentoo-2-a42945c1b25447159839ea1a710808fda3227958.tar.gz
gentoo-2-a42945c1b25447159839ea1a710808fda3227958.tar.bz2
gentoo-2-a42945c1b25447159839ea1a710808fda3227958.zip
Fix this ebuild so openexr_viewers gets the right libs, etc. for compilation.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openexr_ctl/ChangeLog9
-rw-r--r--media-libs/openexr_ctl/files/openexr_ctl-1.0.1-pkgconfig.patch12
-rw-r--r--media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild34
3 files changed, 54 insertions, 1 deletions
diff --git a/media-libs/openexr_ctl/ChangeLog b/media-libs/openexr_ctl/ChangeLog
index 02c3dee32e32..a16eb5f3c223 100644
--- a/media-libs/openexr_ctl/ChangeLog
+++ b/media-libs/openexr_ctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/openexr_ctl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/ChangeLog,v 1.14 2008/06/28 21:35:35 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/ChangeLog,v 1.15 2008/06/28 21:58:18 loki_val Exp $
+
+*openexr_ctl-1.0.1-r1 (28 Jun 2008)
+
+ 28 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/openexr_ctl-1.0.1-pkgconfig.patch, +openexr_ctl-1.0.1-r1.ebuild:
+ Fix this ebuild so openexr_viewers gets the right libs, etc. for
+ compilation.
28 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+files/openexr_ctl-1.0.1-configure_gcc43.patch,
diff --git a/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-pkgconfig.patch b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-pkgconfig.patch
new file mode 100644
index 000000000000..e35bdfc11a5c
--- /dev/null
+++ b/media-libs/openexr_ctl/files/openexr_ctl-1.0.1-pkgconfig.patch
@@ -0,0 +1,12 @@
+diff -up openexr_ctl-1.0.1/OpenEXR_CTL.pc.in.pkgconfig openexr_ctl-1.0.1/OpenEXR_CTL.pc.in
+--- openexr_ctl-1.0.1/OpenEXR_CTL.pc.in.pkgconfig 2008-01-09 15:17:58.000000000 +0100
++++ openexr_ctl-1.0.1/OpenEXR_CTL.pc.in 2008-01-09 15:24:52.000000000 +0100
+@@ -7,5 +7,6 @@ OpenEXR_includedir=@includedir@/OpenEXR
+ Name: OpenEXR_CTL
+ Description: Simplified OpenEXR interface to CTL
+ Version: @OPENEXR_CTL_VERSION@
+-Libs: -L${libdir} -lIlmImfCtl @OPENEXR_LDFLAGS@ @CTL_LDFLAGS@
+-Cflags: @CTL_CXXFLAGS_PC@ @OPENEXR_CXXFLAGS@ -I${OpenEXR_includedir}
++Requires: CTL , OpenEXR
++Libs: -L${libdir} -lIlmImfCtl
++Cflags: -I${OpenEXR_includedir}
diff --git a/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild b/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..4c4bce3bc684
--- /dev/null
+++ b/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr_ctl/openexr_ctl-1.0.1-r1.ebuild,v 1.1 2008/06/28 21:58:18 loki_val Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="OpenEXR CTL libraries"
+HOMEPAGE="http://sourceforge.net/projects/ampasctl"
+SRC_URI="mirror://sourceforge/ampasctl/${P}.tar.gz"
+
+LICENSE="AMPAS"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/ilmbase
+ media-libs/openexr
+ media-libs/ctl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-configure_gcc43.patch
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}