summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-30 20:27:40 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-30 20:27:40 +0000
commita94b33fdc73f83da8ac118725bbf3a15073ae6c9 (patch)
treeb0cb3b63c24bb1110ef455a5f62ad0a89256fa5f /media-libs
parentIntroduce the initial version. (diff)
downloadgentoo-2-a94b33fdc73f83da8ac118725bbf3a15073ae6c9.tar.gz
gentoo-2-a94b33fdc73f83da8ac118725bbf3a15073ae6c9.tar.bz2
gentoo-2-a94b33fdc73f83da8ac118725bbf3a15073ae6c9.zip
fix various multilib failures wrt #514486
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/ChangeLog8
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.15-caca.patch26
-rw-r--r--media-libs/libsdl/libsdl-1.2.15-r7.ebuild142
3 files changed, 175 insertions, 1 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 91f6163b2181..7844c9bad181 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libsdl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.219 2014/06/25 11:03:07 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.220 2014/06/30 20:27:40 hasufell Exp $
+
+*libsdl-1.2.15-r7 (30 Jun 2014)
+
+ 30 Jun 2014; Julian Ospald <hasufell@gentoo.org> +libsdl-1.2.15-r7.ebuild,
+ +files/libsdl-1.2.15-caca.patch:
+ fix various multilib failures wrt #514486
25 Jun 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
-files/libsdl-1.2.13-sdl-config.patch, -files/libsdl-1.2.14-click.patch,
diff --git a/media-libs/libsdl/files/libsdl-1.2.15-caca.patch b/media-libs/libsdl/files/libsdl-1.2.15-caca.patch
new file mode 100644
index 000000000000..faf5ae132a96
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.15-caca.patch
@@ -0,0 +1,26 @@
+--- SDL-1.2.15/configure.in
++++ SDL-1.2.15/configure.in
+@@ -1507,11 +1507,10 @@
+ , enable_video_caca=no)
+ if test x$enable_video = xyes -a x$enable_video_caca = xyes; then
+ video_caca=no
+- AC_PATH_PROG(CACACONFIG, caca-config, no)
+- if test x$CACACONFIG != xno; then
++ PKG_PROG_PKG_CONFIG([0.20])
++ PKG_CHECK_MODULES(CACA, caca, has_caca_pc=yes, has_caca_pc=no])
++ if test x$has_caca_pc == xyes; then
+ AC_MSG_CHECKING(for libcaca support)
+- CACA_CFLAGS=`$CACACONFIG --cflags`
+- CACA_LDFLAGS=`$CACACONFIG --libs`
+ save_CFLAGS="$CFLAGS"
+ AC_TRY_COMPILE([
+ #include <caca.h>
+@@ -1524,7 +1523,7 @@
+ if test x$video_caca = xyes; then
+ AC_DEFINE(SDL_VIDEO_DRIVER_CACA)
+ EXTRA_CFLAGS="$EXTRA_CFLAGS $CACA_CFLAGS"
+- EXTRA_LDFLAGS="$EXTRA_LDFLAGS $CACA_LDFLAGS"
++ EXTRA_LDFLAGS="$EXTRA_LDFLAGS $CACA_LIBS"
+ SOURCES="$SOURCES $srcdir/src/video/caca/*.c"
+ fi
+ fi
diff --git a/media-libs/libsdl/libsdl-1.2.15-r7.ebuild b/media-libs/libsdl/libsdl-1.2.15-r7.ebuild
new file mode 100644
index 000000000000..ed5df307c5b1
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.15-r7.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.15-r7.ebuild,v 1.1 2014/06/30 20:27:40 hasufell Exp $
+
+EAPI=5
+inherit autotools flag-o-matic multilib toolchain-funcs eutils multilib-minimal
+
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="http://www.libsdl.org/"
+SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+# WARNING:
+# If you turn on the custom-cflags use flag in USE and something breaks,
+# you pick up the pieces. Be prepared for bug reports to be marked INVALID.
+IUSE="oss alsa nas X dga xv xinerama fbcon tslib aalib opengl libcaca +sound +video +joystick custom-cflags pulseaudio static-libs"
+
+RDEPEND="
+ abi_x86_32? (
+ !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ !<=app-emulation/emul-linux-x86-sdl-20140406
+ )
+ sound? ( >=media-libs/audiofile-0.3.5[${MULTILIB_USEDEP}] )
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ nas? (
+ >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ )
+ aalib? ( >=media-libs/aalib-1.4_rc5-r6[${MULTILIB_USEDEP}] )
+ libcaca? ( >=media-libs/libcaca-0.99_beta18-r1[${MULTILIB_USEDEP}] )
+ opengl? (
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ )
+ tslib? ( >=x11-libs/tslib-1.0-r3[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ nas? (
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ )
+ x86? ( || ( >=dev-lang/yasm-0.6.0 >=dev-lang/nasm-0.98.39-r3 ) )"
+
+S=${WORKDIR}/SDL-${PV}
+
+pkg_setup() {
+ if use custom-cflags ; then
+ ewarn "Since you've chosen to use possibly unsafe CFLAGS,"
+ ewarn "don't bother filing libsdl-related bugs until trying to remerge"
+ ewarn "libsdl without the custom-cflags use flag in USE."
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-sdl-config.patch \
+ "${FILESDIR}"/${P}-resizing.patch \
+ "${FILESDIR}"/${P}-joystick.patch \
+ "${FILESDIR}"/${P}-gamma.patch \
+ "${FILESDIR}"/${P}-const-xdata32.patch \
+ "${FILESDIR}"/${P}-caca.patch
+ AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=
+ if use !x86 ; then
+ myconf="${myconf} --disable-nasm"
+ else
+ myconf="${myconf} --enable-nasm"
+ fi
+ use custom-cflags || strip-flags
+ use sound || myconf="${myconf} --disable-audio"
+ use video \
+ && myconf="${myconf} --enable-video-dummy" \
+ || myconf="${myconf} --disable-video"
+ use joystick || myconf="${myconf} --disable-joystick"
+
+ ECONF_SOURCE="${S}" econf \
+ --disable-rpath \
+ --disable-arts \
+ --disable-esd \
+ --enable-events \
+ --enable-cdrom \
+ --enable-threads \
+ --enable-timers \
+ --enable-file \
+ --enable-cpuinfo \
+ --disable-alsa-shared \
+ --disable-esd-shared \
+ --disable-pulseaudio-shared \
+ --disable-arts-shared \
+ --disable-nas-shared \
+ --disable-osmesa-shared \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable pulseaudio) \
+ $(use_enable nas) \
+ $(use_enable X video-x11) \
+ $(use_enable dga) \
+ $(use_enable xv video-x11-xv) \
+ $(use_enable xinerama video-x11-xinerama) \
+ $(use_enable X video-x11-xrandr) \
+ $(use_enable dga video-dga) \
+ $(use_enable fbcon video-fbcon) \
+ --disable-video-ggi \
+ --disable-video-svga \
+ $(use_enable aalib video-aalib) \
+ $(use_enable libcaca video-caca) \
+ $(use_enable opengl video-opengl) \
+ --disable-video-ps3 \
+ $(use_enable tslib input-tslib) \
+ $(use_with X x) \
+ $(use_enable static-libs static) \
+ --disable-video-x11-xme \
+ --disable-video-directfb \
+ ${myconf}
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files --all
+ dodoc BUGS CREDITS README README-SDL.txt README.HG TODO WhatsNew
+ dohtml -r ./
+}