summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2014-09-01 09:29:28 +0000
committerThomas Kahle <tomka@gentoo.org>2014-09-01 09:29:28 +0000
commitae205bd215ba98d0c06aac2b199ced653cea64d2 (patch)
tree8073b5e7bdb84169ce4674dfcaa6ce7d61125e7c /media-libs
parentcorrect typo (diff)
downloadgentoo-2-ae205bd215ba98d0c06aac2b199ced653cea64d2.tar.gz
gentoo-2-ae205bd215ba98d0c06aac2b199ced653cea64d2.tar.bz2
gentoo-2-ae205bd215ba98d0c06aac2b199ced653cea64d2.zip
EAPI bump, fix bug 518540 for real
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 565C32BC)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/leptonica/ChangeLog8
-rw-r--r--media-libs/leptonica/files/leptonica-1.71-fix-openjpeg-test.patch15
-rw-r--r--media-libs/leptonica/leptonica-1.71-r1.ebuild70
3 files changed, 92 insertions, 1 deletions
diff --git a/media-libs/leptonica/ChangeLog b/media-libs/leptonica/ChangeLog
index c36996d83b6a..c07bd8d3b47d 100644
--- a/media-libs/leptonica/ChangeLog
+++ b/media-libs/leptonica/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/leptonica
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/leptonica/ChangeLog,v 1.22 2014/08/30 17:54:58 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/leptonica/ChangeLog,v 1.23 2014/09/01 09:29:28 tomka Exp $
+
+*leptonica-1.71-r1 (01 Sep 2014)
+
+ 01 Sep 2014; Thomas Kahle <tomka@gentoo.org>
+ +files/leptonica-1.71-fix-openjpeg-test.patch, +leptonica-1.71-r1.ebuild:
+ EAPI bump, fix bug 518540 for real
30 Aug 2014; Chema Alonso <nimiux@gentoo.org> leptonica-1.70.ebuild:
Stable for amd64 wrt bug #513376
diff --git a/media-libs/leptonica/files/leptonica-1.71-fix-openjpeg-test.patch b/media-libs/leptonica/files/leptonica-1.71-fix-openjpeg-test.patch
new file mode 100644
index 000000000000..f7d18a24adce
--- /dev/null
+++ b/media-libs/leptonica/files/leptonica-1.71-fix-openjpeg-test.patch
@@ -0,0 +1,15 @@
+--- leptonica-1.71.orig/configure.ac 2014-08-31 14:33:16.834598973 +0200
++++ leptonica-1.71/configure.ac 2014-09-01 10:56:59.394975447 +0200
+@@ -78,10 +78,10 @@
+ )
+ )
+
+-AS_IF([test "x$with_libopenjp2" != xno],
++AS_IF([test "x$with_libopenjpeg" != xno],
+ AC_CHECK_LIB([openjp2], [opj_create_decompress],
+ AC_DEFINE([HAVE_LIBJP2K], 1, [Define to 1 if you have libopenjp2.]) AC_SUBST([LIBJP2K_LIBS], [-lopenjp2]),
+- AS_IF([test "x$with_libopenjp2" = xyes], AC_MSG_ERROR([libopenjp2 support requested but library not found]))
++ AS_IF([test "x$with_libopenjpeg" = xyes], AC_MSG_ERROR([libopenjp2 support requested but library not found]))
+ )
+ )
+
diff --git a/media-libs/leptonica/leptonica-1.71-r1.ebuild b/media-libs/leptonica/leptonica-1.71-r1.ebuild
new file mode 100644
index 000000000000..8610bc3748fa
--- /dev/null
+++ b/media-libs/leptonica/leptonica-1.71-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/leptonica/leptonica-1.71-r1.ebuild,v 1.1 2014/09/01 09:29:28 tomka Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="1"
+inherit eutils autotools-utils
+
+DESCRIPTION="C library for image processing and analysis"
+HOMEPAGE="http://code.google.com/p/leptonica/"
+SRC_URI="http://www.leptonica.com/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gif jpeg jpeg2k png tiff webp utils zlib static-libs"
+
+# N.b. Tests need at least tiff, jpeg and maybe others to work
+DEPEND="gif? ( media-libs/giflib )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ png? ( media-libs/libpng
+ sys-libs/zlib
+ )
+ tiff? ( media-libs/tiff )
+ webp? ( media-libs/libwebp )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README version-notes )
+PATCHES=( "${FILESDIR}"/"${P}"-fix-openjpeg-test.patch )
+
+src_prepare() {
+ if has_version "<media-libs/openjpeg-2.1" ; then
+ epatch "${FILESDIR}"/"${P}"-openjpeg-2.0.patch
+ fi
+
+ # unhtmlize docs
+ local X
+ for X in ${DOCS[@]}; do
+ awk '/<\/pre>/{s--} {if (s) print $0} /<pre>/{s++}' \
+ "${X}.html" > "${X}" || die 'awk failed'
+ rm -f -- "${X}.html"
+ done
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # $(use_with webp libwebp) -> unknown
+ # so use-flag just for pulling dependencies
+ # zlib handling see bug 454890
+ local myeconfargs=(
+ $(use_with gif giflib)
+ $(use_with jpeg)
+ $(use_with jpeg2k libopenjpeg)
+ $(use_with png libpng)
+ $(use_with tiff libtiff)
+ $(use_enable utils programs)
+ $(use_enable static-libs static)
+ )
+ # libpng requires zlib:
+ if use png && ! use zlib ; then
+ # Ignore users non-sensical choice of -zlib
+ myeconfargs+=("--with-zlib")
+ else
+ myeconfargs+=( $(use_with zlib) )
+ fi
+ autotools-utils_src_configure
+}