summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-10 22:25:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-10 22:25:39 +0000
commitc84e31ea3d1215b8c707f9d363a3fb0669d32f21 (patch)
treee6f5cc1abdef8e7ce175d256091c65bc893f74aa /media-libs
parentnew revision featuring fribidi and libcdio{,-paranoia} conversion. Keep libcd... (diff)
downloadgentoo-2-c84e31ea3d1215b8c707f9d363a3fb0669d32f21.tar.gz
gentoo-2-c84e31ea3d1215b8c707f9d363a3fb0669d32f21.tar.bz2
gentoo-2-c84e31ea3d1215b8c707f9d363a3fb0669d32f21.zip
convert to multilib
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gavl/ChangeLog7
-rw-r--r--media-libs/gavl/gavl-1.4.0-r1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/media-libs/gavl/ChangeLog b/media-libs/gavl/ChangeLog
index 0958a14e6ca2..e3c87b2c8844 100644
--- a/media-libs/gavl/ChangeLog
+++ b/media-libs/gavl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gavl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gavl/ChangeLog,v 1.24 2013/05/15 11:28:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gavl/ChangeLog,v 1.25 2013/08/10 22:25:38 aballier Exp $
+
+*gavl-1.4.0-r1 (10 Aug 2013)
+
+ 10 Aug 2013; Alexis Ballier <aballier@gentoo.org> +gavl-1.4.0-r1.ebuild:
+ convert to multilib
15 May 2013; Samuli Suominen <ssuominen@gentoo.org> gavl-1.2.0.ebuild:
Pull in virtual/pkgconfig (at least for now) because of how
diff --git a/media-libs/gavl/gavl-1.4.0-r1.ebuild b/media-libs/gavl/gavl-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..8d1a0316d44a
--- /dev/null
+++ b/media-libs/gavl/gavl-1.4.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gavl/gavl-1.4.0-r1.ebuild,v 1.1 2013/08/10 22:25:39 aballier Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-multilib
+
+DESCRIPTION="library for handling uncompressed audio and video data"
+HOMEPAGE="http://gmerlin.sourceforge.net"
+SRC_URI="mirror://sourceforge/gmerlin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ # AC_CONFIG_HEADERS, bug #467736
+ sed -i \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e 's:-mfpmath=387::g' \
+ -e 's:-O3 -funroll-all-loops -fomit-frame-pointer -ffast-math::g' \
+ -e '/LDFLAGS=/d' \
+ configure.ac || die
+
+ export AT_M4DIR="m4"
+
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ # --disable-libpng because it's only used for tests
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}/html
+ --disable-libpng
+ $(use_with doc doxygen)
+ --without-cpuflags
+ )
+
+ autotools-multilib_src_configure
+}