summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Walls <malverian@gentoo.org>2003-03-21 05:01:50 +0000
committerPhilip Walls <malverian@gentoo.org>2003-03-21 05:01:50 +0000
commitc947eaa10697deeafe371e0688da1b358e28cc7b (patch)
tree855c5b1b23bba57933704899347220e17d68efee /media-libs
parentversion bump to 1.0.0 (diff)
downloadgentoo-2-c947eaa10697deeafe371e0688da1b358e28cc7b.tar.gz
gentoo-2-c947eaa10697deeafe371e0688da1b358e28cc7b.tar.bz2
gentoo-2-c947eaa10697deeafe371e0688da1b358e28cc7b.zip
version bump to sdl-mixer-1.2.5
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/sdl-mixer/ChangeLog11
-rw-r--r--media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.51
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.5.ebuild40
3 files changed, 50 insertions, 2 deletions
diff --git a/media-libs/sdl-mixer/ChangeLog b/media-libs/sdl-mixer/ChangeLog
index 8506f8bfff5f..4fca9d6a27f1 100644
--- a/media-libs/sdl-mixer/ChangeLog
+++ b/media-libs/sdl-mixer/ChangeLog
@@ -1,14 +1,21 @@
# ChangeLog for media-libs/sdl-mixer
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.9 2003/02/12 07:16:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.10 2003/03/21 05:01:50 malverian Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*sdl-mixer-1.2.5 (19 Mar 2003)
+
+ 19 Mar 2003; Philip Walls <malverian@gentoo.org> sdl-mixer-1.2.5.ebuild
+ digest-sdl-mixer-1.2.5 :
+
+ Version bump.
*sdl-mixer-1.2.4 (08 Jul 2002)
15 Dec 2002; Bjoern Brauel <bjb@gentoo.org> sdl-mixer-1.2.4.ebuild :
Add alpha to KEYWORDS
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
02 Aug 2002; mark Guertin <gerk@gentoo.org> sdl-mixer-1.2.4.ebuild :
Added ppc to keywords
diff --git a/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.5 b/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.5
new file mode 100644
index 000000000000..4363805f47b0
--- /dev/null
+++ b/media-libs/sdl-mixer/files/digest-sdl-mixer-1.2.5
@@ -0,0 +1 @@
+MD5 f26d4e4625f00517203e32bd06fbc5d8 SDL_mixer-1.2.5.tar.gz 936765
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.5.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.5.ebuild
new file mode 100644
index 000000000000..fd49e34f6215
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.5.ebuild,v 1.1 2003/03/21 05:01:50 malverian Exp $
+
+IUSE="mpeg mikmod oggvorbis"
+
+MY_P="${P/sdl-/SDL_}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/index.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=media-libs/libsdl-1.2.5
+ >=media-libs/smpeg-0.4.4-r1
+ mikmod? ( >=media-libs/libmikmod-3.1.10 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
+
+
+src_compile() {
+
+ local myconf
+
+ use mikmod || myconf="${myconf} --disable-mod"
+ use mpeg || myconf="${myconf} --disable-music-mp3"
+ use oggvorbis || myconf="${myconf} --disable-music-ogg"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc CHANGES COPYING README
+}