summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-04 09:15:48 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-04 09:15:48 +0000
commitd7aeb611b22f02123404bb43494b3f3d1bac9462 (patch)
tree7762fa5475067c50f1ad3113d6f54e584b3581c4 /media-libs
parentia64 stable, bug #528242 by Émeric Maschino (diff)
downloadgentoo-2-d7aeb611b22f02123404bb43494b3f3d1bac9462.tar.gz
gentoo-2-d7aeb611b22f02123404bb43494b3f3d1bac9462.tar.bz2
gentoo-2-d7aeb611b22f02123404bb43494b3f3d1bac9462.zip
Version bump. Bug #538298.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libvisio/ChangeLog7
-rw-r--r--media-libs/libvisio/libvisio-0.1.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/media-libs/libvisio/ChangeLog b/media-libs/libvisio/ChangeLog
index e02ec8c39214..983b23606b26 100644
--- a/media-libs/libvisio/ChangeLog
+++ b/media-libs/libvisio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libvisio
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisio/ChangeLog,v 1.59 2015/02/02 14:46:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisio/ChangeLog,v 1.60 2015/02/04 09:15:48 mgorny Exp $
+
+*libvisio-0.1.1 (04 Feb 2015)
+
+ 04 Feb 2015; Michał Górny <mgorny@gentoo.org> +libvisio-0.1.1.ebuild:
+ Version bump. Bug #538298.
02 Feb 2015; Jeroen Roovers <jer@gentoo.org> libvisio-0.1.0.ebuild:
Marked ~hppa (bug #538520).
diff --git a/media-libs/libvisio/libvisio-0.1.1.ebuild b/media-libs/libvisio/libvisio-0.1.1.ebuild
new file mode 100644
index 000000000000..c69de22c2b79
--- /dev/null
+++ b/media-libs/libvisio/libvisio-0.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisio/libvisio-0.1.1.ebuild,v 1.1 2015/02/04 09:15:48 mgorny Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ dev-util/gperf
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}