summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-20 22:28:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-20 22:28:22 +0000
commitde19a61bba40f9143baf6e1d1a1ec0093746a539 (patch)
tree26a6b943c8aa3967067d8c886d0dd89f4404cf82 /media-libs
parentold (diff)
downloadgentoo-2-de19a61bba40f9143baf6e1d1a1ec0093746a539.tar.gz
gentoo-2-de19a61bba40f9143baf6e1d1a1ec0093746a539.tar.bz2
gentoo-2-de19a61bba40f9143baf6e1d1a1ec0093746a539.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/tiff/ChangeLog7
-rw-r--r--media-libs/tiff/tiff-3.9.4.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/media-libs/tiff/ChangeLog b/media-libs/tiff/ChangeLog
index fb714c0093a4..a6a47d388fc0 100644
--- a/media-libs/tiff/ChangeLog
+++ b/media-libs/tiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/tiff
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/ChangeLog,v 1.152 2010/05/12 03:38:15 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/ChangeLog,v 1.153 2010/06/20 22:28:22 ssuominen Exp $
+
+*tiff-3.9.4 (20 Jun 2010)
+
+ 20 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> +tiff-3.9.4.ebuild:
+ Version bump.
*tiff-4.0.0_beta5 (12 May 2010)
diff --git a/media-libs/tiff/tiff-3.9.4.ebuild b/media-libs/tiff/tiff-3.9.4.ebuild
new file mode 100644
index 000000000000..79777923b4f5
--- /dev/null
+++ b/media-libs/tiff/tiff-3.9.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-3.9.4.ebuild,v 1.1 2010/06/20 22:28:22 ssuominen Exp $
+
+EAPI=3
+inherit libtool
+
+DESCRIPTION="Library for manipulation of TIFF (Tag Image File Format) images"
+HOMEPAGE="http://www.remotesensing.org/libtiff/"
+SRC_URI="ftp://ftp.remotesensing.org/pub/libtiff/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="jpeg jbig +cxx zlib"
+
+DEPEND="jpeg? ( >=media-libs/jpeg-6b:0 )
+ jbig? ( media-libs/jbigkit )
+ zlib? ( sys-libs/zlib )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable cxx) \
+ $(use_enable zlib) \
+ $(use_enable jpeg) \
+ $(use_enable jbig) \
+ --without-x \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+}
+
+pkg_postinst() {
+ if use jbig; then
+ echo
+ elog "JBIG support is intended for Hylafax fax compression, so we"
+ elog "really need more feedback in other areas (most testing has"
+ elog "been done with fax). Be sure to recompile anything linked"
+ elog "against tiff if you rebuild it with jbig support."
+ echo
+ fi
+}