summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-09 18:52:30 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-09 18:52:30 +0000
commite72ad773fd36c8aa219256ed640ab9982e2afe37 (patch)
tree0e3be0e7fc182a700abc37f027a12b8e078d909f /media-libs
parentVersion bump #486894 (diff)
downloadgentoo-2-e72ad773fd36c8aa219256ed640ab9982e2afe37.tar.gz
gentoo-2-e72ad773fd36c8aa219256ed640ab9982e2afe37.tar.bz2
gentoo-2-e72ad773fd36c8aa219256ed640ab9982e2afe37.zip
version bump wrt #486500
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mediastreamer/ChangeLog10
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.9.0-libav9.patch120
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.9.0-underlinking.patch57
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.9.0-v4l-automagic.patch55
-rw-r--r--media-libs/mediastreamer/mediastreamer-2.9.0.ebuild157
-rw-r--r--media-libs/mediastreamer/metadata.xml13
6 files changed, 410 insertions, 2 deletions
diff --git a/media-libs/mediastreamer/ChangeLog b/media-libs/mediastreamer/ChangeLog
index 30cacc66eacd..88ed063c845e 100644
--- a/media-libs/mediastreamer/ChangeLog
+++ b/media-libs/mediastreamer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/mediastreamer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/ChangeLog,v 1.69 2013/06/29 19:23:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/ChangeLog,v 1.70 2013/10/09 18:52:30 hasufell Exp $
+
+*mediastreamer-2.9.0 (09 Oct 2013)
+
+ 09 Oct 2013; Julian Ospald <hasufell@gentoo.org> +mediastreamer-2.9.0.ebuild,
+ +files/mediastreamer-2.9.0-libav9.patch,
+ +files/mediastreamer-2.9.0-underlinking.patch,
+ +files/mediastreamer-2.9.0-v4l-automagic.patch, metadata.xml:
+ version bump wrt #486500
29 Jun 2013; Agostino Sarubbo <ago@gentoo.org> mediastreamer-2.8.2.ebuild:
Stable for ppc64, wrt bug #464536
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.9.0-libav9.patch b/media-libs/mediastreamer/files/mediastreamer-2.9.0-libav9.patch
new file mode 100644
index 000000000000..078f360b3382
--- /dev/null
+++ b/media-libs/mediastreamer/files/mediastreamer-2.9.0-libav9.patch
@@ -0,0 +1,120 @@
+diff --git a/src/videofilters/h264dec.c b/src/videofilters/h264dec.c
+index 38881c1..f306723 100644
+--- a/src/videofilters/h264dec.c
++++ b/src/videofilters/h264dec.c
+@@ -58,10 +58,10 @@ static void dec_open(DecData *d){
+ int error;
+ codec=avcodec_find_decoder(CODEC_ID_H264);
+ if (codec==NULL) ms_fatal("Could not find H264 decoder in ffmpeg.");
+- avcodec_get_context_defaults(&d->av_context);
+- error=avcodec_open(&d->av_context,codec);
++ avcodec_get_context_defaults3(&d->av_context, NULL);
++ error=avcodec_open2(&d->av_context,codec, NULL);
+ if (error!=0){
+- ms_fatal("avcodec_open() failed.");
++ ms_fatal("avcodec_open2() failed.");
+ }
+ }
+
+diff --git a/src/videofilters/jpegwriter.c b/src/videofilters/jpegwriter.c
+index 891f618..96f5d7f 100644
+--- a/src/videofilters/jpegwriter.c
++++ b/src/videofilters/jpegwriter.c
+@@ -90,7 +90,7 @@ static void jpg_process(MSFilter *f){
+ mblk_t *jpegm;
+ struct SwsContext *sws_ctx;
+
+- AVCodecContext *avctx=avcodec_alloc_context();
++ AVCodecContext *avctx=avcodec_alloc_context3(NULL);
+
+ avctx->width=yuvbuf.w;
+ avctx->height=yuvbuf.h;
+@@ -98,9 +98,9 @@ static void jpg_process(MSFilter *f){
+ avctx->time_base.den =1;
+ avctx->pix_fmt=PIX_FMT_YUVJ420P;
+
+- error=avcodec_open(avctx,s->codec);
++ error=avcodec_open2(avctx,s->codec,NULL);
+ if (error!=0) {
+- ms_error("avcodec_open() failed: %i",error);
++ ms_error("avcodec_open2() failed: %i",error);
+ cleanup(s,NULL);
+ av_free(avctx);
+ return;
+diff --git a/src/videofilters/nowebcam.c b/src/videofilters/nowebcam.c
+index 60e3853..329c453 100644
+--- a/src/videofilters/nowebcam.c
++++ b/src/videofilters/nowebcam.c
+@@ -68,9 +68,9 @@ static mblk_t *jpeg2yuv(uint8_t *jpgbuf, int bufsize, MSVideoSize *reqsize){
+ return NULL;
+ }
+
+- avcodec_get_context_defaults(&av_context);
+- if (avcodec_open(&av_context,codec)<0){
+- ms_error("jpeg2yuv: avcodec_open failed");
++ avcodec_get_context_defaults3(&av_context, NULL);
++ if (avcodec_open2(&av_context,codec,NULL)<0){
++ ms_error("jpeg2yuv: avcodec_open2 failed");
+ return NULL;
+ }
+ av_init_packet(&pkt);
+diff --git a/src/videofilters/videodec.c b/src/videofilters/videodec.c
+index 494debf..c52e207 100644
+--- a/src/videofilters/videodec.c
++++ b/src/videofilters/videodec.c
+@@ -53,7 +53,7 @@ static void dec_init(MSFilter *f, enum CodecID cid){
+ DecState *s=(DecState *)ms_new0(DecState,1);
+ ms_ffmpeg_check_init();
+
+- avcodec_get_context_defaults(&s->av_context);
++ avcodec_get_context_defaults3(&s->av_context, NULL);
+ s->av_codec=NULL;
+ s->codec=cid;
+ s->input=NULL;
+@@ -135,8 +135,8 @@ static void dec_preprocess(MSFilter *f){
+ if (s->av_context.codec==NULL){
+ /* we must know picture size before initializing snow decoder*/
+ if (s->codec!=CODEC_ID_SNOW){
+- error=avcodec_open(&s->av_context, s->av_codec);
+- if (error!=0) ms_error("avcodec_open() failed: %i",error);
++ error=avcodec_open2(&s->av_context, s->av_codec,NULL);
++ if (error!=0) ms_error("avcodec_open2() failed: %i",error);
+ if (s->codec==CODEC_ID_MPEG4 && s->dci_size>0){
+ s->av_context.extradata=s->dci;
+ s->av_context.extradata_size=s->dci_size;
+@@ -225,8 +225,8 @@ static mblk_t * parse_snow_header(DecState *s,mblk_t *inm){
+ int error;
+ s->av_context.width=h>>16;
+ s->av_context.height=h&0xffff;
+- error=avcodec_open(&s->av_context, s->av_codec);
+- if (error!=0) ms_error("avcodec_open() failed for snow: %i",error);
++ error=avcodec_open2(&s->av_context, s->av_codec, NULL);
++ if (error!=0) ms_error("avcodec_open2() failed for snow: %i",error);
+ else {
+ s->snow_initialized=TRUE;
+ ms_message("Snow decoder initialized,size=%ix%i",
+diff --git a/src/videofilters/videoenc.c b/src/videofilters/videoenc.c
+index da35592..09dcc9d 100644
+--- a/src/videofilters/videoenc.c
++++ b/src/videofilters/videoenc.c
+@@ -242,7 +242,7 @@ static void prepare(EncState *s){
+ AVCodecContext *c=&s->av_context;
+ const int max_br_vbv=128000;
+
+- avcodec_get_context_defaults(c);
++ avcodec_get_context_defaults3(c, NULL);
+ if (s->codec==CODEC_ID_MJPEG)
+ {
+ ms_message("Codec bitrate set to %i",c->bit_rate);
+@@ -348,9 +348,9 @@ static void enc_preprocess(MSFilter *f){
+ ms_error("could not find encoder for codec id %i",s->codec);
+ return;
+ }
+- error=avcodec_open(&s->av_context, s->av_codec);
++ error=avcodec_open2(&s->av_context, s->av_codec, NULL);
+ if (error!=0) {
+- ms_error("avcodec_open() failed: %i",error);
++ ms_error("avcodec_open2() failed: %i",error);
+ return;
+ }
+ video_starter_init(&s->starter);
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.9.0-underlinking.patch b/media-libs/mediastreamer/files/mediastreamer-2.9.0-underlinking.patch
new file mode 100644
index 000000000000..19d6af803c2c
--- /dev/null
+++ b/media-libs/mediastreamer/files/mediastreamer-2.9.0-underlinking.patch
@@ -0,0 +1,57 @@
+From 497ad9c27385c02f4f038b6e787ada9c7b6f8373 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Wed, 9 Oct 2013 18:24:28 +0200
+Subject: [PATCH] fix underlinking
+
+---
+ configure.ac | 20 ++++++++++++++++++++
+ src/Makefile.am | 2 +-
+ 2 files changed, 21 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9f402bd..4b923a9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -893,6 +893,26 @@ fi
+
+ AM_CONDITIONAL(BUILD_TESTS,test x$found_cunit = xyes)
+
++dnl Check for clock_gettime, in libc for FreeBSD, in rt for linux,
++dnl in rt for Solaris 7, in posix4 for Solaris 2.5.1
++LIB_CLOCK_GETTIME=
++clk_saved_libs=$LIBS
++AC_SEARCH_LIBS([clock_gettime], [rt posix4],
++ [test "$ac_cv_search_clock_gettime" = "none required" ||
++ LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettime])
++AC_SUBST([LIB_CLOCK_GETTIME])
++
++AC_MSG_CHECKING([for working clock_gettime])
++AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <time.h>]],
++ [[clock_gettime(CLOCK_REALTIME, 0);]])], [gnupg_cv_clock_gettime=yes], [gnupg_cv_clock_gettime=no])
++AC_MSG_RESULT($gnupg_cv_clock_gettime)
++
++if test x"$gnupg_cv_clock_gettime" = xyes; then
++ AC_DEFINE([HAVE_CLOCK_GETTIME], 1,
++ [Define to 1 if you have the `clock_gettime' function.])
++fi
++LIBS=$clk_saved_libs
++
+
+ dnl ##################################################
+ dnl # Check for doxygen
+diff --git a/src/Makefile.am b/src/Makefile.am
+index a315e92..a5e144c 100755
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -266,7 +266,7 @@ voipdescs.h: Makefile $(libmediastreamer_voip_la_SOURCES)
+ awk 'BEGIN { print("MSFilterDesc * ms_voip_filter_descs[]={") } { printf("&%s,\n",$$1) } END{ print("NULL\n};\n") } ' $$builddir/voipdescs.txt >> $$builddir/$@
+
+
+-libmediastreamer_base_la_LIBADD= $(ORTP_LIBS)
++libmediastreamer_base_la_LIBADD= $(ORTP_LIBS) @LIB_CLOCK_GETTIME@
+ libmediastreamer_base_la_LDFLAGS= -no-undefined -version-info $(LIBMEDIASTREAMER_SO_VERSION)
+
+ if !BUILD_WIN32
+--
+1.8.3.2
+
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.9.0-v4l-automagic.patch b/media-libs/mediastreamer/files/mediastreamer-2.9.0-v4l-automagic.patch
new file mode 100644
index 000000000000..c590aef3b713
--- /dev/null
+++ b/media-libs/mediastreamer/files/mediastreamer-2.9.0-v4l-automagic.patch
@@ -0,0 +1,55 @@
+From b99ddff6f322c8b466f3cdfd71b0d629cea33aac Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Wed, 9 Oct 2013 18:12:46 +0200
+Subject: [PATCH] Support disabling V4L support completely
+
+---
+ configure.ac | 18 +++++++++++++++---
+ 1 file changed, 15 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 94b6f18..9f402bd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -746,6 +746,16 @@ PACKAGE_DATA_DIR="$prefix/share"
+ AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${package_prefix}/share" ,[path of data])
+ AC_SUBST(PACKAGE_DATA_DIR)
+
++AC_ARG_ENABLE(v4l,
++ [ --disable-v4l Disable usage of v4l],
++ [case "${enableval}" in
++ yes) v4l=yes ;;
++ no) v4l=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-v4l) ;;
++ esac],[v4l=yes])
++
++if test "$v4l" = "yes" ; then
++
+ dnl check for video4linux headers
+ AC_CHECK_HEADERS(linux/videodev.h linux/videodev2.h)
+ if test "${ac_cv_header_linux_videodev_h}" = "yes" ; then
+@@ -759,9 +769,6 @@ else
+ found_v4l2=no
+ fi
+
+-AM_CONDITIONAL(BUILD_V4L1, test x$found_v4l1 = xyes )
+-AM_CONDITIONAL(BUILD_V4L2, test x$found_v4l2 = xyes )
+-
+ AC_ARG_ENABLE(libv4l1,
+ [AS_HELP_STRING([--disable-libv4l1], [Disable usage of libv4l1, really discouraged])],
+ [case "${enableval}" in
+@@ -805,6 +812,11 @@ this check.
+ fi
+ fi
+
++fi
++
++AM_CONDITIONAL(BUILD_V4L1, test x$found_v4l1 = xyes )
++AM_CONDITIONAL(BUILD_V4L2, test x$found_v4l2 = xyes )
++
+
+ AC_PATH_PROG(PCAP,pcap-config,false)
+ AM_CONDITIONAL(HAVE_PCAP, test $PCAP != false)
+--
+1.8.3.2
+
diff --git a/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild b/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild
new file mode 100644
index 000000000000..890dae0d575e
--- /dev/null
+++ b/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild,v 1.1 2013/10/09 18:52:30 hasufell Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Mediastreaming library for telephony application"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+# Many cameras will not work or will crash an application if mediastreamer2 is
+# not built with v4l2 support (taken from configure.ac)
+# TODO: run-time test for ipv6: does it really need ortp[ipv6] ?
+IUSE="+alsa amr bindist coreaudio debug doc examples +filters g726 g729 gsm ilbc
+ ipv6 ntp-timestamp opus +ortp oss pcap portaudio pulseaudio sdl silk +speex
+ static-libs theora upnp v4l video x264 X"
+
+REQUIRED_USE="|| ( oss alsa portaudio coreaudio pulseaudio )
+ video? ( || ( sdl X ) )
+ theora? ( video )
+ X? ( video )
+ v4l? ( video )"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ g726? ( >=media-libs/spandsp-0.0.6_pre1 )
+ gsm? ( media-sound/gsm )
+ opus? ( media-libs/opus )
+ ortp? ( >=net-libs/ortp-0.17[ipv6?] )
+ pcap? ( sys-libs/libcap )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.21 )
+ speex? ( >=media-libs/speex-1.2_beta3 )
+ upnp? ( net-libs/libupnp )
+ video? (
+ virtual/ffmpeg
+ v4l? ( media-libs/libv4l
+ sys-kernel/linux-headers )
+ theora? ( media-libs/libtheora )
+ sdl? ( media-libs/libsdl[video,X] )
+ X? ( x11-libs/libX11
+ x11-libs/libXv ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ X? ( x11-proto/videoproto )"
+
+PDEPEND="amr? ( !bindist? ( media-plugins/mediastreamer-amr ) )
+ g729? ( !bindist? ( media-plugins/mediastreamer-bcg729 ) )
+ ilbc? ( media-plugins/mediastreamer-ilbc )
+ video? ( x264? ( media-plugins/mediastreamer-x264 ) )
+ silk? ( !bindist? ( media-plugins/mediastreamer-silk ) )"
+
+src_prepare() {
+ # variable causes "command not found" warning and is not
+ # needed anyway
+ sed -i \
+ -e 's/$(ACLOCAL_MACOS_FLAGS)//' \
+ Makefile.am || die
+
+ # respect user's CFLAGS
+ sed -i \
+ -e "s:-O2::;s: -g::" \
+ configure.ac || die "patching configure.ac failed"
+
+ # change default paths
+ sed -i \
+ -e "s:\(prefix/share\):\1/${PN}:" \
+ configure.ac || die "patching configure.ac failed"
+
+ # fix doc installation dir
+ sed -i \
+ -e "s:\$(pkgdocdir):\$(docdir):" \
+ help/Makefile.am || die "patching help/Makefile.am failed"
+
+ # fix html installation dir
+ sed -i \
+ -e "s:\(doc_htmldir=\).*:\1\$(htmldir):" \
+ help/Makefile.am || die "patching help/Makefile.am failed"
+
+ # linux/videodev.h dropped in 2.6.38
+ sed -i \
+ -e 's:linux/videodev.h ::' \
+ configure.ac || die
+
+ epatch "${FILESDIR}/${P}-v4l-automagic.patch" \
+ "${FILESDIR}/${P}-libav9.patch" \
+ "${FILESDIR}/${P}-underlinking.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --datadir="${EPREFIX}"/usr/share/${PN}
+ # arts is deprecated
+ --disable-artsc
+ # don't want -Werror
+ --disable-strict
+ --disable-libv4l1
+ # don't use bundled libs
+ --enable-external-ortp
+ $(use_enable alsa)
+ $(use_enable pulseaudio)
+ $(use_enable coreaudio macsnd)
+ $(use_enable debug)
+ $(use_enable filters)
+ $(use_enable g726 spandsp )
+ $(use_enable gsm)
+ $(use_enable ipv6)
+ $(use_enable ntp-timestamp)
+ $(use_enable opus)
+ $(use_enable ortp)
+ $(use_enable oss)
+ $(use_enable pcap)
+ $(use_enable portaudio)
+ $(use_enable speex)
+ $(use_enable static-libs static)
+ $(use_enable theora)
+ $(use_enable upnp)
+ $(use_enable video)
+ $(use_enable v4l)
+ $(use_enable v4l libv4l2)
+ $(use_enable sdl)
+ $(use_enable X x11)
+ $(use_enable X xv)
+
+ $(use doc || echo ac_cv_path_DOXYGEN=false)
+ )
+
+ # Mac OS X Audio Queue is an audio recording facility, available on
+ # 10.5 (Leopard, Darwin9) and onward
+ if use coreaudio && [[ ${CHOST} == *-darwin* && ${CHOST##*-darwin} -ge 9 ]]
+ then
+ myeconfargs+=( --enable-macaqsnd )
+ else
+ myeconfargs+=( --disable-macaqsnd )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins tester/*.c
+ fi
+}
diff --git a/media-libs/mediastreamer/metadata.xml b/media-libs/mediastreamer/metadata.xml
index d57107b9b96d..3596cd9f5118 100644
--- a/media-libs/mediastreamer/metadata.xml
+++ b/media-libs/mediastreamer/metadata.xml
@@ -2,13 +2,24 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>voip</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>bircoph@gmail.com</email>
+ <name>Andrew Savchenko</name>
+ <description>Proxy maintainer. Assign bugs to him.</description>
+ </maintainer>
<use>
<flag name="amr">Use of AMR Narrow Band codec plugin</flag>
+ <flag name="filters">Enable compilation of filters</flag>
<flag name="g726">Support g726 codec</flag>
<flag name="g729">Use g726 codec plugin</flag>
<flag name="ilbc">Use of iLBC (RFC3951) codec plugin</flag>
+ <flag name="ntp-timestamp">Turn on NTP timestamping on received
+ packet</flag>
+ <flag name="opus">Enable opus codec support</flag>
+ <flag name="ortp">Enable usage of <pkg>net-libs/ortp</pkg></flag>
+ <flag name="pcap">Enable usage of <pkg>net-libs/libpcap</pkg></flag>
<flag name="silk">Use silk (skype protocol) codec plugin</flag>
<flag name="video">Enable video support</flag>
</use>
</pkgmetadata>
-