summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-07 06:50:25 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-07 06:50:25 +0000
commitfcf8861dea731f2c454922d1728a011aee1680ab (patch)
treeda56153bc5adecb511c0be380f682c6929b0c06c /media-libs
parent"user" -> "use" typo fix (diff)
downloadgentoo-2-fcf8861dea731f2c454922d1728a011aee1680ab.tar.gz
gentoo-2-fcf8861dea731f2c454922d1728a011aee1680ab.tar.bz2
gentoo-2-fcf8861dea731f2c454922d1728a011aee1680ab.zip
new libsdl with XVideo USE support
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/ChangeLog8
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.2.3-r11
-rw-r--r--media-libs/libsdl/libsdl-1.2.3-r1.ebuild123
-rw-r--r--media-libs/libsdl/libsdl-1.2.3.ebuild4
4 files changed, 133 insertions, 3 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index f5657ba72daa..806e6027cb9d 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libsdl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.1 2002/02/01 21:53:30 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.2 2002/02/07 06:50:24 drobbins Exp $
+
+*libsdl-1.2.3-r1 (6 Feb 2002)
+
+ 6 Feb 2002; Daniel Robbins <drobbins@gentoo.org> libsdl-1.2.3-r1.ebuild:
+ Added support for the new "xv" USE variable to turn on/off the XVideo extension.
+ This seems to be causing problems for some people. See bug #159.
*libsdl-1.2.3 (1 Feb 2002)
diff --git a/media-libs/libsdl/files/digest-libsdl-1.2.3-r1 b/media-libs/libsdl/files/digest-libsdl-1.2.3-r1
new file mode 100644
index 000000000000..edc753ea635f
--- /dev/null
+++ b/media-libs/libsdl/files/digest-libsdl-1.2.3-r1
@@ -0,0 +1 @@
+MD5 a942c605c0f36752a4df5709a449ae7a SDL-1.2.3.tar.gz 1568671
diff --git a/media-libs/libsdl/libsdl-1.2.3-r1.ebuild b/media-libs/libsdl/libsdl-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..6ca4c93e5b67
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.3-r1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.3-r1.ebuild,v 1.1 2002/02/07 06:50:24 drobbins Exp $
+
+S=${WORKDIR}/SDL-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+HOMEPAGE="http://www.libsdl.org/"
+
+DEPEND="virtual/glibc
+ >=dev-lang/nasm-0.98
+ >=media-libs/audiofile-0.1.9
+ opengl? ( virtual/opengl )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ esd? ( >=media-sound/esound-0.2.19 )
+ X? ( virtual/x11 )
+ arts? ( >=kde-base/kdelibs-2.0.1 )
+ nas? ( media-libs/nas )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ alsa? ( media-libs/alsa-lib )
+ directfb? ( >=dev-libs/DirectFB-0.9.7 )"
+
+RDEPEND="virtual/glibc
+ >=media-libs/audiofile-0.1.9
+ opengl? ( virtual/opengl )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ esd? ( >=media-sound/esound-0.2.19 )
+ X? ( virtual/x11 )
+ arts? ( >=kde-base/kdelibs-2.0.1 )
+ nas? ( media-libs/nas )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ alsa? ( media-libs/alsa-lib )
+ directfb? ( >=dev-libs/DirectFB-0.9.7 )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use esd`" ]
+ then
+ myconf="--disable-esd"
+ else
+ myconf="--enable-esd"
+ fi
+ if [ -z "`use xv`" ]
+ then
+ myconf="${myconf} --disable-video-x11-xv"
+ else
+ myconf="${myconf} --enable-video-x11-xv"
+ fi
+ if [ -z "`use arts`" ]
+ then
+ myconf="${myconf} --disable-arts"
+ else
+ myconf="${myconf} --enable-arts"
+ fi
+
+ if [ -z "`use nas`" ]
+ then
+ myconf="${myconf} --disable-nas"
+ else
+ myconf="${myconf} --enable-nas"
+ fi
+ if [ -z "`use X`" ]
+ then
+ myconf="${myconf} --disable-video-x11"
+ else
+ myconf="${myconf} --enable-video-x11"
+ fi
+ if [ "`use svga`" ]
+ then
+ myconf="${myconf} --enable-video-svga"
+ else
+ myconf="${myconf} --disable-video-svga"
+ fi
+ if [ -z "`use fbcon`" ]
+ then
+ myconf="${myconf} --disable-video-fbcon"
+ else
+ myconf="${myconf} --enable-video-fbcon"
+ fi
+ if [ "`use aalib`" ]
+ then
+ myconf="${myconf} --enable-video-aalib"
+ else
+ myconf="${myconf} --disable-video-aalib"
+ fi
+ if [ "`use ggi`" ]
+ then
+ myconf="${myconf} --enable-video-ggi"
+ else
+ myconf="${myconf} --disable-video-ggi"
+ fi
+ if [ -z "`use opengl`" ]
+ then
+ myconf="${myconf} --disable-video-opengl"
+ else
+ myconf="${myconf} --enable-video-opengl"
+ fi
+ if [ -z "`use directfb`" ]
+ then
+ myconf="${myconf} --disable-video-directfb"
+ else
+ myconf="${myconf} --enable-video-directfb"
+ fi
+ if [ -n "`use alsa`" ]
+ then
+ myconf="${myconf} --enable-alsa"
+ else
+ myconf="${myconf} --disable-alsa"
+ fi
+ ./configure --host=${CHOST} --enable-input-events --prefix=/usr --mandir=/usr/share/man ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install || die
+ preplib /usr
+ dodoc BUGS COPYING CREDITS README* TODO WhatsNew
+ docinto html
+ dodoc *.html
+ docinto html/docs
+ dodoc docs/*.html
+}
diff --git a/media-libs/libsdl/libsdl-1.2.3.ebuild b/media-libs/libsdl/libsdl-1.2.3.ebuild
index aca67de2e192..8953bb70c6c7 100644
--- a/media-libs/libsdl/libsdl-1.2.3.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.3.ebuild,v 1.2 2001/11/17 11:28:28 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.3.ebuild,v 1.3 2002/02/07 06:50:24 drobbins Exp $
A=SDL-${PV}.tar.gz
S=${WORKDIR}/SDL-${PV}
@@ -37,7 +37,7 @@ RDEPEND="virtual/glibc
src_compile() {
local myconf
-
+
if [ -z "`use esd`" ]
then
myconf="--disable-esd"