summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-05-24 00:34:56 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-05-24 00:34:56 +0000
commit9c9032f9609bf18169f198d18853ccb737d4dd47 (patch)
treed182abecca5a2f0a5b0648d86a21f908d123f8a4 /media-plugins/audacious-plugins
parentVersion bump. Now supports session management through libSM. (diff)
downloadgentoo-2-9c9032f9609bf18169f198d18853ccb737d4dd47.tar.gz
gentoo-2-9c9032f9609bf18169f198d18853ccb737d4dd47.tar.bz2
gentoo-2-9c9032f9609bf18169f198d18853ccb737d4dd47.zip
Version bump. Bugfixes, lots of bugfixes...
(Portage version: 2.1.5)
Diffstat (limited to 'media-plugins/audacious-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog7
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.5.1.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index ea5c0766d5ea..da7719a258f8 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.89 2008/05/12 15:40:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.90 2008/05/24 00:34:56 chainsaw Exp $
+
+*audacious-plugins-1.5.1 (24 May 2008)
+
+ 24 May 2008; <chainsaw@gentoo.org> +audacious-plugins-1.5.1.ebuild:
+ Version bump. Bugfixes, lots of bugfixes...
12 May 2008; Markus Rothe <corsair@gentoo.org>
audacious-plugins-1.4.5.ebuild:
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.5.1.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.5.1.ebuild
new file mode 100644
index 000000000000..700b8127e306
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-1.5.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.5.1.ebuild,v 1.1 2008/05/24 00:34:56 chainsaw Exp $
+
+inherit eutils flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac adplug alsa arts chardet esd flac gnome jack lirc modplug mp3 mtp musepack nls oss pulseaudio sdl sid sndfile sse2 timidity tta vorbis wavpack wma"
+
+RDEPEND="app-arch/unzip
+ >=dev-libs/libcdio-0.79-r1
+ >=dev-libs/dbus-glib-0.60
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=media-libs/libcddb-1.2.1
+ >=media-sound/audacious-1.5.1
+ >=net-misc/neon-0.26.4
+ >=x11-libs/gtk+-2.10
+ adplug? ( >=dev-cpp/libbinio-1.4 )
+ alsa? ( >=media-libs/alsa-lib-1.0.16 )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.38-r1 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.2.1-r1 )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ mp3? ( media-libs/libmad )
+ mtp? ( >=media-libs/libmtp-0.2.6.1 )
+ musepack? ( media-libs/libmpcdec media-libs/taglib )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ sid? ( media-libs/libsidplay )
+ sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
+ timidity? ( media-sound/timidity++ )
+ tta? ( media-libs/libid3tag )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )
+ wavpack? ( >=media-sound/wavpack-4.41.0 )
+ wma? ( >=media-libs/libmms-0.3 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ econf \
+ --enable-cdaudio-ng \
+ --enable-dbus \
+ --enable-neon \
+ --disable-projectm \
+ --disable-projectm-1.0 \
+ $(use_enable aac) \
+ $(use_enable adplug) \
+ $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable chardet) \
+ $(use_enable esd) \
+ $(use_enable flac) \
+ $(use_enable jack) \
+ $(use_enable gnome gnomeshortcuts) \
+ $(use_enable lirc) \
+ $(use_enable mp3) \
+ $(use_enable modplug) \
+ $(use_enable musepack) \
+ $(use_enable mtp mtp_up) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable sdl paranormal) \
+ $(use_enable sid) \
+ $(use_enable sndfile) \
+ $(use_enable sse2) \
+ $(use_enable timidity) \
+ $(use_enable tta) \
+ $(use_enable vorbis) \
+ $(use_enable wavpack) \
+ $(use_enable wma) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS
+}
+
+pkg_postinst() {
+ mp3_warning
+}