summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-27 21:49:16 +0000
committerDror Levin <spatz@gentoo.org>2010-03-27 21:49:16 +0000
commit376956f15b52f2c0c87a3214e8210da9712bca75 (patch)
tree017cb38e4d2a0aae213aea60f7bdefb9e5194b0d /media-plugins/gimp-resynthesizer/gimp-resynthesizer-0.16.ebuild
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-376956f15b52f2c0c87a3214e8210da9712bca75.tar.gz
gentoo-2-376956f15b52f2c0c87a3214e8210da9712bca75.tar.bz2
gentoo-2-376956f15b52f2c0c87a3214e8210da9712bca75.zip
Initial import, bug 126220. Thanks to Maurizio Pucci and Jouni Rinne.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/gimp-resynthesizer/gimp-resynthesizer-0.16.ebuild')
-rw-r--r--media-plugins/gimp-resynthesizer/gimp-resynthesizer-0.16.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-plugins/gimp-resynthesizer/gimp-resynthesizer-0.16.ebuild b/media-plugins/gimp-resynthesizer/gimp-resynthesizer-0.16.ebuild
new file mode 100644
index 000000000000..97a73313b342
--- /dev/null
+++ b/media-plugins/gimp-resynthesizer/gimp-resynthesizer-0.16.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-resynthesizer/gimp-resynthesizer-0.16.ebuild,v 1.1 2010/03/27 21:49:16 spatz Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MY_PN="${PN#gimp-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="GIMP plug-ing for texture synthesis"
+HOMEPAGE="http://www.logarithmic.net/pfh/resynthesizer"
+SRC_URI="http://www.logarithmic.net/pfh-files/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-gfx/gimp"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+
+ tc-export CXX
+}
+
+src_install() {
+ exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
+ doexe resynth || die
+
+ insinto $(gimptool-2.0 --gimpdatadir)/scripts
+ doins smart-enlarge.scm smart-remove.scm || die
+
+ dodoc README || die
+}
+
+pkg_postinst() {
+ elog "The Resynthesizer plugin is accessible from the menu:"
+ elog "* Filters -> Map -> Resynthesize"
+ elog "* Filters -> Enhance -> Smart enlarge/sharpen/remove selection"
+}