summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-10 00:51:40 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-10 00:51:40 +0000
commitddc59bada898678c63684126edc7b3bfa82888af (patch)
tree0b8a8f4932a6043db65da1c198be8a1fa378eb18 /media-plugins/live/live-2004.03.27.ebuild
parentAdded sys-libs/lib-compat to DEPEND. (Manifest recommit) (diff)
downloadgentoo-2-ddc59bada898678c63684126edc7b3bfa82888af.tar.gz
gentoo-2-ddc59bada898678c63684126edc7b3bfa82888af.tar.bz2
gentoo-2-ddc59bada898678c63684126edc7b3bfa82888af.zip
an -fPIC fix
Diffstat (limited to 'media-plugins/live/live-2004.03.27.ebuild')
-rw-r--r--media-plugins/live/live-2004.03.27.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/media-plugins/live/live-2004.03.27.ebuild b/media-plugins/live/live-2004.03.27.ebuild
index 940ef1e3abe8..8afa80aec530 100644
--- a/media-plugins/live/live-2004.03.27.ebuild
+++ b/media-plugins/live/live-2004.03.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2004.03.27.ebuild,v 1.2 2004/04/09 23:24:53 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2004.03.27.ebuild,v 1.3 2004/04/10 00:51:40 lv Exp $
DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
@@ -17,6 +17,16 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
cd ${S}
+
+ # -fPIC is needed on amd64 because some applications are using live
+ # to make shared libraries, which wont work without -fPIC on that
+ # arch. The build system used isn't advanced enough to easily
+ # specify that the test programs dont need to be PIC themselves,
+ # and makefiles are generated on the fly, so I'm adding it as a
+ # global flag.
+ # Travis Tilley <lv@gentoo.org> 09 Apr 2004
+ use amd64 && append-flags -fPIC
+
sed -i.orig -e "s:-O:${CFLAGS} -Wno-deprecated:" config.linux
epatch ${FILESDIR}/gcc-3.3.patch
#quick fix, something better will follow.