summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-02-29 20:19:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-02-29 20:19:52 +0000
commit31ab3bac77a54afd7f6f6d43ba5d8b0dd2ba77eb (patch)
treeb1a17d6d41eeff88531f39eccab378b03e38d2a6 /media-plugins/live
parent Remove icon extension from desktop entry to match Icon Theme Specification. (diff)
downloadgentoo-2-31ab3bac77a54afd7f6f6d43ba5d8b0dd2ba77eb.tar.gz
gentoo-2-31ab3bac77a54afd7f6f6d43ba5d8b0dd2ba77eb.tar.bz2
gentoo-2-31ab3bac77a54afd7f6f6d43ba5d8b0dd2ba77eb.zip
version bump for bug #204065, respect ldflags for bug #209728, give it a loosy manual ABI handling, do not build pic programs as they will not be installed
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/ChangeLog11
-rw-r--r--media-plugins/live/live-2008.02.08.ebuild81
2 files changed, 90 insertions, 2 deletions
diff --git a/media-plugins/live/ChangeLog b/media-plugins/live/ChangeLog
index e834583cad8e..45360ff9fa0c 100644
--- a/media-plugins/live/ChangeLog
+++ b/media-plugins/live/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/live
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.80 2007/10/25 23:09:22 beandog Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.81 2008/02/29 20:19:52 aballier Exp $
+
+*live-2008.02.08 (29 Feb 2008)
+
+ 29 Feb 2008; Alexis Ballier <aballier@gentoo.org> +live-2008.02.08.ebuild:
+ version bump for bug #204065, respect ldflags for bug #209728, give it a
+ loosy manual ABI handling, do not build pic programs as they will not be
+ installed
*live-2007.08.03a (25 Oct 2007)
diff --git a/media-plugins/live/live-2008.02.08.ebuild b/media-plugins/live/live-2008.02.08.ebuild
new file mode 100644
index 000000000000..0f9b3b7a1d32
--- /dev/null
+++ b/media-plugins/live/live-2008.02.08.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2008.02.08.ebuild,v 1.1 2008/02/29 20:19:52 aballier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
+HOMEPAGE="http://www.live555.com/"
+SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+# Alexis Ballier <aballier@gentoo.org>
+# Be careful, bump this everytime you bump the package and the ABI has changed.
+# If you don't know, ask someone.
+LIVE_ABI_VERSION=1
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+
+ cp -pPR live live-shared
+ mv live live-static
+
+ cp "${FILESDIR}/config.gentoo" live-static
+ cp "${FILESDIR}/config.gentoo-so" live-shared
+}
+
+src_compile() {
+ tc-export CC CXX LD
+
+ cd "${WORKDIR}/live-static"
+
+ einfo "Beginning static library build"
+ ./genMakefiles gentoo
+ emake -j1 LINK_OPTS="-L. $(raw-ldflags)" TESTPROGS_APP="" MEDIA_SERVER_APP="" || die "failed to build static libraries"
+
+ einfo "Beginning programs build"
+ cd "${WORKDIR}/live-static/testProgs"
+ emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
+ cd "${WORKDIR}/live-static/mediaServer"
+ emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build the mediaserver"
+
+ cd "${WORKDIR}/live-shared"
+ einfo "Beginning shared library build"
+ ./genMakefiles gentoo-so
+ emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="so.${LIVE_ABI_VERSION}" TESTPROGS_APP="" MEDIA_SERVER_APP="" || die "failed to build shared libraries"
+}
+
+src_install() {
+ for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
+ dolib.a live-static/${library}/lib${library}.a
+ dolib.so live-shared/${library}/lib${library}.so.${LIVE_ABI_VERSION}
+ dosym lib${library}.so.${LIVE_ABI_VERSION} /usr/$(get_libdir)/lib${library}.so
+
+ insinto /usr/include/${library}
+ doins live-shared/${library}/include/*h
+ done
+
+ # Should we really install these?
+ find live-static/testProgs -type f -perm +111 -print0 | \
+ xargs -0 dobin
+
+ #install included live555MediaServer aplication
+ dobin live-static/mediaServer/live555MediaServer
+
+ # install docs
+ dodoc live-static/README
+}
+
+pkg_postinst() {
+ ewarn "If you are upgrading from a version prior to live-2008.02.08"
+ ewarn "Please make sure to rebuild applications built against ${PN}"
+ ewarn "like vlc or mplayer. ${PN} may have had ABI changes and ${PN}"
+ ewarn "support might be broken."
+}