summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-02-11 07:28:55 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-02-11 07:28:55 +0000
commit5ab895b26d621edd9dc32f6c193a9249ec07f667 (patch)
treec6b89ff48ce7fb9772d054f1e248d699c858e708 /media-plugins/mythbrowser/mythbrowser-0.17.ebuild
parentmask out all of the new mythtv ebuilds (diff)
downloadgentoo-2-5ab895b26d621edd9dc32f6c193a9249ec07f667.tar.gz
gentoo-2-5ab895b26d621edd9dc32f6c193a9249ec07f667.tar.bz2
gentoo-2-5ab895b26d621edd9dc32f6c193a9249ec07f667.zip
revision bump. inherit kde-functions to set KDEDIR
(Portage version: 2.0.51.16)
Diffstat (limited to 'media-plugins/mythbrowser/mythbrowser-0.17.ebuild')
-rw-r--r--media-plugins/mythbrowser/mythbrowser-0.17.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-plugins/mythbrowser/mythbrowser-0.17.ebuild b/media-plugins/mythbrowser/mythbrowser-0.17.ebuild
new file mode 100644
index 000000000000..f6aa3e3fc59c
--- /dev/null
+++ b/media-plugins/mythbrowser/mythbrowser-0.17.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythbrowser/mythbrowser-0.17.ebuild,v 1.1 2005/02/11 07:28:55 cardoe Exp $
+
+inherit myth kde-functions
+
+DESCRIPTION="Web browser module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=sys-apps/sed-4
+ >=kde-base/kdelibs-3.1
+ || ( ~media-tv/mythtv-${PV} ~media-tv/mythfrontend-${PV} )"
+
+setup_pro() {
+ set-kdedir
+ echo "INCLUDEPATH += ${KDEDIR}/include" >> settings.pro
+ echo "EXTRA_LIBS += -L${KDEDIR}/lib" >> settings.pro
+}