summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2008-07-06 17:12:19 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2008-07-06 17:12:19 +0000
commitf4d24e8428dc2bca084c58f0f2bd07955445d839 (patch)
tree2417c75ef1c22e254cab08631bcc72259b659008 /media-plugins/vdr-console
parentVersion bump wrt #230765, thanks to Lietart Frederic for reporting. (diff)
downloadgentoo-2-f4d24e8428dc2bca084c58f0f2bd07955445d839.tar.gz
gentoo-2-f4d24e8428dc2bca084c58f0f2bd07955445d839.tar.bz2
gentoo-2-f4d24e8428dc2bca084c58f0f2bd07955445d839.zip
added compile fix for >=vdr-1.5.8, it compiles, but you will miss all character symbols on OSD; unmainted, no upstream available, bug 215683
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-plugins/vdr-console')
-rw-r--r--media-plugins/vdr-console/ChangeLog10
-rw-r--r--media-plugins/vdr-console/files/vdr-console-0.6.0-vdr-1.6.x-compilefix.diff79
-rw-r--r--media-plugins/vdr-console/vdr-console-0.6.0.ebuild13
3 files changed, 98 insertions, 4 deletions
diff --git a/media-plugins/vdr-console/ChangeLog b/media-plugins/vdr-console/ChangeLog
index 40c6d363c88f..34adfce05f4a 100644
--- a/media-plugins/vdr-console/ChangeLog
+++ b/media-plugins/vdr-console/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-console
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-console/ChangeLog,v 1.4 2006/12/03 14:33:00 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-console/ChangeLog,v 1.5 2008/07/06 17:12:19 hd_brummy Exp $
+
+ 06 Jul 2008; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/vdr-console-0.6.0-vdr-1.6.x-compilefix.diff,
+ vdr-console-0.6.0.ebuild:
+ added compile fix for >=vdr-1.5.8, it compiles, but you will miss all
+ character symbols on OSD; unmainted, no upstream available, bug 215683
03 Dec 2006; Matthias Schwarzott <zzam@gentoo.org>
+files/vdr-console-0.6.0-uint64.diff, vdr-console-0.6.0.ebuild:
diff --git a/media-plugins/vdr-console/files/vdr-console-0.6.0-vdr-1.6.x-compilefix.diff b/media-plugins/vdr-console/files/vdr-console-0.6.0-vdr-1.6.x-compilefix.diff
new file mode 100644
index 000000000000..35aac3e0e263
--- /dev/null
+++ b/media-plugins/vdr-console/files/vdr-console-0.6.0-vdr-1.6.x-compilefix.diff
@@ -0,0 +1,79 @@
+http://svn.debian.org/wsvn/pkg-vdr-dvb/vdr/vdr-plugin-console/trunk/debian/patches/94_console-1.6.0.dpatch?op=file&rev=0&sc=0
+
+by Tobias Grimm <tg@e-tobi.net>
+--- vdr-plugin-console-0.6.0.orig/menu.c
++++ vdr-plugin-console-0.6.0/menu.c
+@@ -24,7 +24,7 @@
+
+
+
+-#include "fontsmallfix.c"
++//#include "fontsmallfix.c"
+ #include "symbols/bell.xpm"
+ #include "symbols/keyboard.xpm"
+
+@@ -59,31 +59,11 @@
+ if (backColor != clrConsoleTransparent)
+ bitmap.DrawRectangle(x, y, x + w - 1, y + h - 1, backColor);
+
+- const cFont::tCharData* CharData = font.CharData(ch);
++ char text[2];
++ text[1] = 0;
++ text[0] = ch;
+
+- // Center the char within its cell
+- x += (w - (int)CharData->width) / 2;
+- if (w > (int)CharData->width)
+- w = (int)CharData->width;
+-
+- for (int row = 0; row < h; ++row) {
+-
+- cFont::tPixelData PixelData = CharData->lines[row];
+-//@@TEST
+- PixelData >>= 1;
+- for (int col = w; col-- > 0;) {
+-
+- if (PixelData & 1) {
+- bitmap.SetIndex(x + col, y + row, fg);
+-
+- // Try to fix flickering
+-// if (*bitmap.Data(x + col, y + row - 1) != fg)
+-// bitmap.SetIndex(x + col, y + row + 1, fg);
+- }
+-
+- PixelData >>= 1;
+- }
+- }
++ bitmap.DrawText(x, y, text, foreColor, backColor, &font);
+
+ } else {
+
+@@ -794,22 +774,22 @@
+ // Small
+ _pFont = cFont::GetFont(fontSml);
+ _charW = _pFont->Width('A');
+- _charH = _pFont->Height('A');
++ _charH = _pFont->Height("A");
+
+ } else if (_selectedFont == 2) {
+
+ // Extra small
+ // The space between the chars can shrink, so more chars can go to the screen.
+- _pFont = new cFont(consFontSmallFix);
+- _charW = _pFont->Width('A') - 1;
+- _charH = _pFont->Height('A') - 1;
++ _pFont = cFont::GetFont(fontOsd);
++ _charW = _pFont->Width('A');
++ _charH = _pFont->Height("A");
+
+ } else {
+
+ // Normal
+ _pFont = cFont::GetFont(fontFix);
+ _charW = _pFont->Width('A');
+- _charH = _pFont->Height('A');
++ _charH = _pFont->Height("A");
+ }
+
+ _charsW = (_pixelW / _charW);
+
diff --git a/media-plugins/vdr-console/vdr-console-0.6.0.ebuild b/media-plugins/vdr-console/vdr-console-0.6.0.ebuild
index 7ebf8ae938a8..9c48bc019202 100644
--- a/media-plugins/vdr-console/vdr-console-0.6.0.ebuild
+++ b/media-plugins/vdr-console/vdr-console-0.6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-console/vdr-console-0.6.0.ebuild,v 1.3 2006/12/03 14:33:00 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-console/vdr-console-0.6.0.ebuild,v 1.4 2008/07/06 17:12:19 hd_brummy Exp $
inherit vdr-plugin eutils
@@ -18,3 +18,12 @@ DEPEND=">=media-video/vdr-1.3.36"
PATCHES="${FILESDIR}/${P}-vdr-1.3.18.diff
${FILESDIR}/${P}-uint64.diff"
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ if has_version ">=media-video/vdr-1.5.8" ; then
+ ewarn "plugin will not support the new fonthandling"
+ epatch "${FILESDIR}/${P}-vdr-1.6.x-compilefix.diff"
+ fi
+}