summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2009-10-22 14:26:13 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2009-10-22 14:26:13 +0000
commit5badf0e3722f85dcd2602ec619ea40f5b4351ab6 (patch)
tree4f6670e4c36f5db8e02f93c105f337e32d1edbe7 /media-plugins/vdr-graphtft
parentinitial ebuild; theme for vdr-graphtft-0.3.1.x (diff)
downloadgentoo-2-5badf0e3722f85dcd2602ec619ea40f5b4351ab6.tar.gz
gentoo-2-5badf0e3722f85dcd2602ec619ea40f5b4351ab6.tar.bz2
gentoo-2-5badf0e3722f85dcd2602ec619ea40f5b4351ab6.zip
version bump; svn revision 24; #276087
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-graphtft')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog13
-rw-r--r--media-plugins/vdr-graphtft/files/rc-addon.sh4
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_ffmpeg-0.5.diff29
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff50
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gentoo.diff141
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff39
-rw-r--r--media-plugins/vdr-graphtft/metadata.xml5
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild122
8 files changed, 401 insertions, 2 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index 3d8bdc1c8d94..cf801b17d824 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.17 2009/09/22 05:22:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.18 2009/10/22 14:26:13 hd_brummy Exp $
+
+*vdr-graphtft-0.3.2.24 (22 Oct 2009)
+
+ 22 Oct 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +vdr-graphtft-0.3.2.24.ebuild,
+ +files/vdr-graphtft-0.3.2.24_ffmpeg-0.5.diff,
+ +files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff,
+ +files/vdr-graphtft-0.3.2.24_gentoo.diff,
+ +files/vdr-graphtft-0.3.2.24_makefile.diff, files/rc-addon.sh,
+ metadata.xml:
+ version bump; svn revision 24; #276087
22 Sep 2009; Alexis Ballier <aballier@gentoo.org>
vdr-graphtft-0.2.2-r1.ebuild, +files/vdr-graphtft-0.2.2-avutil50.patch:
diff --git a/media-plugins/vdr-graphtft/files/rc-addon.sh b/media-plugins/vdr-graphtft/files/rc-addon.sh
index 0d191ca637a0..87eeaa906831 100644
--- a/media-plugins/vdr-graphtft/files/rc-addon.sh
+++ b/media-plugins/vdr-graphtft/files/rc-addon.sh
@@ -1,9 +1,11 @@
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/files/rc-addon.sh,v 1.1 2007/12/23 22:05:10 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/files/rc-addon.sh,v 1.2 2009/10/22 14:26:11 hd_brummy Exp $
#
# rc-addon-script for plugin graphtft & graphtft-fe
#
# Joerg Bornkessel <hd_brummy@g.o>
+. /etc/conf.d/vdr.graphtft
+
plugin_pre_vdr_start() {
: ${GRAPHTFT_DEVICE:=/dev/fb0}
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_ffmpeg-0.5.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_ffmpeg-0.5.diff
new file mode 100644
index 000000000000..0f62d20d7f15
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_ffmpeg-0.5.diff
@@ -0,0 +1,29 @@
+diff -ur graphtft-0.2.2.orig/imlibrenderer/dvbrenderer/mpeg2encoder.c graphtft-0.2.2/imlibrenderer/dvbrenderer/mpeg2encoder.c
+--- graphtft-0.2.2.orig/imlibrenderer/dvbrenderer/mpeg2encoder.c 2008-11-01 10:02:54.000000000 +0200
++++ graphtft-0.2.2/imlibrenderer/dvbrenderer/mpeg2encoder.c 2009-07-24 21:11:58.000000000 +0300
+@@ -126,11 +126,11 @@
+ int i;
+ AVPicture avpsrc;
+
+- avpicture_fill(&avpsrc, buf, PIX_FMT_RGBA32, width, height);
++ avpicture_fill(&avpsrc, buf, PIX_FMT_RGBA, width, height);
+
+ #ifndef HAVE_SWSCALE
+
+- img_convert(&pic, PIX_FMT_YUV420P, &avpsrc, PIX_FMT_RGBA32, width, height);
++ img_convert(&pic, PIX_FMT_YUV420P, &avpsrc, PIX_FMT_RGBA, width, height);
+
+ #else
+
+diff -ur graphtft-0.2.2.orig/imlibrenderer/fbrenderer/fbrenderer.c graphtft-0.2.2/imlibrenderer/fbrenderer/fbrenderer.c
+--- graphtft-0.2.2.orig/imlibrenderer/fbrenderer/fbrenderer.c 2008-11-01 10:02:05.000000000 +0200
++++ graphtft-0.2.2/imlibrenderer/fbrenderer/fbrenderer.c 2009-07-24 21:11:39.000000000 +0300
+@@ -192,7 +192,7 @@
+
+ switch (fb_vinfo.bits_per_pixel)
+ {
+- case 32: tell(4, "fbdevout.c: using 32 bit depth"); fb_type = PIX_FMT_RGBA32; break;
++ case 32: tell(4, "fbdevout.c: using 32 bit depth"); fb_type = PIX_FMT_RGBA; break;
+ case 24: tell(4, "fbdevout.c: using 24 bit depth"); fb_type = PIX_FMT_RGB24; break;
+ case 16: tell(4, "fbdevout.c: using 16 bit depth"); fb_type = PIX_FMT_RGB565; break;
+ default: tell(4, "fbdevout.c: color depth not supported -> %i bits per pixel",
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff
new file mode 100644
index 000000000000..90bc2405be3c
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff
@@ -0,0 +1,50 @@
+based on patch
+http://www.vdr-portal.de/board/thread.php?postid=846248#post846248H
+Joerg Bornkessel <hd_brummy@g.o> 22 Aug 2009
+diff -urNad vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/common.h vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153-patched/common.h
+--- vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/common.h 2008-12-17 22:56:39.000000000 +0100
++++ vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153-patched/common.h 2009-10-06 18:39:53.574720223 +0200
+@@ -17,6 +17,7 @@
+
+ #include <string>
+ #include <iconv.h>
++#include <stdint.h>
+
+ using std::string;
+
+
+diff -urNad vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/display.c vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153-patched/display.c
+--- vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/display.c 2009-02-15 16:06:59.000000000 +0100
++++ vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153-patched/display.c 2009-10-06 18:39:53.578713784 +0200
+@@ -158,7 +158,7 @@
+
+ int cGraphTFTDisplay::Init(const char* dev, const char* cfgDir, int port)
+ {
+- char* pos = 0;
++ const char* pos = 0;
+ int devnum = na;
+
+ #ifdef HAVE_DFB
+diff -urNad vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/scan.h vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153-patched/scan.h
+--- vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/scan.h 2008-12-17 22:56:39.000000000 +0100
++++ vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153-patched/scan.h 2009-10-06 18:39:53.578713784 +0200
+@@ -12,6 +12,7 @@
+ // Includes
+ //***************************************************************************
+
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+
+diff -urNad vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/theme.c vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153-patched/theme.c
+--- vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/theme.c 2009-02-15 16:06:59.000000000 +0100
++++ vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153-patched/theme.c 2009-10-06 18:39:53.578713784 +0200
+@@ -112,7 +112,7 @@
+ {
+ s++;
+
+- if (!(e = strchr(s, '}')))
++ if (!(e = (char *)strchr(s, '}')))
+ {
+ tell(0, "Parsing of [%s] failed, missing bracket '}'", expression);
+ return fail;
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gentoo.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gentoo.diff
new file mode 100644
index 000000000000..9665affdb83e
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gentoo.diff
@@ -0,0 +1,141 @@
+addapted to gentoo vdr path
+Joerg Bornkessel <hd_brummy@g.o> 22 Aug 2009
+diff -Naur graphtft-0.3.1.orig/dfbrenderer/dfbrenderer.c graphtft-0.3.1/dfbrenderer/dfbrenderer.c
+--- graphtft-0.3.1.orig/dfbrenderer/dfbrenderer.c 2009-03-23 19:46:26.000000000 +0100
++++ graphtft-0.3.1/dfbrenderer/dfbrenderer.c 2009-03-23 19:49:09.000000000 +0100
+@@ -231,7 +231,7 @@
+ {
+ // make path relative to the themes directory
+
+- asprintf(&path, "%s/graphTFT/themes/%s/%s",
++ asprintf(&path, "%s/themes/%s/%s",
+ confPath.c_str(), themePath.c_str(), p.c_str());
+ }
+ else
+@@ -255,7 +255,7 @@
+
+ // at least add the default path
+
+- asprintf(&path, "%s/graphTFT/fonts/", confPath.c_str());
++ asprintf(&path, "%s/fonts/", confPath.c_str());
+ tell(0, "Info: Adding font path '%s'", path);
+ fontPaths[count] = path;
+ free(path);
+@@ -464,7 +464,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s\n", fpath);
+@@ -538,7 +538,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s\n", fpath);
+diff -Naur graphtft-0.3.1.orig/dspitems.c graphtft-0.3.1/dspitems.c
+--- graphtft-0.3.1.orig/dspitems.c 2009-03-23 19:46:26.000000000 +0100
++++ graphtft-0.3.1/dspitems.c 2009-03-23 19:49:56.000000000 +0100
+@@ -113,7 +113,7 @@
+ if (p[0] != '/')
+ {
+ p = string(GraphTFTSetup.PluginConfPath)
+- + "/graphTFT/themes/"
++ + "/themes/"
+ + string(Thms::theTheme->getDir())
+ + "/" + p;
+ }
+diff -Naur graphtft-0.3.1.orig/graphtft.c graphtft-0.3.1/graphtft.c
+--- graphtft-0.3.1.orig/graphtft.c 2009-03-23 19:46:26.000000000 +0100
++++ graphtft-0.3.1/graphtft.c 2009-03-23 19:54:23.000000000 +0100
+@@ -22,6 +22,8 @@
+ #include <graphtft.h>
+ #include <span.h>
+
++#define DATA_DIR "/usr/share/vdr/graphTFT"
++
+ //***************************************************************************
+ // cGraphTFTMenu
+ //***************************************************************************
+@@ -296,15 +298,9 @@
+
+ #endif
+
+- // try to get the config dir
+-
+- if (!ConfigDirectory())
+- return false;
+-
+- // init
+
+ GraphTFTSetup.setClient(this);
+- GraphTFTSetup.PluginConfPath = strdup(ConfigDirectory());
++ GraphTFTSetup.PluginConfPath = strdup(DATA_DIR);
+
+ #if APIVERSNUM < 10507
+ RegisterI18n(Phrases);
+@@ -320,7 +316,7 @@
+ if (loadThemes() != 0)
+ return false;
+
+- if (display->Init(_dev, ConfigDirectory(), port) != success)
++ if (display->Init(_dev, DATA_DIR, port) != success)
+ {
+ tell(0, "Error: Initializing graphTFT device faild, aborting!");
+
+@@ -353,8 +349,8 @@
+
+ // look for the themes in the config directory
+
+- asprintf(&buffer, "find %s/graphTFT/themes -follow -type f -name '*.theme' | sort",
+- ConfigDirectory());
++ asprintf(&buffer, "find %s/themes -follow -type f -name '*.theme' | sort",
++ DATA_DIR);
+
+ p = popen(buffer, "r");
+
+diff -Naur graphtft-0.3.1.orig/imlibrenderer/imlibrenderer.c graphtft-0.3.1/imlibrenderer/imlibrenderer.c
+--- graphtft-0.3.1.orig/imlibrenderer/imlibrenderer.c 2009-03-23 19:46:26.000000000 +0100
++++ graphtft-0.3.1/imlibrenderer/imlibrenderer.c 2009-03-23 19:55:19.000000000 +0100
+@@ -123,7 +123,7 @@
+ {
+ // make path relative to the themes directory
+
+- asprintf(&path, "%s/graphTFT/themes/%s/%s",
++ asprintf(&path, "%s/themes/%s/%s",
+ confPath.c_str(), themePath.c_str(), p.c_str());
+ }
+ else
+@@ -146,7 +146,7 @@
+
+ // at least add the default path
+
+- asprintf(&path, "%s/graphTFT/fonts/", confPath.c_str());
++ asprintf(&path, "%s/fonts/", confPath.c_str());
+ tell(0, "Info: Adding font path '%s'", path);
+ imlib_add_path_to_font_path(path);
+ free(path);
+@@ -217,7 +217,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ if (!fileExists(path.str().c_str()))
+ {
+@@ -289,7 +289,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ if (!fileExists(path.str().c_str()))
+ {
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff
new file mode 100644
index 000000000000..1c13c3e5cb6b
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff
@@ -0,0 +1,39 @@
+Joerg Bornkessel <hd_brummy@g.o> 22 Aug 2009
+diff -Naur graphtft-24.orig/Makefile graphtft-24/Makefile
+--- graphtft-24.orig/Makefile 2009-10-21 21:53:56.000000000 +0200
++++ graphtft-24/Makefile 2009-10-21 21:57:24.000000000 +0200
+@@ -158,10 +158,10 @@
+ DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+ ifdef HAVE_IMLIB
+- LIBS += `imlib2-config --libs`
++ LIBS += $(shell imlib2-config --libs)
+
+ ifdef HAVE_IMAGE_MAGICK
+- LIBS += `Magick++-config --libs`
++ LIBS += $(shell Magick++-config --libs)
+ DEFINES += -DHAVE_IMAGE_MAGICK
+ endif
+
+@@ -170,8 +170,8 @@
+ endif
+
+ ifdef HAVE_GTOP
+- GTOP_INC = `pkg-config libgtop-2.0 --cflags`
+- GTOP_LIB = `pkg-config libgtop-2.0 --libs`
++ GTOP_INC = $(shell pkg-config libgtop-2.0 --cflags)
++ GTOP_LIB = $(shell pkg-config libgtop-2.0 --libs)
+
+ DEFINES += -DWITH_SYSINFO
+ LIBS += $(GTOP_LIB)
+@@ -186,8 +186,8 @@
+ endif
+
+ ifdef HAVE_DFB
+- INCLUDES += `directfb-config --cflags`
+- LIBS += `directfb-config --libs`
++ INCLUDES += $(shell directfb-config --cflags)
++ LIBS += $(shell directfb-config --libs)
+ DEFINES += -DHAVE_DFB
+ endif
+
diff --git a/media-plugins/vdr-graphtft/metadata.xml b/media-plugins/vdr-graphtft/metadata.xml
index eb701f63dc17..d67657837d87 100644
--- a/media-plugins/vdr-graphtft/metadata.xml
+++ b/media-plugins/vdr-graphtft/metadata.xml
@@ -8,5 +8,10 @@
</maintainer>
<use>
<flag name='graphtft-fe'>Install external x11 remote frontend</flag>
+ <flag name='theme_avp'>graphTFT Alien vs. Predato theme</flag>
+ <flag name='theme_deepblue'>graphTFT default theme</flag>
+ <flag name='theme_deeppurple'>graphTFT Deep Purple theme</flag>
+ <flag name='theme_poetter'>graphTFT Poetter theme</flag>
+ <flag name='touchscreen'>Enable Touchscreen support</flag>
</use>
</pkgmetadata>
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
new file mode 100644
index 000000000000..ebe2240fdae8
--- /dev/null
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.2.24.ebuild,v 1.1 2009/10/22 14:26:13 hd_brummy Exp $
+
+EAPI="2"
+
+inherit eutils vdr-plugin
+
+#MY_P="${PN}-${PV/_rc/-rc}"
+#S="${WORKDIR}/graphtft-${PV/_rc/-rc}"
+
+S="${WORKDIR}/graphtft-24"
+
+DESCRIPTION="VDR plugin: GraphTFT"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+IUSE_THEMES="+theme_deepblue theme_avp theme_deeppurple theme_poetter"
+IUSE="${IUSE_THEMES} directfb graphtft-fe imagemagick touchscreen"
+
+DEPEND=">=media-video/vdr-1.6.0_p2-r1[graphtft]
+ media-fonts/ttf-bitstream-vera
+ media-libs/imlib2[png,jpeg]
+ gnome-base/libgtop
+ >=media-video/ffmpeg-0.4.8_p20090201
+ imagemagick? ( media-gfx/imagemagick[png,jpeg] )
+ directfb? ( dev-libs/DirectFB )
+ graphtft-fe? ( x11-libs/qt-gui:4 )"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND="theme_deepblue? ( =x11-themes/vdrgraphtft-deepblue-0.3.1 )
+ theme_avp? ( =x11-themes/vdrgraphtft-avp-0.3.1 )
+ theme_deeppurple? ( =x11-themes/vdrgraphtft-deeppurple-0.3.2 )
+ theme_poetter? ( =x11-themes/vdrgraphtft-poetter-0.3.2 )"
+
+PATCHES=("${FILESDIR}/${P}_gentoo.diff"
+ "${FILESDIR}/${P}_makefile.diff"
+ "${FILESDIR}/${P}_gcc-4.4.x.diff"
+ "${FILESDIR}/${P}_ffmpeg-0.5.diff")
+
+extpatch_v_check() {
+
+ EXTPATCH_V="`cat /var/db/pkg/media-video/vdr-*/vdr-*.ebuild | grep EXT_V | head -n 1 | cut -c8-9`"
+
+ if [ "${EXTPATCH_V}" -lt "65" ]; then
+ echo
+ eerror "You need an update of vdr with a newer EXTENSIONSPATCH version!"
+ eerror "minimal version of Extensionspatch = 65!"
+ eerror "graphtft will not work fullfilled"
+ echo
+ einfo "use VDR"
+ einfo ">=media-video/vdr-1.6.0_p2-r2"
+ einfo "or"
+ einfo ">=media-video/vdr-1.7.0-r1 from vdr-devel Overlay"
+ echo
+ fi
+}
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ extpatch_v_check
+}
+
+src_prepare() {
+
+ sed -i Makefile -e "s: WITH_X_COMM = 1:#WITH_X_COMM = 1:"
+
+ ! use touchscreen && sed -i Makefile -e "s:WITH_TOUCH = 1:#WITH_TOUCH = 1:"
+
+ use graphtft-fe && sed -i Makefile \
+ -e "s:#WITH_X_COMM:WITH_X_COMM:"
+
+ vdr-plugin_src_prepare
+
+ sed -i "${S}"/imlibrenderer/fbrenderer/fbrenderer.c \
+ -i "${S}"/imlibrenderer/dvbrenderer/mpeg2encoder.c \
+ -e "s:libavutil/avcodec.h:libavcodec/avcodec.h:"
+}
+
+src_compile() {
+ vdr-plugin_src_compile
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe
+ sed -i build.sh -e "s:qmake-qt4:qmake:"
+ ./clean.sh
+ ./build.sh || die "build.sh failed"
+ fi
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ keepdir /usr/share/vdr/graphTFT/themes
+
+ dosym /usr/share/fonts/ttf-bitstream-vera /usr/share/vdr/graphTFT/fonts
+
+ dodoc "${S}"/documents/{README,HISTORY,HOWTO.Themes,INSTALL}
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe && dobin graphtft-fe
+ doinit graphtft-fe
+ fi
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+
+ if use graphtft-fe; then
+ echo
+ elog "Graphtft-fe user:"
+ elog "Edit /etc/conf.d/vdr.graphtft"
+ elog "/etc/init.d/graphtft-fe start"
+ echo
+ fi
+}