summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2013-03-31 12:25:05 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2013-03-31 12:25:05 +0000
commit8344c97a2c6c93b3880d90af9145037b3e399cf2 (patch)
tree6a9efc66dea72c7bd451e90376ef73ca0e3f8904 /media-plugins/vdr-graphtft
parentbump, need >=vdr-1.7.34 (diff)
downloadgentoo-2-8344c97a2c6c93b3880d90af9145037b3e399cf2.tar.gz
gentoo-2-8344c97a2c6c93b3880d90af9145037b3e399cf2.tar.bz2
gentoo-2-8344c97a2c6c93b3880d90af9145037b3e399cf2.zip
bump
(Portage version: 2.1.11.50/cvs/Linux i686, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-plugins/vdr-graphtft')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog10
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_gcc-4.4.x.diff22
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_gentoo.diff139
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_makefile.diff67
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.3.7.ebuild97
5 files changed, 334 insertions, 1 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index 58692e93166f..43c6c6a3f95d 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.34 2013/01/24 13:05:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.35 2013/03/31 12:25:05 hd_brummy Exp $
+
+*vdr-graphtft-0.3.7 (31 Mar 2013)
+
+ 31 Mar 2013; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +vdr-graphtft-0.3.7.ebuild, +files/vdr-graphtft-0.3.7_gcc-4.4.x.diff,
+ +files/vdr-graphtft-0.3.7_gentoo.diff,
+ +files/vdr-graphtft-0.3.7_makefile.diff:
+ bump
24 Jan 2013; Alexis Ballier <aballier@gentoo.org> vdr-graphtft-0.3.4.ebuild,
+files/vdr-graphtft-0.3.4_ffmpeg-1.patch:
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_gcc-4.4.x.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_gcc-4.4.x.diff
new file mode 100644
index 000000000000..4e32c187ac10
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_gcc-4.4.x.diff
@@ -0,0 +1,22 @@
+diff -Naur graphtft-30.orig/graphtft-fe/common.cc graphtft-30/graphtft-fe/common.cc
+--- graphtft-30.orig/graphtft-fe/common.cc 2012-03-12 02:10:38.000000000 +0100
++++ graphtft-30/graphtft-fe/common.cc 2012-03-12 02:30:16.000000000 +0100
+@@ -11,6 +11,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #include <graphtft.hpp>
+
+diff -Naur graphtft-30.orig/graphtft-fe/graphtft.hpp graphtft-30/graphtft-fe/graphtft.hpp
+--- graphtft-30.orig/graphtft-fe/graphtft.hpp 2012-03-12 02:10:38.000000000 +0100
++++ graphtft-30/graphtft-fe/graphtft.hpp 2012-03-12 02:30:57.000000000 +0100
+@@ -16,6 +16,7 @@
+ #include <X11/Xlib.h>
+ #include <Imlib2.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #define __FRONTEND
+ #include <../common.h>
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_gentoo.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_gentoo.diff
new file mode 100644
index 000000000000..ea0e7ad3d748
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_gentoo.diff
@@ -0,0 +1,139 @@
+diff -Naur graphtft-30.orig/dfbrenderer/dfbrenderer.c graphtft-30/dfbrenderer/dfbrenderer.c
+--- graphtft-30.orig/dfbrenderer/dfbrenderer.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/dfbrenderer/dfbrenderer.c 2012-03-12 03:29:35.000000000 +0100
+@@ -257,7 +257,7 @@
+ {
+ // make path relative to the themes directory
+
+- asprintf(&path, "%s/graphTFT/themes/%s/%s",
++ asprintf(&path, "%s/themes/%s/%s",
+ confPath.c_str(), themePath.c_str(), p.c_str());
+ }
+ else
+@@ -281,7 +281,7 @@
+
+ // at least add the default path
+
+- asprintf(&path, "%s/graphTFT/fonts/", confPath.c_str());
++ asprintf(&path, "%s/fonts/", confPath.c_str());
+ tell(0, "Info: Adding font path '%s'", path);
+ fontPaths[count] = path;
+ free(path);
+@@ -483,7 +483,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s", fpath);
+@@ -561,7 +561,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s", fpath);
+diff -Naur graphtft-30.orig/dspitems.c graphtft-30/dspitems.c
+--- graphtft-30.orig/dspitems.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/dspitems.c 2012-03-12 03:30:16.000000000 +0100
+@@ -107,7 +107,7 @@
+ if (p[0] != '/')
+ {
+ p = string(GraphTFTSetup.PluginConfPath)
+- + "/graphTFT/themes/"
++ + "/themes/"
+ + string(Thms::theTheme->getDir())
+ + "/" + p;
+ }
+diff -Naur graphtft-30.orig/graphtft.c graphtft-30/graphtft.c
+--- graphtft-30.orig/graphtft.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/graphtft.c 2012-03-12 03:32:48.000000000 +0100
+@@ -22,6 +22,8 @@
+ #include <graphtft.h>
+ #include <span.h>
+
++#define DATA_DIR "/usr/share/vdr/graphTFT"
++
+ //***************************************************************************
+ // cGraphTFTMenu
+ //***************************************************************************
+@@ -300,13 +302,13 @@
+
+ // try to get the config dir
+
+- if (!ConfigDirectory())
+- return false;
++// if (!ConfigDirectory())
++// return false;
+
+ // init
+
+ GraphTFTSetup.setClient(this);
+- GraphTFTSetup.PluginConfPath = strdup(ConfigDirectory());
++ GraphTFTSetup.PluginConfPath = strdup(DATA_DIR);
+
+ #if APIVERSNUM < 10507
+ RegisterI18n(Phrases);
+@@ -322,7 +324,7 @@
+ if (loadThemes() != 0)
+ return false;
+
+- if (display->Init(_dev, ConfigDirectory(), port) != success)
++ if (display->Init(_dev, DATA_DIR, port) != success)
+ {
+ tell(0, "Error: Initializing graphTFT device faild, aborting!");
+
+@@ -355,8 +357,8 @@
+
+ // look for the themes in the config directory
+
+- asprintf(&buffer, "find %s/graphTFT/themes -follow -type f -name '*.theme' | sort",
+- ConfigDirectory());
++ asprintf(&buffer, "find %s/themes -follow -type f -name '*.theme' | sort",
++ DATA_DIR);
+
+ p = popen(buffer, "r");
+
+diff -Naur graphtft-30.orig/imlibrenderer/imlibrenderer.c graphtft-30/imlibrenderer/imlibrenderer.c
+--- graphtft-30.orig/imlibrenderer/imlibrenderer.c 2012-03-12 03:27:38.000000000 +0100
++++ graphtft-30/imlibrenderer/imlibrenderer.c 2012-03-12 03:33:54.000000000 +0100
+@@ -123,7 +123,7 @@
+ {
+ // make path relative to the themes directory
+
+- asprintf(&path, "%s/graphTFT/themes/%s/%s",
++ asprintf(&path, "%s/themes/%s/%s",
+ confPath.c_str(), themePath.c_str(), p.c_str());
+ }
+ else
+@@ -146,7 +146,7 @@
+
+ // at least add the default path
+
+- asprintf(&path, "%s/graphTFT/fonts/", confPath.c_str());
++ asprintf(&path, "%s/fonts/", confPath.c_str());
+ tell(0, "Info: Adding font path '%s'", path);
+ imlib_add_path_to_font_path(path);
+ free(path);
+@@ -217,7 +217,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ if (!fileExists(path.str().c_str()))
+ {
+@@ -291,7 +291,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ if (!fileExists(path.str().c_str()))
+ {
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_makefile.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_makefile.diff
new file mode 100644
index 000000000000..f638be630069
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.7_makefile.diff
@@ -0,0 +1,67 @@
+Joerg Bornkessel <hd_brummy@g.o> 22 Okt 2009
+Matthias Schwarzott <zzam@g.o> 23 Okt 2009
+diff -Naur graphtft-24.orig/Makefile graphtft-24/Makefile
+--- graphtft-24.orig/Makefile 2009-10-21 21:53:56.000000000 +0200
++++ graphtft-24/Makefile 2009-10-21 21:57:24.000000000 +0200
+@@ -158,10 +158,10 @@
+ DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+ ifdef HAVE_IMLIB
+- LIBS += `imlib2-config --libs`
++ LIBS += $(shell imlib2-config --libs)
+
+ ifdef HAVE_IMAGE_MAGICK
+- LIBS += `Magick++-config --libs`
++ LIBS += $(shell Magick++-config --libs)
+ DEFINES += -DHAVE_IMAGE_MAGICK
+ endif
+
+@@ -170,8 +170,8 @@
+ endif
+
+ ifdef HAVE_GTOP
+- GTOP_INC = `pkg-config libgtop-2.0 --cflags`
+- GTOP_LIB = `pkg-config libgtop-2.0 --libs`
++ GTOP_INC = $(shell pkg-config libgtop-2.0 --cflags)
++ GTOP_LIB = $(shell pkg-config libgtop-2.0 --libs)
+
+ DEFINES += -DWITH_SYSINFO
+ LIBS += $(GTOP_LIB)
+@@ -186,8 +186,8 @@
+ endif
+
+ ifdef HAVE_DFB
+- INCLUDES += `directfb-config --cflags`
+- LIBS += `directfb-config --libs`
++ INCLUDES += $(shell directfb-config --cflags)
++ LIBS += $(shell directfb-config --libs)
+ DEFINES += -DHAVE_DFB
+ endif
+
+diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefile
+--- graphtft-24.orig/graphtft-fe/Makefile 2009-10-22 17:39:55.000000000 +0200
++++ graphtft-24/graphtft-fe/Makefile 2009-10-22 17:41:29.000000000 +0200
+@@ -1,9 +1,9 @@
+
+ CXX = g++
+ CXXFLAGS = -pipe -ggdb -O2 -Wall -W -D_REENTRANT -fPIC
+-INCPATH = -I. `Magick++-config --cppflags`
++INCPATH = -I. $(shell Magick++-config --cppflags)
+ LFLAGS = -Wl,--no-undefined
+-LIBS = -lpthread `imlib2-config --libs` `Magick++-config --libs`
++LIBS = -lpthread $(shell imlib2-config --libs) $(shell Magick++-config --libs)
+ AR = ar
+
+ TARGET = graphtft-fe
+diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefile
+--- graphtft-24.orig/graphtft-fe/Makefile 2009-10-23 16:20:43.000000000 +0200
++++ graphtft-24/graphtft-fe/Makefile 2009-10-23 16:21:20.000000000 +0200
+@@ -17,7 +17,7 @@
+
+ all:
+ echo Build graphTFT Frontend
+- @(make $(TARGET))
++ @$(MAKE) $(TARGET)
+
+
+ $(TARGET): $(OBJECTS)
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.3.7.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.7.ebuild
new file mode 100644
index 000000000000..3995f243f352
--- /dev/null
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.3.7.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.3.7.ebuild,v 1.1 2013/03/31 12:25:05 hd_brummy Exp $
+
+EAPI="5"
+
+inherit vdr-plugin-2 flag-o-matic
+
+RESTRICT="test"
+
+DESCRIPTION="VDR plugin: GraphTFT"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin"
+SRC_URI="http://www.jwendel.de/vdr/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+IUSE_THEMES="+theme_deepblue theme_avp theme_deeppurple theme_poetter"
+IUSE="${IUSE_THEMES} directfb graphtft-fe imagemagick touchscreen"
+
+DEPEND=">=media-video/vdr-1.7.27[graphtft]
+ media-libs/imlib2[png,jpeg]
+ gnome-base/libgtop
+ >=virtual/ffmpeg-0.4.8_p20090201
+ imagemagick? ( media-gfx/imagemagick[png,jpeg,cxx] )
+ directfb? ( dev-libs/DirectFB )
+ graphtft-fe? ( media-libs/imlib2[png,jpeg,X] )"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND="theme_deepblue? ( =x11-themes/vdrgraphtft-deepblue-0.3.1 )
+ theme_avp? ( =x11-themes/vdrgraphtft-avp-0.3.1 )
+ theme_deeppurple? ( =x11-themes/vdrgraphtft-deeppurple-0.3.2 )
+ theme_poetter? ( =x11-themes/vdrgraphtft-poetter-0.3.2 )"
+
+PATCHES=("${FILESDIR}/${P}_gentoo.diff"
+ "${FILESDIR}/${P}_makefile.diff"
+ "${FILESDIR}/${P}_gcc-4.4.x.diff")
+
+src_prepare() {
+
+ # remove untranslated Language
+ rm "${S}"/po/{ca_ES,cs_CZ,da_DK,el_GR,es_ES,et_EE,fr_FR,hr_HR,hu_HU,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ sed -i Makefile -e "s: WITH_X_COMM = 1:#WITH_X_COMM = 1:"
+
+ ! use touchscreen && sed -i Makefile \
+ -e "s:WITH_TOUCH = 1:#WITH_TOUCH = 1:"
+
+ use graphtft-fe && sed -i Makefile \
+ -e "s:#WITH_X_COMM:WITH_X_COMM:"
+
+ vdr-plugin-2_src_prepare
+
+ remove_i18n_include graphtft.h setup.h
+
+ # UINT64_C is needed by ffmpeg headers
+ append-cxxflags -D__STDC_CONSTANT_MACROS
+
+ if has_version ">=media-video/vdr-1.7.33"; then
+ sed -i dspitems.c \
+ -e "s:int timerMatch = 0:eTimerMatch timerMatch = tmNone:"
+ fi
+}
+
+src_compile() {
+ vdr-plugin-2_src_compile
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe
+ emake
+ fi
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ dodoc "${S}"/documents/{README,HISTORY,HOWTO.Themes,INSTALL}
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe && dobin graphtft-fe
+ doinit graphtft-fe
+ fi
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ if use graphtft-fe; then
+ echo
+ elog "Graphtft-fe user:"
+ elog "Edit /etc/conf.d/vdr.graphtft"
+ elog "/etc/init.d/graphtft-fe start"
+ echo
+ fi
+}