summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2013-10-05 16:46:26 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2013-10-05 16:46:26 +0000
commit3783e7ab1612b734b5c441931fb23d33b58e2e6b (patch)
tree2b350825f0ebbe79fa1c7b9204c40c631a34eca8 /media-plugins/vdr-live
parentarm stable, bug #475480 (diff)
downloadgentoo-2-3783e7ab1612b734b5c441931fb23d33b58e2e6b.tar.gz
gentoo-2-3783e7ab1612b734b5c441931fb23d33b58e2e6b.tar.bz2
gentoo-2-3783e7ab1612b734b5c441931fb23d33b58e2e6b.zip
Workaround for recent cxxtools versions, http://projects.vdr-developer.org/issues/1351
(Portage version: 2.2.1/cvs/Linux i686, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-plugins/vdr-live')
-rw-r--r--media-plugins/vdr-live/ChangeLog9
-rw-r--r--media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild99
2 files changed, 107 insertions, 1 deletions
diff --git a/media-plugins/vdr-live/ChangeLog b/media-plugins/vdr-live/ChangeLog
index 1256a376f574..26cd6a4f065f 100644
--- a/media-plugins/vdr-live/ChangeLog
+++ b/media-plugins/vdr-live/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-live
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.40 2013/04/07 18:20:39 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.41 2013/10/05 16:46:26 hd_brummy Exp $
+
+*vdr-live-0.3.0_p20130504 (05 Oct 2013)
+
+ 05 Oct 2013; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +vdr-live-0.3.0_p20130504.ebuild:
+ Workaround for recent cxxtools versions,
+ http://projects.vdr-developer.org/issues/1351
*vdr-live-0.3.0-r1 (07 Apr 2013)
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild
new file mode 100644
index 000000000000..161c5c727b9e
--- /dev/null
+++ b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.3.0_p20130504.ebuild,v 1.1 2013/10/05 16:46:26 hd_brummy Exp $
+
+EAPI="5"
+
+inherit vdr-plugin-2 ssl-cert
+
+DESCRIPTION="VDR Plugin: Web Access To Settings"
+HOMEPAGE="http://live.vdr-developer.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pcre ssl"
+
+DEPEND="media-video/vdr
+ >=dev-libs/tntnet-2.0[ssl=,sdk]
+ >=dev-libs/cxxtools-2.0
+ pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+VDR_CONFD_FILE="${FILESDIR}/confd-0.2"
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.2.sh"
+
+KEEP_I18NOBJECT="yes"
+
+make_live_cert() {
+ # TODO: still true?
+ # ssl-cert eclass creates a "invalid" cert, create our own one
+ local base=$(get_base 1)
+ local keydir="/etc/vdr/plugins/live"
+
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
+ SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
+
+ echo
+ gen_cnf || return 1
+ echo
+ gen_key 1 || return 1
+ gen_csr 1 || return 1
+ gen_crt 1 || return 1
+ echo
+
+ install -d "${ROOT}${keydir}"
+ install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
+ install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
+ chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live{,-key}.pem
+}
+
+src_prepare() {
+ # remove untranslated language files
+ rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nl_NL,nn_NO,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ vdr-plugin-2_src_prepare
+
+ if ! use pcre; then
+ sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
+ fi
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /usr/share/vdr/plugins/live
+ doins -r live/*
+
+ fowners -R vdr:vdr /usr/share/vdr/plugins/live
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "To be able to use all functions of vdr-live"
+ elog "you should emerge and enable"
+ elog "media-plugins/vdr-epgsearch to search the EPG,"
+ elog "media-plugins/vdr-streamdev for Live-TV streaming"
+
+ elog "The default username/password is:"
+ elog "\tadmin:live"
+
+ if use ssl ; then
+ if path_exists -a "${ROOT}"/etc/vdr/plugins/live/live.pem; then
+ einfo "found an existing SSL cert, to create a new SSL cert, run:\n"
+ einfo "emerge --config ${PN}"
+ else
+ einfo "No SSL cert found, creating a default one now"
+ make_live_cert
+ fi
+ fi
+}
+
+pkg_config() {
+ make_live_cert
+}