summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-06-24 12:24:06 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-06-24 12:24:06 +0000
commit1e2df41557a6833d86a8b6879a701ab89740bcae (patch)
tree9aab49ab17c7ae6c93d44e69a327451164593d2e /media-plugins/vdr-osdpip
parentVersion bump. (diff)
downloadgentoo-2-1e2df41557a6833d86a8b6879a701ab89740bcae.tar.gz
gentoo-2-1e2df41557a6833d86a8b6879a701ab89740bcae.tar.bz2
gentoo-2-1e2df41557a6833d86a8b6879a701ab89740bcae.zip
Make it compile with vdr-1.5
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'media-plugins/vdr-osdpip')
-rw-r--r--media-plugins/vdr-osdpip/ChangeLog8
-rw-r--r--media-plugins/vdr-osdpip/files/digest-vdr-osdpip-0.0.8-r23
-rw-r--r--media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.8-vdr-1.5.0.diff47
-rw-r--r--media-plugins/vdr-osdpip/vdr-osdpip-0.0.8-r2.ebuild33
4 files changed, 90 insertions, 1 deletions
diff --git a/media-plugins/vdr-osdpip/ChangeLog b/media-plugins/vdr-osdpip/ChangeLog
index d461191332f4..5e6c7fc5e585 100644
--- a/media-plugins/vdr-osdpip/ChangeLog
+++ b/media-plugins/vdr-osdpip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-osdpip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.2 2007/06/19 12:02:40 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/ChangeLog,v 1.3 2007/06/24 12:24:06 zzam Exp $
+
+*vdr-osdpip-0.0.8-r2 (24 Jun 2007)
+
+ 24 Jun 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-osdpip-0.0.8-vdr-1.5.0.diff, +vdr-osdpip-0.0.8-r2.ebuild:
+ Make it compile with vdr-1.5
19 Jun 2007; Matthias Schwarzott <zzam@gentoo.org>
vdr-osdpip-0.0.8-r1.ebuild:
diff --git a/media-plugins/vdr-osdpip/files/digest-vdr-osdpip-0.0.8-r2 b/media-plugins/vdr-osdpip/files/digest-vdr-osdpip-0.0.8-r2
new file mode 100644
index 000000000000..11b69ddea2bb
--- /dev/null
+++ b/media-plugins/vdr-osdpip/files/digest-vdr-osdpip-0.0.8-r2
@@ -0,0 +1,3 @@
+MD5 d3baa1b58be91aa03a93e0030f2012da vdr-osdpip-0.0.8.tgz 25918
+RMD160 58752d70a5ca01e3cbfec0f533162f9b5cc0abbf vdr-osdpip-0.0.8.tgz 25918
+SHA256 4901aad58b75662dcf58388f8636c96ea7a31efd195f1dce6af21c6653ee9a67 vdr-osdpip-0.0.8.tgz 25918
diff --git a/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.8-vdr-1.5.0.diff b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.8-vdr-1.5.0.diff
new file mode 100644
index 000000000000..29115870d5f7
--- /dev/null
+++ b/media-plugins/vdr-osdpip/files/vdr-osdpip-0.0.8-vdr-1.5.0.diff
@@ -0,0 +1,47 @@
+Index: osdpip-0.0.8/osd.c
+===================================================================
+--- osdpip-0.0.8.orig/osd.c
++++ osdpip-0.0.8/osd.c
+@@ -71,7 +71,11 @@ void cOsdPipObject::SwapChannels(void)
+ if (chan) {
+ Stop();
+ Channels.SwitchTo(m_Channel->Number());
++#if VDRVERSNUM >= 10500
++ cDevice *dev = cDevice::GetDevice(chan, 1, false);
++#else
+ cDevice *dev = cDevice::GetDevice(chan, 1);
++#endif
+ if (dev) {
+ DELETENULL(m_Receiver);
+ m_Channel = chan;
+Index: osdpip-0.0.8/osdpip.c
+===================================================================
+--- osdpip-0.0.8.orig/osdpip.c
++++ osdpip-0.0.8/osdpip.c
+@@ -89,7 +89,11 @@ cOsdObject *cPluginOsdpip::MainMenuActio
+ chan = cDevice::CurrentChannel() != 0
+ ? Channels.GetByNumber(cDevice::CurrentChannel()) : NULL;
+ if (chan != NULL) {
++#if VDRVERSNUM >= 10500
++ dev = cDevice::GetDevice(chan, 1, false);
++#else
+ dev = cDevice::GetDevice(chan, 1);
++#endif
+ if (dev)
+ return new cOsdPipObject(dev, chan);
+ }
+Index: osdpip-0.0.8/receiver.c
+===================================================================
+--- osdpip-0.0.8.orig/receiver.c
++++ osdpip-0.0.8/receiver.c
+@@ -14,7 +14,9 @@
+
+ cOsdPipReceiver::cOsdPipReceiver(const cChannel *Channel,
+ cRingBufferFrame *ESBuffer):
+-#if VDRVERSNUM >= 10319
++#if VDRVERSNUM >= 10500
++ cReceiver(Channel->GetChannelID(), 0, Channel->Vpid())
++#elif VDRVERSNUM >= 10319
+ cReceiver(Channel->Ca(), 0, Channel->Vpid())
+ #else
+ cReceiver(Channel->Ca(), 0, 1, Channel->Vpid())
diff --git a/media-plugins/vdr-osdpip/vdr-osdpip-0.0.8-r2.ebuild b/media-plugins/vdr-osdpip/vdr-osdpip-0.0.8-r2.ebuild
new file mode 100644
index 000000000000..72d00c2bd31d
--- /dev/null
+++ b/media-plugins/vdr-osdpip/vdr-osdpip-0.0.8-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2003-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-osdpip/vdr-osdpip-0.0.8-r2.ebuild,v 1.1 2007/06/24 12:24:06 zzam Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: Show another channel in the OSD"
+HOMEPAGE="http://www.magoa.net/linux"
+SRC_URI="http://www.magoa.net/linux/files/${P}.tgz"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.7
+ >=media-libs/libmpeg2-0.4.0
+ >=media-video/ffmpeg-0.4.8
+ "
+
+PATCHES="${FILESDIR}/${P}-includes.diff
+ ${FILESDIR}/${P}-gcc4.diff
+ ${FILESDIR}/${P}-vdr-1.5.0.diff"
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ /bin/sed -i Makefile \
+ -e 's+^FFMDIR.*$+FFMDIR = /usr/include/ffmpeg+' \
+ -e 's+-I\$(FFMDIR)/libavcodec+-I$(FFMDIR)+' \
+ -e 's+-L\$(FFMDIR)/libavcodec++'
+}
+