summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-10-11 10:29:00 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-10-11 10:29:00 +0000
commit3b10179199fa2606f271de447acfd18cfe324cfc (patch)
treeab33aa8d7eda17014642662a4e934a86f5d17db4 /media-plugins/vdr-softdevice
parentRemoved masking of media-plugins/vdr-xineliboutput-1.0.0_pre4 as this ebuild-... (diff)
downloadgentoo-2-3b10179199fa2606f271de447acfd18cfe324cfc.tar.gz
gentoo-2-3b10179199fa2606f271de447acfd18cfe324cfc.tar.bz2
gentoo-2-3b10179199fa2606f271de447acfd18cfe324cfc.zip
Added patch from softdevice-cvs to prevent a segfault when having nonzero cutting parameter in combination with YUY2-pixelformat.
(Portage version: 2.1.2_pre2-r8)
Diffstat (limited to 'media-plugins/vdr-softdevice')
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog10
-rw-r--r--media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.0-r13
-rw-r--r--media-plugins/vdr-softdevice/files/vdr-softdevice-0.3.0-YUY2-cut-segfault.diff38
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.3.0-r1.ebuild132
4 files changed, 182 insertions, 1 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index 988898729656..b6daad7853fb 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.21 2006/10/09 21:24:51 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.22 2006/10/11 10:29:00 zzam Exp $
+
+*vdr-softdevice-0.3.0-r1 (11 Oct 2006)
+
+ 11 Oct 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-softdevice-0.3.0-YUY2-cut-segfault.diff,
+ +vdr-softdevice-0.3.0-r1.ebuild:
+ Added patch from softdevice-cvs to prevent a segfault when having nonzero
+ cutting parameter in combination with YUY2-pixelformat.
*vdr-softdevice-0.3.0 (09 Oct 2006)
diff --git a/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.0-r1 b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.0-r1
new file mode 100644
index 000000000000..ac181d951443
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.0-r1
@@ -0,0 +1,3 @@
+MD5 0be5f52328bd649a33f31df4cd905455 vdr-softdevice-0.3.0.tgz 154294
+RMD160 fce250ac59e0a4bd3122fbed85bb6d8a6f4c2ebe vdr-softdevice-0.3.0.tgz 154294
+SHA256 2c15bfaf94c07dda3facd3c44219c4d9ebb1199093ec0aa4d35c1d3f67828b8a vdr-softdevice-0.3.0.tgz 154294
diff --git a/media-plugins/vdr-softdevice/files/vdr-softdevice-0.3.0-YUY2-cut-segfault.diff b/media-plugins/vdr-softdevice/files/vdr-softdevice-0.3.0-YUY2-cut-segfault.diff
new file mode 100644
index 000000000000..660e6fdcedfe
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/vdr-softdevice-0.3.0-YUY2-cut-segfault.diff
@@ -0,0 +1,38 @@
+diff -ru --exclude=CVS softdevice-0.3.0/CHANGELOG softdevice-cvs/CHANGELOG
+--- softdevice-0.3.0/CHANGELOG 2006-10-09 00:28:53.000000000 +0200
++++ softdevice-cvs/CHANGELOG 2006-10-11 12:22:23.000000000 +0200
+@@ -1,4 +1,8 @@
+ Changelog
++2006-10-10:
++ - fix segfaults when YUY2 pixelformat is used for xv-out and cut lines
++ from top is non zero. This fixes wrong colors and misplaced OSD drawing
++ too, when cut colums from left is non zero.
+ 2006-10-09: softdevice-0.3.0
+ 2006-10-03:
+ - fix hang after long pause.
+Nur in softdevice-cvs: .cvsignore.
+diff -ru --exclude=CVS softdevice-0.3.0/PicBuffer.c softdevice-cvs/PicBuffer.c
+--- softdevice-0.3.0/PicBuffer.c 2006-10-01 14:08:05.000000000 +0200
++++ softdevice-cvs/PicBuffer.c 2006-10-11 12:22:23.000000000 +0200
+@@ -326,7 +326,10 @@
+ int dstStride=dst->stride[0];
+ int lumStride=src->stride[0];
+ int chromStride=src->stride[1];
+-
++
++ height -= 2 * (cutTop + cutBottom);
++ width -= 2 * (cutLeft + cutRight);
++
+ if (src->interlaced_frame) {
+ for(int y=height/4; y--; ) {
+ /* ---------------------------------------------
+@@ -492,6 +495,9 @@
+ int lumStride=src->stride[0];
+ int chromStride=src->stride[1];
+
++ height -= 2 * (cutTop + cutBottom);
++ width -= 2 * (cutLeft + cutRight);
++
+ if (src->interlaced_frame) {
+ for(int y=height/4; y--; ) {
+ /* ---------------------------------------------
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.3.0-r1.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..b6ad6d2b7f2f
--- /dev/null
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.0-r1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.3.0-r1.ebuild,v 1.1 2006/10/11 10:29:00 zzam Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+SRC_URI="mirror://gentoo/${P}.tgz
+ http://dev.gentoo.org/~zzam/distfiles/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xv fbcon directfb mmx mmxext xinerama"
+
+RDEPEND=">=media-video/vdr-1.3.36
+ >=media-video/ffmpeg-0.4.9_pre1
+ directfb? (
+ dev-libs/DirectFB
+ dev-libs/DFB++
+ )
+ media-libs/alsa-lib
+ xv? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXv
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ ) )"
+
+DEPEND="${RDEPEND}
+ xv? ( || ( ( x11-proto/xproto
+ x11-proto/xextproto
+ x11-libs/libXv
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ ) )
+ fbcon? ( sys-kernel/linux-headers )"
+
+
+PATCHES="
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
+ ${FILESDIR}/softdevice-cvs-xinerama-configure-opts.patch
+ ${FILESDIR}/vdr-softdevice-0.3.0-YUY2-cut-segfault.diff"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if use !xv && use !fbcon && use !directfb; then
+ ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+ die "no output-method enabled"
+ fi
+
+ COMPILE_SHM=0
+ if has_version ">=media-video/vdr-1.3.0"; then
+ if use xv; then
+ COMPILE_SHM=1
+ else
+ einfo "SHM does only support xv at the moment"
+ fi
+ else
+ einfo "SHM not supported on vdr-1.2"
+ fi
+ case ${COMPILE_SHM} in
+ 0) einfo "SHM support will not be compiled." ;;
+ 1) einfo "SHM support will be compiled." ;;
+ esac
+
+ # Check for ffmpeg relying on libtheora without pkg-config-file
+ # Bug #142250
+ if built_with_use media-video/ffmpeg theora && \
+ has_version "<media-libs/libtheora/libtheora-1.0_alpha4"; then
+
+ eerror "This package will not work when using ffmpeg with"
+ eerror "USE=\"theora\" combined with media-libs/libtheora"
+ eerror "older than version 1.0_alpha4."
+ eerror "Please update to at least media-libs/libtheora-1.0_alpha4."
+ die "Please update to at least media-libs/libtheora-1.0_alpha4."
+ fi
+}
+
+src_compile() {
+ local MYOPTS=""
+ MYOPTS="${MYOPTS} --disable-vidix"
+ use xv || MYOPTS="${MYOPTS} --disable-xv"
+ use fbcon || MYOPTS="${MYOPTS} --disable-fb"
+ use directfb || MYOPTS="${MYOPTS} --disable-dfb"
+
+ # MMX-Support
+ # hardcode mmx for amd64 - do not disable even without use-flag
+ if ! use amd64; then
+ use mmx || MYOPTS="${MYOPTS} --disable-mmx"
+ use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
+
+ if use !mmx && use !mmxext; then
+ ewarn "${PN}"' does not compile with USE="-mmx -mmxext".'
+ ewarn 'Please enable at least one of these two use-flags.'
+ die "${PN}"' does not compile with USE="-mmx -mmxext".'
+ fi
+ fi
+
+ use xinerama || MYOPTS="${MYOPTS} --disable-xinerama"
+
+ [[ ${COMPILE_SHM} == 1 ]] || MYOPTS="${MYOPTS} --disable-shm"
+
+ cd ${S}
+ einfo configure ${MYOPTS}
+ ./configure ${MYOPTS} || die "configure failed"
+
+ vdr-plugin_src_compile
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ cd ${S}
+
+ insinto "${VDR_PLUGIN_DIR}"
+ doins libsoftdevice-*.so.*
+
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ exeinto "/usr/bin"
+ doexe ShmClient
+ fi
+
+ insinto /usr/include/vdr-softdevice
+ doins *.h
+}
+