summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-11-23 12:44:17 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-11-23 12:44:17 +0000
commitc4d3c02d954f0e96e64032a0a072f6f6e7c188b8 (patch)
tree02198b3779ea32036b1e27fe27898c1cc2ee9a85 /media-plugins/vdr-softdevice
parentStable on hppa. (diff)
downloadgentoo-2-c4d3c02d954f0e96e64032a0a072f6f6e7c188b8.tar.gz
gentoo-2-c4d3c02d954f0e96e64032a0a072f6f6e7c188b8.tar.bz2
gentoo-2-c4d3c02d954f0e96e64032a0a072f6f6e7c188b8.zip
No longer kill ShmClient at vdr-restart, as it seems to work now without that.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'media-plugins/vdr-softdevice')
-rw-r--r--media-plugins/vdr-softdevice/ChangeLog8
-rw-r--r--media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1-r23
-rw-r--r--media-plugins/vdr-softdevice/files/rc-addon.sh12
-rw-r--r--media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r2.ebuild133
4 files changed, 143 insertions, 13 deletions
diff --git a/media-plugins/vdr-softdevice/ChangeLog b/media-plugins/vdr-softdevice/ChangeLog
index c144959e4d05..d5544b8468bb 100644
--- a/media-plugins/vdr-softdevice/ChangeLog
+++ b/media-plugins/vdr-softdevice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-softdevice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.28 2006/11/14 09:27:13 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.29 2006/11/23 12:44:16 zzam Exp $
+
+*vdr-softdevice-0.3.1-r2 (23 Nov 2006)
+
+ 23 Nov 2006; Matthias Schwarzott <zzam@gentoo.org> files/rc-addon.sh,
+ -vdr-softdevice-0.3.1-r1.ebuild, +vdr-softdevice-0.3.1-r2.ebuild:
+ No longer kill ShmClient at vdr-restart, as it seems to work now without that.
*vdr-softdevice-0.3.1-r1 (14 Nov 2006)
diff --git a/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1-r2 b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1-r2
new file mode 100644
index 000000000000..bdd142b55ec4
--- /dev/null
+++ b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1-r2
@@ -0,0 +1,3 @@
+MD5 269777294df93a027ac9dc849af0edb2 vdr-softdevice-0.3.1.tgz 154509
+RMD160 b582215eca1c0ce954eca54045456145488b1b34 vdr-softdevice-0.3.1.tgz 154509
+SHA256 d88fc234ad6d3686b95d4848519ffdb97ee22a1fcd8cff60d737c0ecb1a43252 vdr-softdevice-0.3.1.tgz 154509
diff --git a/media-plugins/vdr-softdevice/files/rc-addon.sh b/media-plugins/vdr-softdevice/files/rc-addon.sh
index f93d00ff7cf6..d87a58f445d4 100644
--- a/media-plugins/vdr-softdevice/files/rc-addon.sh
+++ b/media-plugins/vdr-softdevice/files/rc-addon.sh
@@ -8,15 +8,3 @@ plugin_pre_vdr_start() {
add_plugin_param "-ao ${SOFTDEVICE_AUDIO_OUT}:${SOFTDEVICE_AUDIO_OUT_SUBOPTS}"
fi
}
-
-plugin_pre_vdr_stop() {
- if [[ ${SOFTDEVICE_VIDEO_OUT} == "shm" ]]; then
- killall ShmClient 2>/dev/null
- fi
-}
-
-# for compatibility
-if [[ ${SCRIPT_API:-1} -lt 2 ]]; then
- plugin_pre_vdr_start
-fi
-
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r2.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..69f1a313aa7d
--- /dev/null
+++ b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r2.ebuild,v 1.1 2006/11/23 12:44:16 zzam Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+SRC_URI="mirror://gentoo/${P}.tgz
+ http://dev.gentoo.org/~zzam/distfiles/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xv fbcon directfb mmx mmxext xinerama"
+
+RDEPEND=">=media-video/vdr-1.3.36
+ >=media-video/ffmpeg-0.4.9_pre1
+ directfb? (
+ dev-libs/DirectFB
+ dev-libs/DFB++
+ )
+ media-libs/alsa-lib
+ xv? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXv
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ ) )"
+
+DEPEND="${RDEPEND}
+ xv? ( || ( ( x11-proto/xproto
+ x11-proto/xextproto
+ x11-libs/libXv
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ ) )
+ fbcon? ( sys-kernel/linux-headers )
+ dev-util/pkgconfig"
+
+
+PATCHES="
+ ${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
+ ${FILESDIR}/softdevice-cvs-xinerama-configure-opts.patch
+ ${FILESDIR}/vdr-softdevice-0.3.1-osdmode-software-default.diff"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if use !xv && use !fbcon && use !directfb; then
+ ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+ die "no output-method enabled"
+ fi
+
+ COMPILE_SHM=0
+ if has_version ">=media-video/vdr-1.3.0"; then
+ if use xv; then
+ COMPILE_SHM=1
+ else
+ einfo "SHM does only support xv at the moment"
+ fi
+ else
+ einfo "SHM not supported on vdr-1.2"
+ fi
+ case ${COMPILE_SHM} in
+ 0) einfo "SHM support will not be compiled." ;;
+ 1) einfo "SHM support will be compiled." ;;
+ esac
+
+ # Check for ffmpeg relying on libtheora without pkg-config-file
+ # Bug #142250
+ if built_with_use media-video/ffmpeg theora && \
+ has_version "<media-libs/libtheora/libtheora-1.0_alpha4"; then
+
+ eerror "This package will not work when using ffmpeg with"
+ eerror "USE=\"theora\" combined with media-libs/libtheora"
+ eerror "older than version 1.0_alpha4."
+ eerror "Please update to at least media-libs/libtheora-1.0_alpha4."
+ die "Please update to at least media-libs/libtheora-1.0_alpha4."
+ fi
+}
+
+src_compile() {
+ local MYOPTS=""
+ MYOPTS="${MYOPTS} --disable-vidix"
+ use xv || MYOPTS="${MYOPTS} --disable-xv"
+ use fbcon || MYOPTS="${MYOPTS} --disable-fb"
+ use directfb || MYOPTS="${MYOPTS} --disable-dfb"
+
+ # MMX-Support
+ # hardcode mmx for amd64 - do not disable even without use-flag
+ if ! use amd64; then
+ use mmx || MYOPTS="${MYOPTS} --disable-mmx"
+ use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
+
+ if use !mmx && use !mmxext; then
+ ewarn "${PN}"' does not compile with USE="-mmx -mmxext".'
+ ewarn 'Please enable at least one of these two use-flags.'
+ die "${PN}"' does not compile with USE="-mmx -mmxext".'
+ fi
+ fi
+
+ use xinerama || MYOPTS="${MYOPTS} --disable-xinerama"
+
+ [[ ${COMPILE_SHM} == 1 ]] || MYOPTS="${MYOPTS} --disable-shm"
+
+ cd ${S}
+ einfo configure ${MYOPTS}
+ ./configure ${MYOPTS} || die "configure failed"
+
+ vdr-plugin_src_compile
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ cd ${S}
+
+ insinto "${VDR_PLUGIN_DIR}"
+ doins libsoftdevice-*.so.*
+
+ if [[ "${COMPILE_SHM}" = "1" ]]; then
+ exeinto "/usr/bin"
+ doexe ShmClient
+ fi
+
+ insinto /usr/include/vdr-softdevice
+ doins *.h
+}
+