summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-30 08:35:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-30 08:35:31 +0000
commitef43d15b5e5061e3b1c95a53739b46f0e763f96d (patch)
tree0561d74dc5a82b04cc3b8550c5be4b258e6c52b6 /media-plugins/xmms-shell
parentmoved x11-misc/ikons to x11-themes/ikons (diff)
downloadgentoo-2-ef43d15b5e5061e3b1c95a53739b46f0e763f96d.tar.gz
gentoo-2-ef43d15b5e5061e3b1c95a53739b46f0e763f96d.tar.bz2
gentoo-2-ef43d15b5e5061e3b1c95a53739b46f0e763f96d.zip
moved xmms plugins from media-sound to media-plugins
Diffstat (limited to 'media-plugins/xmms-shell')
-rw-r--r--media-plugins/xmms-shell/ChangeLog30
-rw-r--r--media-plugins/xmms-shell/files/digest-xmms-shell-0.99.0-r11
-rw-r--r--media-plugins/xmms-shell/files/xmms-shell-gcc3.patch68
-rw-r--r--media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild38
4 files changed, 137 insertions, 0 deletions
diff --git a/media-plugins/xmms-shell/ChangeLog b/media-plugins/xmms-shell/ChangeLog
new file mode 100644
index 000000000000..e396f716bbd9
--- /dev/null
+++ b/media-plugins/xmms-shell/ChangeLog
@@ -0,0 +1,30 @@
+# ChangeLog for media-sound/xmms-shell
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/ChangeLog,v 1.1 2002/08/30 08:35:31 seemant Exp $
+
+*xmms-shell-0.99.0-r1 (9 May 2002)
+
+ 30 Aug 2002; Seemant Kulleen <seemant@gentoo.org> * :
+
+ Relocated to media-plugins
+
+ 15 Aug 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ xmms-shell-0.99.0-r1.ebuild :
+
+ Patch works with gcc2.
+
+ 9 May 2000; Matthew Kennedy <mkennedy@gentoo.org>
+ xmms-shell-0.99.0-r1.ebuild :ChangeLog,
+ files/digest-xmms-shell-0.99.0-r1, files/xmms-shell-gcc3.patch :
+
+ Conditional patch for a GCC3 profile. Patch shall be sent upstream.
+
+*xmms-shell-0.99.0 (5 May 2002)
+
+ 5 May 2002; Ryan Phillips <rphillips@gentoo.org> xmms-shell-0.99.0.ebuild :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/media-plugins/xmms-shell/files/digest-xmms-shell-0.99.0-r1 b/media-plugins/xmms-shell/files/digest-xmms-shell-0.99.0-r1
new file mode 100644
index 000000000000..9ac88339d0d0
--- /dev/null
+++ b/media-plugins/xmms-shell/files/digest-xmms-shell-0.99.0-r1
@@ -0,0 +1 @@
+MD5 a1685669f12770fbce0ea412e4e8e7da xmms-shell-0.99.0.tar.gz 51914
diff --git a/media-plugins/xmms-shell/files/xmms-shell-gcc3.patch b/media-plugins/xmms-shell/files/xmms-shell-gcc3.patch
new file mode 100644
index 000000000000..7c3bb7a5990d
--- /dev/null
+++ b/media-plugins/xmms-shell/files/xmms-shell-gcc3.patch
@@ -0,0 +1,68 @@
+diff -ur xmms-shell-0.99.0.original/include/command.h xmms-shell-0.99.0/include/command.h
+--- xmms-shell-0.99.0.original/include/command.h 2002-02-11 01:07:27.000000000 -0600
++++ xmms-shell-0.99.0/include/command.h 2002-05-09 08:02:00.000000000 -0500
+@@ -5,6 +5,8 @@
+ #include <vector>
+ #include <string>
+
++using namespace std;
++
+ #define COMFLAG_INTERACTIVE 0x1
+
+ #define COMERR_NOEFFECT 123
+diff -ur xmms-shell-0.99.0.original/src/eval.cc xmms-shell-0.99.0/src/eval.cc
+--- xmms-shell-0.99.0.original/src/eval.cc 2002-02-10 22:59:34.000000000 -0600
++++ xmms-shell-0.99.0/src/eval.cc 2002-05-09 08:02:24.000000000 -0500
+@@ -3,6 +3,8 @@
+ #include "command.h"
+ #include <stdio.h>
+
++#include <cctype>
++
+ static string dequote(const string &line, string::const_iterator &p, bool &completed)
+ {
+ string arg;
+diff -ur xmms-shell-0.99.0.original/src/general.cc xmms-shell-0.99.0/src/general.cc
+--- xmms-shell-0.99.0.original/src/general.cc 2002-02-11 01:05:04.000000000 -0600
++++ xmms-shell-0.99.0/src/general.cc 2002-05-09 08:02:37.000000000 -0500
+@@ -5,6 +5,7 @@
+ #include "config.h"
+ #include "command.h"
+ #include "output.h"
++#include <cctype>
+
+ class QuitCommand : public Command
+ {
+diff -ur xmms-shell-0.99.0.original/src/misc.cc xmms-shell-0.99.0/src/misc.cc
+--- xmms-shell-0.99.0.original/src/misc.cc 2002-02-10 21:05:31.000000000 -0600
++++ xmms-shell-0.99.0/src/misc.cc 2002-05-09 08:02:54.000000000 -0500
+@@ -3,6 +3,7 @@
+ #include <errno.h>
+ #include <xmmsctrl.h>
+ #include "command.h"
++#include <cctype>
+
+ #define SECTION virtual const string get_section(void) const { return "Playlist"; }
+
+diff -ur xmms-shell-0.99.0.original/src/playlist.cc xmms-shell-0.99.0/src/playlist.cc
+--- xmms-shell-0.99.0.original/src/playlist.cc 2002-02-10 20:01:44.000000000 -0600
++++ xmms-shell-0.99.0/src/playlist.cc 2002-05-09 08:03:07.000000000 -0500
+@@ -2,6 +2,7 @@
+ #include <errno.h>
+ #include <xmmsctrl.h>
+ #include "command.h"
++#include <cctype>
+
+ #define SECTION virtual const string get_section(void) const { return "Playlist"; }
+
+diff -ur xmms-shell-0.99.0.original/src/volume.cc xmms-shell-0.99.0/src/volume.cc
+--- xmms-shell-0.99.0.original/src/volume.cc 2002-02-10 22:50:01.000000000 -0600
++++ xmms-shell-0.99.0/src/volume.cc 2002-05-09 08:03:20.000000000 -0500
+@@ -4,6 +4,7 @@
+ #include <xmmsctrl.h>
+ #include "config.h"
+ #include "command.h"
++#include <cctype>
+
+ #define SECTION virtual const string get_section(void) const { return "Volume Control"; }
+
diff --git a/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
new file mode 100644
index 000000000000..9e13df686999
--- /dev/null
+++ b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild,v 1.1 2002/08/30 08:35:31 seemant Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XMMS-Shell is a simple utility to control XMMS externally."
+SRC_URI="http://download.sourceforge.net/xmms-shell/${P}.tar.gz"
+HOMEPAGE="http://www.loganh.com/xmms-shell/"
+DEPEND=">=media-sound/xmms-1.2.7
+ readline? ( >=sys-libs/readline-4.1 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack ${A}
+ # shall be sent upstream
+ patch -p0 <${FILESDIR}/${PN}-gcc3.patch
+}
+
+src_compile() {
+ local myconf
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS README
+}