summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-06-04 01:08:59 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-06-04 01:08:59 +0000
commit35cbc7d0ed672d6c7a24acff168b995271fa4da5 (patch)
treef36a6e0987af81bede983b0c2e589635b73f20af /media-plugins
parentD instead of ED for eapi0 ebuild (diff)
downloadgentoo-2-35cbc7d0ed672d6c7a24acff168b995271fa4da5.tar.gz
gentoo-2-35cbc7d0ed672d6c7a24acff168b995271fa4da5.tar.bz2
gentoo-2-35cbc7d0ed672d6c7a24acff168b995271fa4da5.zip
Version bump, some cleanup and minor ebuild fixes
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-live/ChangeLog10
-rw-r--r--media-plugins/vdr-live/files/vdr-1.7.27-compatibility.patch48
-rw-r--r--media-plugins/vdr-live/files/vdr-1.7.28-compatibility.patch44
-rw-r--r--media-plugins/vdr-live/files/vdr-live_pcre.patch26
-rw-r--r--media-plugins/vdr-live/vdr-live-0.2.0.20110419-r1.ebuild101
-rw-r--r--media-plugins/vdr-live/vdr-live-0.2.0_p20120325.ebuild (renamed from media-plugins/vdr-live/vdr-live-0.2.0.20120114-r1.ebuild)81
6 files changed, 117 insertions, 193 deletions
diff --git a/media-plugins/vdr-live/ChangeLog b/media-plugins/vdr-live/ChangeLog
index 9aac727ddc2e..4a3e329d6a67 100644
--- a/media-plugins/vdr-live/ChangeLog
+++ b/media-plugins/vdr-live/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/vdr-live
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.31 2012/04/02 20:30:50 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.32 2012/06/04 01:08:59 idl0r Exp $
+
+*vdr-live-0.2.0_p20120325 (04 Jun 2012)
+
+ 04 Jun 2012; Christian Ruppert <idl0r@gentoo.org>
+ +vdr-live-0.2.0_p20120325.ebuild, -vdr-live-0.2.0.20110419-r1.ebuild,
+ -vdr-live-0.2.0.20120114-r1.ebuild, -files/vdr-1.7.27-compatibility.patch,
+ +files/vdr-1.7.28-compatibility.patch, +files/vdr-live_pcre.patch:
+ Version bump, some cleanup and minor ebuild fixes
*vdr-live-0.2.0.20120114-r1 (02 Apr 2012)
diff --git a/media-plugins/vdr-live/files/vdr-1.7.27-compatibility.patch b/media-plugins/vdr-live/files/vdr-1.7.27-compatibility.patch
deleted file mode 100644
index 4eb296676621..000000000000
--- a/media-plugins/vdr-live/files/vdr-1.7.27-compatibility.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-commit 94a0a210a485ce1fc95c47a6bc67c4c16c89a0f9
-Author: Dieter Hametner <dh (plus) vdr (at) gekrumbel (dot) de>
-Date: Sun Mar 25 16:42:12 2012 +0200
-
- Updated LIVE to latest changes in vdr 1.7.27
- - Do not use the direct access to cRecoding members any more.
-
-diff --git a/epg_events.cpp b/epg_events.cpp
-index a514769..cd4996e 100644
---- a/epg_events.cpp
-+++ b/epg_events.cpp
-@@ -182,12 +182,20 @@ namespace vdrlive
-
- time_t EpgRecording::GetStartTime() const
- {
-+#if VDRVERSNUM < 10726
- return m_recording ? m_recording->start : 0;
-+#else
-+ return m_recording ? m_recording->Start() : 0;
-+#endif
- }
-
- time_t EpgRecording::GetEndTime() const
- {
-+#if VDRVERSNUM < 10726
- return m_recording ? m_recording->start : 0;
-+#else
-+ return m_recording ? m_recording->Start() : 0;
-+#endif
- }
-
- const string EpgRecording::Name() const
-diff --git a/recman.cpp b/recman.cpp
-index fb315d2..6a2fc00 100644
---- a/recman.cpp
-+++ b/recman.cpp
-@@ -383,7 +383,11 @@ namespace vdrlive {
-
- time_t RecordingsItemRec::StartTime() const
- {
-+#if VDRVERSNUM < 10726
- return m_recording->start;
-+#else
-+ return m_recording->Start();
-+#endif
- }
-
- long RecordingsItemRec::Duration() const
diff --git a/media-plugins/vdr-live/files/vdr-1.7.28-compatibility.patch b/media-plugins/vdr-live/files/vdr-1.7.28-compatibility.patch
new file mode 100644
index 000000000000..d95ebd748c73
--- /dev/null
+++ b/media-plugins/vdr-live/files/vdr-1.7.28-compatibility.patch
@@ -0,0 +1,44 @@
+From e154fec60a27d5a74e6940941f789e17d7169d54 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Mon, 4 Jun 2012 01:42:31 +0200
+Subject: [PATCH] Compile fix for >=vdr-1.7.28
+
+---
+ tasks.cpp | 10 ++++++++++
+ 1 files changed, 10 insertions(+), 0 deletions(-)
+
+diff --git a/tasks.cpp b/tasks.cpp
+index 9f20190..2a2b8d5 100644
+--- a/tasks.cpp
++++ b/tasks.cpp
+@@ -60,9 +60,15 @@ void PlayRecordingTask::Action()
+
+ const char *current = NowReplaying();
+ if (!current || (0 != strcmp(current, recording->FileName()))) {
++#if VDRVERSNUM >= 10728
++ cReplayControl::SetRecording( 0 );
++ cControl::Shutdown();
++ cReplayControl::SetRecording( recording->FileName() );
++#else
+ cReplayControl::SetRecording( 0, 0 );
+ cControl::Shutdown();
+ cReplayControl::SetRecording( recording->FileName(), recording->Title() );
++#endif
+ cControl::Launch( new cReplayControl );
+ cControl::Attach();
+ }
+@@ -122,7 +128,11 @@ void StopRecordingTask::Action()
+ return;
+ }
+
++#if VDRVERSNUM >= 10728
++ cReplayControl::SetRecording( 0 );
++#else
+ cReplayControl::SetRecording( 0, 0 );
++#endif
+ cControl::Shutdown();
+ }
+
+--
+1.7.3.4
+
diff --git a/media-plugins/vdr-live/files/vdr-live_pcre.patch b/media-plugins/vdr-live/files/vdr-live_pcre.patch
new file mode 100644
index 000000000000..9767cca173a5
--- /dev/null
+++ b/media-plugins/vdr-live/files/vdr-live_pcre.patch
@@ -0,0 +1,26 @@
+From 6b2965a86a20c885fc1fae8d4dea24b29b38805e Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Mon, 4 Jun 2012 02:29:55 +0200
+Subject: [PATCH] Make PCRE optional
+
+---
+ pages/recordings.ecpp | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/pages/recordings.ecpp b/pages/recordings.ecpp
+index ebd57e0..8bdad66 100644
+--- a/pages/recordings.ecpp
++++ b/pages/recordings.ecpp
+@@ -1,6 +1,9 @@
+ <%pre>
+ #include <string>
++
++#ifdef HAVE_LIBPCRECPP
+ #include <pcrecpp.h>
++#endif
+
+ #include <vdr/plugin.h>
+ #include <vdr/config.h>
+--
+1.7.3.4
+
diff --git a/media-plugins/vdr-live/vdr-live-0.2.0.20110419-r1.ebuild b/media-plugins/vdr-live/vdr-live-0.2.0.20110419-r1.ebuild
deleted file mode 100644
index 340974bb1707..000000000000
--- a/media-plugins/vdr-live/vdr-live-0.2.0.20110419-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.2.0.20110419-r1.ebuild,v 1.1 2011/07/10 03:40:52 hd_brummy Exp $
-
-EAPI="3"
-
-inherit vdr-plugin ssl-cert
-
-DESCRIPTION="VDR Plugin: Web Access To Settings"
-HOMEPAGE="http://live.vdr-developer.org"
-#SRC_URI="http://live.vdr-developer.org/downloads/${P}.tar.gz"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ssl"
-
-DEPEND="media-video/vdr
- >=dev-libs/tntnet-2.0[ssl=,sdk]
- >=dev-libs/cxxtools-2.0
- >=dev-libs/libpcre-8.12[cxx]"
-
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${VDRPLUGIN}"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-0.2"
-VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.2.sh"
-
-make_live_cert() {
- # ssl-cert eclass create invalide cert, create my own
-
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
- SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
-
- echo
- gen_cnf || return 1
- echo
- gen_key 1 || return 1
- gen_csr 1 || return 1
- gen_crt 1 || return 1
- echo
-}
-
-src_prepare() {
- vdr-plugin_src_prepare
-
- #make it work with /bin/sh as indicated in the file header
- sed -e "18s/==/=/" -i buildutil/version-util
-
- sed -e "s/ERROR:/WARNING:/" -i tntconfig.cpp
-
- sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile
-
- if ! has_version ">=media-video/vdr-1.7.13"; then
- sed -i "s:-include \$(VDRDIR)/Make.global:#-include \$(VDRDIR)/Make.global:" Makefile
- fi
-}
-
-src_install() {
- vdr-plugin_src_install
-
- cd "${S}/live"
- insinto /etc/vdr/plugins/live
- doins -r *
-
- chown vdr:vdr -R "${D}"/etc/vdr/plugins/live
-}
-
-pkg_postinst() {
- vdr-plugin_pkg_postinst
-
- elog "To be able to use all functions of vdr-live"
- elog "you should emerge and enable"
- elog "=media-plugins/vdr-epgsearch-0.9.25_beta* to search the EPG,"
- elog "media-plugins/vdr-streamdev-0.5.0 for Live-TV streaming"
- echo
- elog "On first install use login:pass"
- elog "\tadmin:live"
- echo
- ewarn "\t\tWARNiNG!!!"
- einfo "\tBe carefull on testing the new feature:"
- einfo "\tedit/rename/move recordings"
- echo
- ewarn "This is a developer snapshot"
- einfo "On problems, use the stable amd64, x86 versions of"
- einfo "dev-libs/tntnet dev-libs/cxxtools media-plugins/vdr-live"
- echo
- # Do not install live.{key,crt) SSL certificates if they already exist
- if use ssl && [[ ! -f "${ROOT}"/etc/vdr/plugins/live/live.key \
- && ! -f "${ROOT}"/etc/vdr/plugins/live/live.crt ]] ; then
- make_live_cert
- local base=$(get_base 1)
- local keydir="/etc/vdr/plugins/live"
- install -d "${ROOT}${keydir}"
- install -m0400 "${base}.key" "${ROOT}${keydir}/live.key"
- install -m0444 "${base}.crt" "${ROOT}${keydir}/live.crt"
- chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live.*
- fi
-}
diff --git a/media-plugins/vdr-live/vdr-live-0.2.0.20120114-r1.ebuild b/media-plugins/vdr-live/vdr-live-0.2.0_p20120325.ebuild
index 7fd065149b03..fec09cf63e0c 100644
--- a/media-plugins/vdr-live/vdr-live-0.2.0.20120114-r1.ebuild
+++ b/media-plugins/vdr-live/vdr-live-0.2.0_p20120325.ebuild
@@ -1,34 +1,36 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.2.0.20120114-r1.ebuild,v 1.1 2012/04/02 20:30:50 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.2.0_p20120325.ebuild,v 1.1 2012/06/04 01:08:59 idl0r Exp $
EAPI="4"
-inherit vdr-plugin ssl-cert
+inherit vdr-plugin-2 ssl-cert toolchain-funcs
DESCRIPTION="VDR Plugin: Web Access To Settings"
HOMEPAGE="http://live.vdr-developer.org"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ssl"
+IUSE="pcre ssl"
DEPEND="media-video/vdr
>=dev-libs/tntnet-2.0[ssl=,sdk]
>=dev-libs/cxxtools-2.0
- >=dev-libs/libpcre-8.12[cxx]"
-
+ pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${VDRPLUGIN}"
-
VDR_CONFD_FILE="${FILESDIR}/confd-0.2"
VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.2.sh"
+S="${WORKDIR}/${P}"
+
make_live_cert() {
- # ssl-cert eclass create invalide cert, create my own
+ # TODO: still true?
+ # ssl-cert eclass creates a "invalid" cert, create our own one
+ local base=$(get_base 1)
+ local keydir="/etc/vdr/plugins/live"
SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
@@ -40,73 +42,66 @@ make_live_cert() {
gen_csr 1 || return 1
gen_crt 1 || return 1
echo
+
+ install -d "${ROOT}${keydir}"
+ install -m0400 "${base}.key" "${ROOT}${keydir}/live.key"
+ install -m0444 "${base}.crt" "${ROOT}${keydir}/live.crt"
+ chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live.*
}
-src_prepare() {
- vdr-plugin_src_prepare
+pkg_setup() {
+ vdr-plugin-2_pkg_setup
- #make it work with /bin/sh as indicated in the file header
- sed -e "18s/==/=/" -i buildutil/version-util
+ tc-export CXX AR
+}
- sed -e "s/ERROR:/WARNING:/" -i tntconfig.cpp
+src_prepare() {
+ vdr-plugin-2_src_prepare
- sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile
+ if ! use pcre; then
+ sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
+ fi
if ! has_version ">=media-video/vdr-1.7.13"; then
- sed -i "s:-include \$(VDRDIR)/Make.global:#-include \$(VDRDIR)/Make.global:" Makefile
+ sed -i "s:-include \$(VDRDIR)/Make.global:#-include \$(VDRDIR)/Make.global:" Makefile || die
fi
- epatch "${FILESDIR}/vdr-1.7.27-compatibility.patch"
+ epatch "${FILESDIR}/vdr-1.7.28-compatibility.patch"
+ epatch "${FILESDIR}/vdr-live_pcre.patch"
}
src_install() {
- vdr-plugin_src_install
+ vdr-plugin-2_src_install
- cd "${S}/live"
insinto /etc/vdr/plugins/live
- doins -r *
+ doins -r live/*
- chown vdr:vdr -R "${D}"/etc/vdr/plugins/live
+ fowners -R vdr:vdr /etc/vdr/plugins/live
}
pkg_postinst() {
- vdr-plugin_pkg_postinst
+ vdr-plugin-2_pkg_postinst
elog "To be able to use all functions of vdr-live"
elog "you should emerge and enable"
- elog "=media-plugins/vdr-epgsearch-0.9.25_beta* to search the EPG,"
- elog "media-plugins/vdr-streamdev-0.5.0 for Live-TV streaming"
+ elog "media-plugins/vdr-epgsearch to search the EPG,"
+ elog "media-plugins/vdr-streamdev for Live-TV streaming"
- elog "On first install use login:pass"
+ elog "The default username/password is:"
elog "\tadmin:live"
- ewarn "\t\tWARNING!!!"
- ewarn "This is a developer snapshot"
- einfo "On problems, use the stable amd64, x86 versions of"
- einfo "dev-libs/tntnet dev-libs/cxxtools media-plugins/vdr-live"
-
if use ssl ; then
if path_exists -a "${ROOT}"/etc/vdr/plugins/live/live.key; then
- einfo "found SSL cert"
- einfo ""
- einfo "to create a new SSL cert, run:"
+ einfo "found an existing SSL cert, to create a new SSL cert, run:"
einfo ""
einfo "emerge --config ${PN}"
else
- einfo "NO SSL cert found"
- einfo ""
- einfo "Create SSL cert, now ..."
- pkg_config
+ einfo "No SSL cert found, creating a default one now"
+ make_live_cert
fi
fi
}
pkg_config() {
make_live_cert
- local base=$(get_base 1)
- local keydir="/etc/vdr/plugins/live"
- install -d "${ROOT}${keydir}"
- install -m0400 "${base}.key" "${ROOT}${keydir}/live.key"
- install -m0444 "${base}.crt" "${ROOT}${keydir}/live.crt"
- chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live.*
}