summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-09-29 14:30:37 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-09-29 14:30:37 +0000
commita2f6a81608f226bfc8d27a6cea29dfd9da4d74ff (patch)
tree1a56a0981772b0d09e936dd4e37ed3ab2ea2dd45 /media-plugins
parentRevision Bump for v31 protocol (diff)
downloadgentoo-2-a2f6a81608f226bfc8d27a6cea29dfd9da4d74ff.tar.gz
gentoo-2-a2f6a81608f226bfc8d27a6cea29dfd9da4d74ff.tar.bz2
gentoo-2-a2f6a81608f226bfc8d27a6cea29dfd9da4d74ff.zip
Patch from upstream to fix segfault when exiting. Rev bump.
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythdvd/ChangeLog8
-rw-r--r--media-plugins/mythdvd/files/digest-mythdvd-0.20_p113296
-rw-r--r--media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild30
3 files changed, 43 insertions, 1 deletions
diff --git a/media-plugins/mythdvd/ChangeLog b/media-plugins/mythdvd/ChangeLog
index cf0100c2af74..5af27d2d22e3 100644
--- a/media-plugins/mythdvd/ChangeLog
+++ b/media-plugins/mythdvd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythdvd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.33 2006/09/16 02:03:23 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.34 2006/09/29 14:30:37 cardoe Exp $
+
+*mythdvd-0.20_p11329 (29 Sep 2006)
+
+ 29 Sep 2006; Doug Goldstein <cardoe@gentoo.org>
+ +mythdvd-0.20_p11329.ebuild:
+ Patch from upstream to fix segfault when exiting. Rev bump.
16 Sep 2006; Doug Goldstein <cardoe@gentoo.org> +files/mtd.init,
mythdvd-0.19.ebuild, mythdvd-0.20.ebuild:
diff --git a/media-plugins/mythdvd/files/digest-mythdvd-0.20_p11329 b/media-plugins/mythdvd/files/digest-mythdvd-0.20_p11329
new file mode 100644
index 000000000000..f1d0a6d72875
--- /dev/null
+++ b/media-plugins/mythdvd/files/digest-mythdvd-0.20_p11329
@@ -0,0 +1,6 @@
+MD5 aa071a34720466b7dd0c4fa63113ac26 mythplugins-0.20.tar.bz2 17852531
+RMD160 0c3c1a3c94d4feb429b88f0b7b73ea23917940f3 mythplugins-0.20.tar.bz2 17852531
+SHA256 b038e715fc322ef914055508ed1394c38b31b415f62e972f9626409a69223a43 mythplugins-0.20.tar.bz2 17852531
+MD5 6a09ec7e180d4000b5c7916180b8b0ae mythplugins-0.20_svn11329.patch.bz2 4290
+RMD160 3001e82550dc27ddac9ce95b0b0600faaddb21bd mythplugins-0.20_svn11329.patch.bz2 4290
+SHA256 7d03920a182f64dc4df8fab9c439559ec3d69fdf1a3ae372e2ea1329b632d5e1 mythplugins-0.20_svn11329.patch.bz2 4290
diff --git a/media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild b/media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild
new file mode 100644
index 000000000000..bbc1725cd1f8
--- /dev/null
+++ b/media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.20_p11329.ebuild,v 1.1 2006/09/29 14:30:37 cardoe Exp $
+
+inherit mythtv-plugins
+
+DESCRIPTION="DVD player module for MythTV."
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="transcode"
+
+RDEPEND="=media-plugins/mythvideo-${MY_PV}*
+ transcode? ( media-video/transcode
+ media-libs/libdvdread )
+ || ( media-video/mplayer media-video/xine-ui media-video/ogle )"
+
+MTVCONF="--enable-vcd $(use_enable transcode)"
+
+src_install() {
+ mythtv-plugins_src_install
+
+ newinitd "${FILESDIR}"/mtd.init mtd
+}
+
+pkg_postinst() {
+ echo
+ einfo "To have Myth Transcode Daemon (mtd) start on boot do the following"
+ einfo "rc-update add mtd default"
+ einfo "Make sure you run 'mtd -n' to setup mtd first"
+ echo
+}