summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-03-21 14:05:46 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-03-21 14:05:46 +0000
commitc38beb2a52a3f340636d15991c486fc6a550ff55 (patch)
tree9b372d3f648abd68b22e5e0d52119ca01b703f54 /media-plugins
parentFix cross-compile hack to work with current xorg-2 and autotools-utils eclass... (diff)
downloadgentoo-2-c38beb2a52a3f340636d15991c486fc6a550ff55.tar.gz
gentoo-2-c38beb2a52a3f340636d15991c486fc6a550ff55.tar.bz2
gentoo-2-c38beb2a52a3f340636d15991c486fc6a550ff55.zip
Add libv4l dep for video buffer format conversion. Fixes bug #250079.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-v4l2/ChangeLog8
-rw-r--r--media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.28-r1.ebuild20
2 files changed, 27 insertions, 1 deletions
diff --git a/media-plugins/gst-plugins-v4l2/ChangeLog b/media-plugins/gst-plugins-v4l2/ChangeLog
index a2e4ef7840fe..7afb9ba1b8f8 100644
--- a/media-plugins/gst-plugins-v4l2/ChangeLog
+++ b/media-plugins/gst-plugins-v4l2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gst-plugins-v4l2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-v4l2/ChangeLog,v 1.75 2011/03/20 09:32:25 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-v4l2/ChangeLog,v 1.76 2011/03/21 14:05:46 ford_prefect Exp $
+
+*gst-plugins-v4l2-0.10.28-r1 (21 Mar 2011)
+
+ 21 Mar 2011; Arun Raghavan <ford_prefect@gentoo.org>
+ +gst-plugins-v4l2-0.10.28-r1.ebuild:
+ Add libv4l dep for video buffer format conversion. Fixes bug #250079.
*gst-plugins-v4l2-0.10.28 (20 Mar 2011)
diff --git a/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.28-r1.ebuild b/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.28-r1.ebuild
new file mode 100644
index 000000000000..a9c369ae9252
--- /dev/null
+++ b/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.28-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-v4l2/gst-plugins-v4l2-0.10.28-r1.ebuild,v 1.1 2011/03/21 14:05:46 ford_prefect Exp $
+
+inherit gst-plugins-good
+
+DESCRIPION="plugin to allow capture from video4linux2 devices"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.32"
+DEPEND="${RDEPEND}
+ media-libs/libv4l
+ virtual/os-headers"
+
+GST_PLUGINS_BUILD="gst_v4l2"
+
+src_configure() {
+ gst-plugins-good_src_configure --with-libv4l2
+}