summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-07-25 21:24:06 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-07-25 21:24:06 +0000
commitd4eef0719492bc8a21140c10e3361f72d09310c9 (patch)
treee8888700136710a84e186147a08ca9da805d0b50 /media-plugins
parentRevbump to fix header for gcc-4.4 issue; bug #278155 (diff)
downloadgentoo-2-d4eef0719492bc8a21140c10e3361f72d09310c9.tar.gz
gentoo-2-d4eef0719492bc8a21140c10e3361f72d09310c9.tar.bz2
gentoo-2-d4eef0719492bc8a21140c10e3361f72d09310c9.zip
Fix compilation with gcc-4.4. Patch by Victor Ostorga <vostorga AT gentoo DOT org>; bug #272514
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-xxvautotimer/ChangeLog8
-rw-r--r--media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_gcc-4.4.diff15
-rw-r--r--media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild5
3 files changed, 25 insertions, 3 deletions
diff --git a/media-plugins/vdr-xxvautotimer/ChangeLog b/media-plugins/vdr-xxvautotimer/ChangeLog
index d50b4aa09f25..ce601a0bdec4 100644
--- a/media-plugins/vdr-xxvautotimer/ChangeLog
+++ b/media-plugins/vdr-xxvautotimer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-xxvautotimer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/ChangeLog,v 1.4 2009/04/12 06:55:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/ChangeLog,v 1.5 2009/07/25 21:24:06 halcy0n Exp $
+
+ 25 Jul 2009; Mark Loeser <halcy0n@gentoo.org>
+ vdr-xxvautotimer-0.1.2-r1.ebuild,
+ +files/vdr-xxvautotimer-0.1.2_gcc-4.4.diff:
+ Fix compilation with gcc-4.4. Patch by Victor Ostorga <vostorga AT gentoo
+ DOT org>; bug #272514
12 Apr 2009; Ulrich Mueller <ulm@gentoo.org>
vdr-xxvautotimer-0.1.2.ebuild, vdr-xxvautotimer-0.1.2-r1.ebuild:
diff --git a/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_gcc-4.4.diff b/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_gcc-4.4.diff
new file mode 100644
index 000000000000..fa3d4f5a9bd6
--- /dev/null
+++ b/media-plugins/vdr-xxvautotimer/files/vdr-xxvautotimer-0.1.2_gcc-4.4.diff
@@ -0,0 +1,15 @@
+diff -NrU5 xxvautotimer-0.1.2.orig/mysqlwrapped-1.4/StderrLog.cpp xxvautotimer-0.1.2/mysqlwrapped-1.4/StderrLog.cpp
+--- xxvautotimer-0.1.2.orig/mysqlwrapped-1.4/StderrLog.cpp 2009-06-10 17:01:27.000000000 -0600
++++ xxvautotimer-0.1.2/mysqlwrapped-1.4/StderrLog.cpp 2009-06-10 17:04:09.000000000 -0600
+@@ -23,10 +23,11 @@
+ */
+ #ifdef _WIN32
+ #pragma warning(disable:4786)
+ #endif
+
++#include <cstdio>
+ #include <string>
+ #include <map>
+ #ifdef WIN32
+ #include <config-win.h>
+ #include <mysql.h>
diff --git a/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild b/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild
index 66a7ae38f52c..e9b7c7f3910f 100644
--- a/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild
+++ b/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild,v 1.2 2009/04/12 06:55:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-xxvautotimer/vdr-xxvautotimer-0.1.2-r1.ebuild,v 1.3 2009/07/25 21:24:06 halcy0n Exp $
inherit vdr-plugin
@@ -20,7 +20,8 @@ RDEPEND=">=www-misc/xxv-0.30"
PATCHES=("${FILESDIR}/vdr-1.5.7-gettext.diff"
"${FILESDIR}/${P}_gcc-4.3.x.diff"
"${FILESDIR}/${P}_compile-warn.diff"
- "${FILESDIR}/${P}-makefile-fix.diff")
+ "${FILESDIR}/${P}-makefile-fix.diff"
+ "${FILESDIR}/${P}_gcc-4.4.diff")
src_unpack() {
vdr-plugin_src_unpack