summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-09-24 19:02:20 +0000
committerChristoph Mende <angelos@gentoo.org>2008-09-24 19:02:20 +0000
commitf75a8808526383401bf1c9549e77577f3c76fee9 (patch)
tree17096364392e441579bc263f1d12bcfe87fca0eb /media-plugins
parentVersion bump. (diff)
downloadgentoo-2-f75a8808526383401bf1c9549e77577f3c76fee9.tar.gz
gentoo-2-f75a8808526383401bf1c9549e77577f3c76fee9.tar.bz2
gentoo-2-f75a8808526383401bf1c9549e77577f3c76fee9.zip
Version bump
(Portage version: 2.2_rc9/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gmpc-lastfm/ChangeLog8
-rw-r--r--media-plugins/gmpc-lastfm/gmpc-lastfm-0.16.0.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/media-plugins/gmpc-lastfm/ChangeLog b/media-plugins/gmpc-lastfm/ChangeLog
index ef501485adae..100c804b156f 100644
--- a/media-plugins/gmpc-lastfm/ChangeLog
+++ b/media-plugins/gmpc-lastfm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gmpc-lastfm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-lastfm/ChangeLog,v 1.13 2008/03/20 21:41:14 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-lastfm/ChangeLog,v 1.14 2008/09/24 19:02:20 angelos Exp $
+
+*gmpc-lastfm-0.16.0 (24 Sep 2008)
+
+ 24 Sep 2008; Christoph Mende <angelos@gentoo.org>
+ +gmpc-lastfm-0.16.0.ebuild:
+ Version bump
20 Mar 2008; Christoph Mende <angelos@gentoo.org>
-gmpc-lastfm-0.14.0.ebuild, -gmpc-lastfm-0.15.0.ebuild:
diff --git a/media-plugins/gmpc-lastfm/gmpc-lastfm-0.16.0.ebuild b/media-plugins/gmpc-lastfm/gmpc-lastfm-0.16.0.ebuild
new file mode 100644
index 000000000000..f60f69510bf2
--- /dev/null
+++ b/media-plugins/gmpc-lastfm/gmpc-lastfm-0.16.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-lastfm/gmpc-lastfm-0.16.0.ebuild,v 1.1 2008/09/24 19:02:20 angelos Exp $
+
+inherit autotools eutils multilib
+
+MY_PN="gmpc-last.fm"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="This plugin fetches artist art from last.fm"
+HOMEPAGE="http://gmpcwiki.sarine.nl/index.php/Last.fm"
+SRC_URI="http://download.sarine.nl/Programs/gmpc/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-sound/gmpc-${PV}
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! built_with_use =x11-libs/gtk+-2* jpeg ; then
+ echo
+ eerror "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ die "x11-libs/gtk+-2 needs to be built with \"jpeg\" USE flag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i "/^libdir/s:/lib/:/$(get_libdir)/:" src/Makefile.am
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+}