summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-10-04 21:50:34 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-10-04 21:50:34 +0000
commitf9d009f6d0a3a30c74b05611cce786715e674326 (patch)
tree126e1ccdb449437d00a8c5ce770ff4ce073943d7 /media-plugins
parentNew alpha release, still masked. Bugs upstream please. (diff)
downloadgentoo-2-f9d009f6d0a3a30c74b05611cce786715e674326.tar.gz
gentoo-2-f9d009f6d0a3a30c74b05611cce786715e674326.tar.bz2
gentoo-2-f9d009f6d0a3a30c74b05611cce786715e674326.zip
New alpha release, still masked. Bugs upstream please.
(Portage version: 2.2_rc43/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog7
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-2.2_alpha2.ebuild113
2 files changed, 119 insertions, 1 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index 0729f5470234..f1abd11ab41a 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.138 2009/09/16 19:08:03 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.139 2009/10/04 21:50:34 chainsaw Exp $
+
+*audacious-plugins-2.2_alpha2 (04 Oct 2009)
+
+ 04 Oct 2009; <chainsaw@gentoo.org> +audacious-plugins-2.2_alpha2.ebuild:
+ New alpha release, still masked. Bugs upstream please.
16 Sep 2009; <chainsaw@gentoo.org> audacious-plugins-2.2_alpha1.ebuild:
Properly remove references to WMA & PulseAudio plugins, which are no
diff --git a/media-plugins/audacious-plugins/audacious-plugins-2.2_alpha2.ebuild b/media-plugins/audacious-plugins/audacious-plugins-2.2_alpha2.ebuild
new file mode 100644
index 000000000000..f2b9d1c77e48
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-2.2_alpha2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-2.2_alpha2.ebuild,v 1.1 2009/10/04 21:50:34 chainsaw Exp $
+
+inherit eutils flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="adplug alsa bs2b cdda esd flac ffmpeg gnome icecast ipv6 jack lirc mp3 mtp
+nls oss projectm scrobbler sdl sid sndfile sse2 timidity tta vorbis wavpack"
+
+RDEPEND="app-arch/unzip
+ >=dev-libs/dbus-glib-0.60
+ dev-libs/libxml2
+ >=media-sound/audacious-2.2_alpha2
+ >=net-misc/neon-0.26.4
+ >=x11-libs/gtk+-2.14
+ adplug? ( >=dev-cpp/libbinio-1.4 )
+ alsa? ( >=media-libs/alsa-lib-1.0.16 )
+ bs2b? ( media-libs/libbs2b )
+ cdda? ( >=media-libs/libcddb-1.2.1
+ >=dev-libs/libcdio-0.79-r1 )
+ esd? ( >=media-sound/esound-0.2.38-r1 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.2.1-r1 )
+ icecast? ( media-libs/libshout )
+ jack? ( >=media-libs/bio2jack-0.4
+ media-sound/jack-audio-connection-kit )
+ lirc? ( app-misc/lirc )
+ mp3? ( media-libs/libmad )
+ mtp? ( media-libs/libmtp )
+ projectm? ( >=media-libs/libprojectm-1.2.0
+ >=media-libs/libsdl-1.2.5 )
+ scrobbler? ( net-misc/curl )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ sid? ( >=media-libs/libsidplay-2.1.1-r2 )
+ sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
+ timidity? ( media-sound/timidity++ )
+ tta? ( media-libs/libid3tag )
+ vorbis? ( >=media-libs/libvorbis-1.2.0
+ >=media-libs/libogg-1.1.3 )
+ wavpack? ( >=media-sound/wavpack-4.41.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+mp3_warning() {
+ if ! useq mp3 ; then
+ ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+ fi
+}
+
+src_compile() {
+ mp3_warning
+
+ econf \
+ --enable-aac \
+ --enable-chardet \
+ --enable-dbus \
+ --enable-modplug \
+ --enable-neon \
+ --disable-coreaudio \
+ --disable-dockalbumart \
+ --disable-projectm \
+ $(use_enable projectm projectm-1.0) \
+ $(use_enable adplug) \
+ $(use_enable alsa) \
+ $(use_enable alsa bluetooth) \
+ $(use_enable bs2b) \
+ $(use_enable cdda cdaudio) \
+ $(use_enable esd) \
+ $(use_enable ffmpeg ffaudio) \
+ $(use_enable flac flacng) \
+ $(use_enable flac filewriter_flac) \
+ $(use_enable ipv6) \
+ $(use_enable jack) \
+ $(use_enable gnome gnomeshortcuts) \
+ $(use_enable lirc) \
+ $(use_enable mp3) \
+ $(use_enable mtp mtp_up) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable sdl paranormal) \
+ $(use_enable sid) \
+ $(use_enable sndfile) \
+ $(use_enable sse2) \
+ $(use_enable timidity) \
+ $(use_enable tta) \
+ $(use_enable vorbis) \
+ $(use_enable vorbis filewriter_vorbis) \
+ $(use_enable wavpack) \
+ $(use_enable icecast) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ mp3_warning
+}