summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-06-19 19:11:43 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-06-19 19:11:43 +0000
commit5b393e3e45fdcc50ffdd9ff69fab235e8b467575 (patch)
tree4ed5b771d2786de969ab9fd58ffc8d1f672d704e /media-radio/ax25-apps
parentadd alpha to KEYWORDS (diff)
downloadgentoo-2-5b393e3e45fdcc50ffdd9ff69fab235e8b467575.tar.gz
gentoo-2-5b393e3e45fdcc50ffdd9ff69fab235e8b467575.tar.bz2
gentoo-2-5b393e3e45fdcc50ffdd9ff69fab235e8b467575.zip
new ebuilds
Diffstat (limited to 'media-radio/ax25-apps')
-rw-r--r--media-radio/ax25-apps/ChangeLog9
-rw-r--r--media-radio/ax25-apps/Manifest6
-rw-r--r--media-radio/ax25-apps/ax25-apps-0.0.6.ebuild38
-rw-r--r--media-radio/ax25-apps/files/ax25ipd.rc20
-rw-r--r--media-radio/ax25-apps/files/ax25mond.rc20
-rw-r--r--media-radio/ax25-apps/files/ax25rtd.blank0
-rw-r--r--media-radio/ax25-apps/files/ax25rtd.rc20
-rw-r--r--media-radio/ax25-apps/files/digest-ax25-apps-0.0.61
8 files changed, 114 insertions, 0 deletions
diff --git a/media-radio/ax25-apps/ChangeLog b/media-radio/ax25-apps/ChangeLog
new file mode 100644
index 000000000000..2a0c8124d5d4
--- /dev/null
+++ b/media-radio/ax25-apps/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-radio/ax25-apps
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-apps/ChangeLog,v 1.1 2003/06/19 19:11:42 rphillips Exp $
+
+*ax25-apps-0.0.6 (19 Jun 2003)
+
+ 19 Jun 2003; Ryan Phillips <rphillips@gentoo.org> :
+
+ Created by Samuel Greenfeld. Fixes Bug #12232
diff --git a/media-radio/ax25-apps/Manifest b/media-radio/ax25-apps/Manifest
new file mode 100644
index 000000000000..28d4f9aefa43
--- /dev/null
+++ b/media-radio/ax25-apps/Manifest
@@ -0,0 +1,6 @@
+MD5 4b3b1574818e0695171fbab1df54a428 ax25-apps-0.0.6.ebuild 1106
+MD5 9d32be567b1b4dc0cbc426847b070834 files/ax25rtd.rc 409
+MD5 487da038fb8422cc25aa692c790c68ff files/ax25mond.rc 413
+MD5 d11cb1e7e7635247a9e2684e98a19915 files/digest-ax25-apps-0.0.6 67
+MD5 d41d8cd98f00b204e9800998ecf8427e files/ax25rtd.blank 0
+MD5 40eb527f5e4c317d0964da0c5eb92e09 files/ax25ipd.rc 409
diff --git a/media-radio/ax25-apps/ax25-apps-0.0.6.ebuild b/media-radio/ax25-apps/ax25-apps-0.0.6.ebuild
new file mode 100644
index 000000000000..432545ab816b
--- /dev/null
+++ b/media-radio/ax25-apps/ax25-apps-0.0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-apps/ax25-apps-0.0.6.ebuild,v 1.1 2003/06/19 19:11:42 rphillips Exp $
+
+DESCRIPTION="Basic AX.25 (Amateur Radio) user tools, additional daemons"
+HOMEPAGE="http://ax25.sourceforge.net/"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/ax25/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc
+ >=dev-libs/libax25-0.0.7"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ # "installconf" installs sample configurations
+ # Gentoo's configuration protection system can work with this
+ make DESTDIR=${D} installconf || die
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ax25ipd.rc ax25ipd
+ newexe ${FILESDIR}/ax25mond.rc ax25mond
+ newexe ${FILESDIR}/ax25rtd.rc ax25rtd
+
+ # FIXME: Configuration protect logic for the ax25rtd cache
+ # or move these files
+ # Moving might require changes to ax25rtd/ax25rtctl
+ insinto /var/lib/ax25/ax25rtd
+ newins ${FILESDIR}/ax25rtd.blank ax25_route
+ newins ${FILESDIR}/ax25rtd.blank ip_route
+}
diff --git a/media-radio/ax25-apps/files/ax25ipd.rc b/media-radio/ax25-apps/files/ax25ipd.rc
new file mode 100644
index 000000000000..a61c331ffd9b
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25ipd.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-apps/files/ax25ipd.rc,v 1.1 2003/06/19 19:11:42 rphillips Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25ipd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25ipd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25ipd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25ipd
+ eend $?
+}
diff --git a/media-radio/ax25-apps/files/ax25mond.rc b/media-radio/ax25-apps/files/ax25mond.rc
new file mode 100644
index 000000000000..20ca6e5ba34a
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25mond.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-apps/files/ax25mond.rc,v 1.1 2003/06/19 19:11:42 rphillips Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25mond"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25mond
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25mond"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25mond
+ eend $?
+}
diff --git a/media-radio/ax25-apps/files/ax25rtd.blank b/media-radio/ax25-apps/files/ax25rtd.blank
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25rtd.blank
diff --git a/media-radio/ax25-apps/files/ax25rtd.rc b/media-radio/ax25-apps/files/ax25rtd.rc
new file mode 100644
index 000000000000..f4b79857f8e1
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25rtd.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ax25-apps/files/ax25rtd.rc,v 1.1 2003/06/19 19:11:43 rphillips Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25rtd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25rtd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25rtd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25rtd
+ eend $?
+}
diff --git a/media-radio/ax25-apps/files/digest-ax25-apps-0.0.6 b/media-radio/ax25-apps/files/digest-ax25-apps-0.0.6
new file mode 100644
index 000000000000..fb5a2c01ba8d
--- /dev/null
+++ b/media-radio/ax25-apps/files/digest-ax25-apps-0.0.6
@@ -0,0 +1 @@
+MD5 47d9a775890f3694cf47659423a69ae5 ax25-apps-0.0.6.tar.gz 273846