summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-03-23 18:46:10 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-03-23 18:46:10 +0000
commit77a96eacd5668fa8c47ebecb46692f096bebfb77 (patch)
tree16ec42a09bc17be5abbe9eb4b2d7686d5b32f9cc /media-radio/tucnak2
parentUpdate HOMEPAGE to git repo. (diff)
downloadgentoo-2-77a96eacd5668fa8c47ebecb46692f096bebfb77.tar.gz
gentoo-2-77a96eacd5668fa8c47ebecb46692f096bebfb77.tar.bz2
gentoo-2-77a96eacd5668fa8c47ebecb46692f096bebfb77.zip
Version bump
(Portage version: 2.1.10.50/cvs/Linux x86_64)
Diffstat (limited to 'media-radio/tucnak2')
-rw-r--r--media-radio/tucnak2/ChangeLog8
-rw-r--r--media-radio/tucnak2/files/tucnak2-2.47-doc.diff19
-rw-r--r--media-radio/tucnak2/tucnak2-2.47.ebuild66
3 files changed, 92 insertions, 1 deletions
diff --git a/media-radio/tucnak2/ChangeLog b/media-radio/tucnak2/ChangeLog
index 36e673814565..47e7bd9550b5 100644
--- a/media-radio/tucnak2/ChangeLog
+++ b/media-radio/tucnak2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-radio/tucnak2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.40 2012/03/13 13:05:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.41 2012/03/23 18:46:10 tomjbe Exp $
+
+*tucnak2-2.47 (23 Mar 2012)
+
+ 23 Mar 2012; Thomas Beierlein <tomjbe@gentoo.org> +tucnak2-2.47.ebuild,
+ +files/tucnak2-2.47-doc.diff:
+ Version bump
13 Mar 2012; Agostino Sarubbo <ago@gentoo.org> tucnak2-2.46.ebuild:
Stable for amd64, wrt bug #407151
diff --git a/media-radio/tucnak2/files/tucnak2-2.47-doc.diff b/media-radio/tucnak2/files/tucnak2-2.47-doc.diff
new file mode 100644
index 000000000000..43cd50aa0d94
--- /dev/null
+++ b/media-radio/tucnak2/files/tucnak2-2.47-doc.diff
@@ -0,0 +1,19 @@
+--- Makefile.am.orig 2011-02-25 18:29:32.000000000 +0100
++++ Makefile.am 2011-02-25 18:29:52.000000000 +0100
+@@ -1,15 +1,11 @@
+ datarootdir = @datarootdir@
+
+-SUBDIRS=data debian doc intl pkg share src win32
++SUBDIRS=data intl pkg share src win32
+
+ MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in stamp-h.in
+
+ EXTRA_DIST = COPYING INSTALL leaks rebuild eee.sh
+
+-docsdir = $(datadir)/tucnak2/doc
+-
+-docs_DATA = AUTHORS ChangeLog TODO
+-
+ stamp = `date +%Y%m%d_%H%M%S`
+
+ distd: dist
diff --git a/media-radio/tucnak2/tucnak2-2.47.ebuild b/media-radio/tucnak2/tucnak2-2.47.ebuild
new file mode 100644
index 000000000000..f572bfe6d06e
--- /dev/null
+++ b/media-radio/tucnak2/tucnak2-2.47.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/tucnak2-2.47.ebuild,v 1.1 2012/03/23 18:46:10 tomjbe Exp $
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw ftdi gpm hamlib suid"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ ftdi? ( dev-embedded/libftdi )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )
+ >=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-doc.diff" \
+ "${FILESDIR}/${PN}-2.42-appname.diff" \
+ "${FILESDIR}/${PN}-soundwrapper.diff"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with alsa) $(use_with ftdi) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3) --with-sdl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman debian/tucnak2.1
+ dodoc AUTHORS ChangeLog TODO doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak2 add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak2 can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}