summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-02-09 17:41:52 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-02-09 17:41:52 +0000
commitaded2dee09fbf44fdbb635b5b9fe56b4c8c0bb2e (patch)
treee1f899d95eb646e4f23e2930823c86e0d91a4195 /media-radio/unixcw
parentVersion bump (#453128) (diff)
downloadgentoo-2-aded2dee09fbf44fdbb635b5b9fe56b4c8c0bb2e.tar.gz
gentoo-2-aded2dee09fbf44fdbb635b5b9fe56b4c8c0bb2e.tar.bz2
gentoo-2-aded2dee09fbf44fdbb635b5b9fe56b4c8c0bb2e.zip
Add missing includes (Bug #456304). Thanks Diego
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio/unixcw')
-rw-r--r--media-radio/unixcw/ChangeLog6
-rw-r--r--media-radio/unixcw/files/unixcw-3.2.0-console.patch17
-rw-r--r--media-radio/unixcw/unixcw-3.2.0.ebuild4
3 files changed, 25 insertions, 2 deletions
diff --git a/media-radio/unixcw/ChangeLog b/media-radio/unixcw/ChangeLog
index 646cb542e084..fc15078bfe3e 100644
--- a/media-radio/unixcw/ChangeLog
+++ b/media-radio/unixcw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-radio/unixcw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.8 2013/02/07 16:29:26 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.9 2013/02/09 17:41:52 tomjbe Exp $
+
+ 09 Feb 2013; Thomas Beierlein <tomjbe@gentoo.org> unixcw-3.2.0.ebuild,
+ +files/unixcw-3.2.0-console.patch:
+ Add missing includes (Bug #456304). Thanks Diego
*unixcw-3.2.0 (07 Feb 2013)
diff --git a/media-radio/unixcw/files/unixcw-3.2.0-console.patch b/media-radio/unixcw/files/unixcw-3.2.0-console.patch
new file mode 100644
index 000000000000..723e39223709
--- /dev/null
+++ b/media-radio/unixcw/files/unixcw-3.2.0-console.patch
@@ -0,0 +1,17 @@
+# add missing headeers
+--- src/libcw/libcw_console.c.orig 2013-02-09 17:20:01.000000000 +0000
++++ src/libcw/libcw_console.c 2013-02-09 17:24:10.000000000 +0000
+@@ -29,6 +29,13 @@
+ #include <sys/ioctl.h>
+ #include <stdio.h>
+ #include <stdbool.h>
++#include <string.h>
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <fcntl.h>
++#include <errno.h>
++#include <assert.h>
++#include <unistd.h>
+
+
+ #if defined(HAVE_SYS_KD_H)
diff --git a/media-radio/unixcw/unixcw-3.2.0.ebuild b/media-radio/unixcw/unixcw-3.2.0.ebuild
index 4ed450c24999..67300565c2d3 100644
--- a/media-radio/unixcw/unixcw-3.2.0.ebuild
+++ b/media-radio/unixcw/unixcw-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/unixcw-3.2.0.ebuild,v 1.1 2013/02/07 16:29:26 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/unixcw-3.2.0.ebuild,v 1.2 2013/02/09 17:41:52 tomjbe Exp $
EAPI=4
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
!<=app-misc/cw-1.0.16-r1"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-console.patch
+
append-cflags -std=gnu99
# add path to qt4 libs
sed -i -e "s#LDADD = -L#LDADD = -L/usr/$(get_libdir)/qt4 -L#g" \