summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-06-02 16:34:53 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-06-02 16:34:53 +0000
commit38ab5e4491cbca1a11b242a4435847186694a085 (patch)
tree8ce16c2f7637c5c4e91187841b5215875dc699c9 /media-radio
parentfix #472046 wrt #472034, drop old (diff)
downloadgentoo-2-38ab5e4491cbca1a11b242a4435847186694a085.tar.gz
gentoo-2-38ab5e4491cbca1a11b242a4435847186694a085.tar.bz2
gentoo-2-38ab5e4491cbca1a11b242a4435847186694a085.zip
Fix import of PIL modules (Bug #471538)
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/wspr/ChangeLog6
-rw-r--r--media-radio/wspr/files/wspr-2.00-PIL.patch13
-rw-r--r--media-radio/wspr/wspr-2.00-r1.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/media-radio/wspr/ChangeLog b/media-radio/wspr/ChangeLog
index 529c54a43097..1eea9f596e35 100644
--- a/media-radio/wspr/ChangeLog
+++ b/media-radio/wspr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-radio/wspr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/ChangeLog,v 1.9 2013/03/03 18:42:51 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/ChangeLog,v 1.10 2013/06/02 16:34:53 tomjbe Exp $
+
+ 02 Jun 2013; Thomas Beierlein <tomjbe@gentoo.org> wspr-2.00-r1.ebuild,
+ +files/wspr-2.00-PIL.patch:
+ Fix import of PIL modules (Bug #471538)
03 Mar 2013; Thomas Beierlein <tomjbe@gentoo.org> wspr-2.00-r1.ebuild:
Improve build logic. Thanks for help Michal
diff --git a/media-radio/wspr/files/wspr-2.00-PIL.patch b/media-radio/wspr/files/wspr-2.00-PIL.patch
new file mode 100644
index 000000000000..69bb853396ac
--- /dev/null
+++ b/media-radio/wspr/files/wspr-2.00-PIL.patch
@@ -0,0 +1,13 @@
+--- wspr.py.orig 2013-06-02 18:25:02.000000000 +0200
++++ wspr.py 2013-06-02 18:25:51.000000000 +0200
+@@ -15,7 +15,9 @@
+ from Numeric import zeros
+ import array
+ import dircache
+-import Image, ImageTk, ImageDraw
++from PIL import Image
++from PIL import ImageTk
++from PIL import ImageDraw
+ from WsprMod.palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ from types import *
diff --git a/media-radio/wspr/wspr-2.00-r1.ebuild b/media-radio/wspr/wspr-2.00-r1.ebuild
index 98ec86e26d7b..a297204ea98e 100644
--- a/media-radio/wspr/wspr-2.00-r1.ebuild
+++ b/media-radio/wspr/wspr-2.00-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/wspr-2.00-r1.ebuild,v 1.3 2013/03/03 18:42:51 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/wspr-2.00-r1.ebuild,v 1.4 2013/06/02 16:34:53 tomjbe Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -53,6 +53,7 @@ python_prepare_all() {
"${FILESDIR}"/${P}-libdir.patch
"${FILESDIR}"/${P}-verbose.patch
"${FILESDIR}"/${P}-script.patch
+ "${FILESDIR}"/${P}-PIL.patch
)
distutils-r1_python_prepare_all