summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-11-03 18:31:49 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-11-03 18:31:49 +0000
commit400ddcd2635cbe3146ae674d70ada569522ee235 (patch)
tree7ca0f021115d49b2d031b34312089f9cb83da1fd /media-radio
parentx86 stable wrt security bug #343389 (diff)
downloadgentoo-2-400ddcd2635cbe3146ae674d70ada569522ee235.tar.gz
gentoo-2-400ddcd2635cbe3146ae674d70ada569522ee235.tar.bz2
gentoo-2-400ddcd2635cbe3146ae674d70ada569522ee235.zip
Version bump
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tucnak2/ChangeLog8
-rw-r--r--media-radio/tucnak2/files/tucnak2-2.37-hamlib.diff12
-rw-r--r--media-radio/tucnak2/tucnak2-2.37.ebuild66
3 files changed, 85 insertions, 1 deletions
diff --git a/media-radio/tucnak2/ChangeLog b/media-radio/tucnak2/ChangeLog
index 9425edb6b32b..6542c5040e41 100644
--- a/media-radio/tucnak2/ChangeLog
+++ b/media-radio/tucnak2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-radio/tucnak2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.23 2010/07/17 10:45:02 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.24 2010/11/03 18:31:49 tomjbe Exp $
+
+*tucnak2-2.37 (03 Nov 2010)
+
+ 03 Nov 2010; Thomas Beierlein <tomjbe@gentoo.org> +tucnak2-2.37.ebuild,
+ +files/tucnak2-2.37-hamlib.diff:
+ Version bump
17 Jul 2010; Thomas Beierlein <tomjbe@gentoo.org>
-files/tucnak2-2.25-appname.diff, -tucnak2-2.26.ebuild,
diff --git a/media-radio/tucnak2/files/tucnak2-2.37-hamlib.diff b/media-radio/tucnak2/files/tucnak2-2.37-hamlib.diff
new file mode 100644
index 000000000000..7714c9c797b5
--- /dev/null
+++ b/media-radio/tucnak2/files/tucnak2-2.37-hamlib.diff
@@ -0,0 +1,12 @@
+--- src/session.c.orig 2010-11-03 19:24:35.000000000 +0100
++++ src/session.c 2010-11-03 19:25:02.000000000 +0100
+@@ -2280,8 +2280,8 @@
+ if (ctest->runmode && cfg->rig_clr_rit){
+ trig_set_rit(trig, 0.0);
+ }
+- qso_saved = 1;
+ #endif
++ qso_saved = 1;
+ }
+ }
+ dbg("process_input(runmode=%d, len=%d, cq=%d, last_cq=%p)\n", ctest->runmode, strlen(text), cq, gses->last_cq);
diff --git a/media-radio/tucnak2/tucnak2-2.37.ebuild b/media-radio/tucnak2/tucnak2-2.37.ebuild
new file mode 100644
index 000000000000..28554cdb0633
--- /dev/null
+++ b/media-radio/tucnak2/tucnak2-2.37.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/tucnak2-2.37.ebuild,v 1.1 2010/11/03 18:31:49 tomjbe Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw ftdi gpm hamlib suid"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ ftdi? ( dev-embedded/libftdi )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )
+ >=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.19-doc.diff" \
+ "${FILESDIR}/${PN}-2.32-appname.diff" \
+ "${FILESDIR}/${P}-hamlib.diff"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with alsa) $(use_with ftdi) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3) --with-sdl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doman debian/tucnak2.1 || die "doman failed"
+ dodoc AUTHORS ChangeLog TODO doc/NAVOD.pdf || die "dodoc failed"
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper || die "fperms failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak2 add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak2 can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}