summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-12 05:16:08 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-12 05:16:08 +0000
commitb3b12a32ed224ab0dc5bca7e58fa84747837f90e (patch)
tree20d446c37642cde5cc1d71eba846d363f5180d6c /media-radio
parentrevbump; conversion -> distutils-r1 wrt bug #541296 (diff)
downloadgentoo-2-b3b12a32ed224ab0dc5bca7e58fa84747837f90e.tar.gz
gentoo-2-b3b12a32ed224ab0dc5bca7e58fa84747837f90e.tar.bz2
gentoo-2-b3b12a32ed224ab0dc5bca7e58fa84747837f90e.zip
revbump; conversion -> distutils-r1 wrt bug #541296
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/KochMorse/ChangeLog10
-rw-r--r--media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild33
2 files changed, 40 insertions, 3 deletions
diff --git a/media-radio/KochMorse/ChangeLog b/media-radio/KochMorse/ChangeLog
index 7dc87425a25b..693289d4204e 100644
--- a/media-radio/KochMorse/ChangeLog
+++ b/media-radio/KochMorse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/KochMorse
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/ChangeLog,v 1.4 2011/03/11 18:39:07 arfrever Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/ChangeLog,v 1.5 2015/03/12 05:16:08 idella4 Exp $
+
+*KochMorse-0.99.6-r1 (12 Mar 2015)
+
+ 12 Mar 2015; Ian Delaney <idella4@gentoo.org> +KochMorse-0.99.6-r1.ebuild:
+ revbump; conversion -> distutils-r1 wrt bug #541296
11 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
KochMorse-0.99.6.ebuild:
@@ -18,4 +23,3 @@
31 Aug 2010; Michael Weber <xmw@gentoo.org> +KochMorse-0.99.6.ebuild,
+metadata.xml:
Initial import, fixes bug #311871.
-
diff --git a/media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild b/media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild
new file mode 100644
index 000000000000..feadc347181b
--- /dev/null
+++ b/media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild,v 1.1 2015/03/12 05:16:08 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Morse-tutor for Linux using the Koch-method"
+HOMEPAGE="http://KochMorse.googlecode.com/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyalsaaudio[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -e 's:Categories=Application;:Categories=:' \
+ -i kochmorse.desktop || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}