summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-10 06:58:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-10 06:58:42 +0000
commitfee9bdd90781f143bac51279208683363605203f (patch)
tree43c13b165ec94f6bed8b55e943578bfa89c5cefd /media-sound/abcde
parentInitial commit, like MusicBrainz-DiscID, this is required by the new version ... (diff)
downloadgentoo-2-fee9bdd90781f143bac51279208683363605203f.tar.gz
gentoo-2-fee9bdd90781f143bac51279208683363605203f.tar.bz2
gentoo-2-fee9bdd90781f143bac51279208683363605203f.zip
Version bump wrt #415319 as reported by "Roger"
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/abcde')
-rw-r--r--media-sound/abcde/ChangeLog7
-rw-r--r--media-sound/abcde/abcde-2.5.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/media-sound/abcde/ChangeLog b/media-sound/abcde/ChangeLog
index 0fc6e8f9be13..6bba6f56ec7c 100644
--- a/media-sound/abcde/ChangeLog
+++ b/media-sound/abcde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcde
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcde/ChangeLog,v 1.56 2012/02/15 02:53:07 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcde/ChangeLog,v 1.57 2012/05/10 06:58:42 ssuominen Exp $
+
+*abcde-2.5.2 (10 May 2012)
+
+ 10 May 2012; Samuli Suominen <ssuominen@gentoo.org> +abcde-2.5.2.ebuild:
+ Version bump wrt #415319 as reported by "Roger"
15 Feb 2012; Tim Harder <radhermit@gentoo.org> -abcde-2.4.1.ebuild:
Remove old.
diff --git a/media-sound/abcde/abcde-2.5.2.ebuild b/media-sound/abcde/abcde-2.5.2.ebuild
new file mode 100644
index 000000000000..d3cde793fd78
--- /dev/null
+++ b/media-sound/abcde/abcde-2.5.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcde/abcde-2.5.2.ebuild,v 1.1 2012/05/10 06:58:42 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A command line CD encoder"
+HOMEPAGE="http://code.google.com/p/abcde/"
+SRC_URI="http://abcde.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="aac cdparanoia flac id3 lame musicbrainz normalize replaygain speex vorbis"
+
+RDEPEND="media-sound/cd-discid
+ net-misc/wget
+ virtual/eject
+ aac? (
+ media-libs/faac
+ media-video/atomicparsley
+ )
+ cdparanoia? ( media-sound/cdparanoia )
+ flac? ( media-libs/flac )
+ id3? (
+ >=media-sound/id3-0.12
+ media-sound/id3v2
+ )
+ lame? ( media-sound/lame )
+ musicbrainz? (
+ dev-perl/MusicBrainz-DiscID
+ dev-perl/WebService-MusicBrainz
+ perl-core/Digest-SHA
+ virtual/perl-Getopt-Long
+ )
+ normalize? ( >=media-sound/normalize-0.7.4 )
+ replaygain? (
+ vorbis? ( media-sound/vorbisgain )
+ lame? ( media-sound/mp3gain )
+ )
+ speex? ( media-libs/speex )
+ vorbis? ( media-sound/vorbis-tools )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/m4a-tagging.patch
+ sed -i -e 's:/etc/abcde.conf:/etc/abcde/abcde.conf:g' abcde || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" etcdir="${D}etc/abcde" install
+ dodoc changelog FAQ README TODO USEPIPES
+ docinto examples
+ dodoc examples/*
+}