summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-02 09:07:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-02 09:07:24 +0000
commit05d0ca9699265304061c69b87fce05226b3f2928 (patch)
tree45f7c293f6d57e1f6b134ec4e273e8938edb912d /media-sound/alsa-driver
parentNew version. (diff)
downloadgentoo-2-05d0ca9699265304061c69b87fce05226b3f2928.tar.gz
gentoo-2-05d0ca9699265304061c69b87fce05226b3f2928.tar.bz2
gentoo-2-05d0ca9699265304061c69b87fce05226b3f2928.zip
Cleanup old verisons.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog9
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild164
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.10.ebuild162
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.10_rc3.ebuild163
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-0.9.8-au-fix.patch24
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch105
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.101
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.10-r11
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc31
-rw-r--r--media-sound/alsa-driver/files/makefile.patch28
10 files changed, 8 insertions, 650 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 9f01b0502a5e..fc0c34f7fd35 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.196 2006/01/22 07:19:21 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.197 2006/02/02 09:07:10 flameeyes Exp $
+
+ 02 Feb 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/alsa-driver-0.9.8-au-fix.patch,
+ -files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch, -files/makefile.patch,
+ -alsa-driver-1.0.10_rc3.ebuild, -alsa-driver-1.0.10.ebuild,
+ -alsa-driver-1.0.10-r1.ebuild:
+ Cleanup old verisons.
22 Jan 2006; Joseph Jezak <josejx@gentoo.org>
alsa-driver-1.0.10-r2.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild
deleted file mode 100644
index 059c0251615f..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild,v 1.2 2005/12/19 09:33:13 flameeyes Exp $
-
-inherit linux-mod flag-o-matic eutils
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="oss doc debug"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- export CBUILD=${CBUILD-${CHOST}}
- export CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
- epatch "${FILESDIR}/${P}-oops.patch"
-
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- $(use_with debug debug full) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- ARCH=$(tc-arch-kernel)
- # -j1 : see bug #71028
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.10.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.10.ebuild
deleted file mode 100644
index 3d3f8297f5f9..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.10.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.10.ebuild,v 1.8 2006/01/15 15:52:20 agriffis Exp $
-
-inherit linux-mod flag-o-matic eutils
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 x86"
-IUSE="oss doc"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- CBUILD=${CBUILD-${CHOST}}
- CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
-
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- ARCH=$(tc-arch-kernel)
- # -j1 : see bug #71028
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.10_rc3.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.10_rc3.ebuild
deleted file mode 100644
index 21e957ff78f4..000000000000
--- a/media-sound/alsa-driver/alsa-driver-1.0.10_rc3.ebuild
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.10_rc3.ebuild,v 1.5 2005/11/15 19:00:50 wolf31o2 Exp $
-
-inherit linux-mod flag-o-matic eutils
-
-MY_P="${P/_rc/rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ppc ~ppc64 x86"
-IUSE="oss doc"
-
-RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- sparc? ( >=sys-devel/autoconf-2.50 )
- sys-apps/debianutils"
-
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- # By default, drivers for all supported cards will be compiled.
- # If you want to only compile for specific card(s), set ALSA_CARDS
- # environment to a space-separated list of drivers that you want to build.
- # For example:
- #
- # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
- #
- ALSA_CARDS=${ALSA_CARDS:-all}
-
- # Which drivers need PNP
- local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
- fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
-
- linux-mod_pkg_setup
-
- if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- CBUILD=${CBUILD-${CHOST}}
- CHOST="sparc64-unknown-linux-gnu"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
- epatch "${FILESDIR}/${P}-ppc-unbreakage.patch"
-
- convert_to_m ${S}/Makefile
- sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
-}
-
-src_compile() {
- # Should fix bug #46901
- is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
- append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
-
- econf $(use_with oss) \
- --with-kernel="${KV_DIR}" \
- --with-build="${KV_OUT_DIR}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-cards="${ALSA_CARDS}" || die "econf failed"
-
- # linux-mod_src_compile doesn't work well with alsa
-
- ARCH=$(tc-arch-kernel)
- # -j1 : see bug #71028
- emake -j1 HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
- ARCH=$(tc-arch)
-
- if use doc;
- then
- ebegin "Building Documentation"
- cd ${S}/scripts
- emake || die Failed making docs in ${S}/scripts
-
- cd ${S}/doc/DocBook
- emake || die Failed making docs in ${S}/doc/DocBook
- eend $?
- fi
-}
-
-
-src_install() {
- make DESTDIR=${D} install-modules || die "make install failed"
-
- dodoc CARDS-STATUS FAQ README WARNING TODO
-
- if use doc; then
- docinto doc
- dodoc doc/*
- rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
-
- docinto DocBook
- dodoc doc/DocBook/*
- rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
-
- docinto Documentation
- dodoc sound/Documentation/*
- fi
-
- if kernel_is 2 6; then
- # mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
- fi
-}
-
-pkg_postinst() {
- einfo
- einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
- einfo
- einfo "Also, remember that all mixer channels will be MUTED by default."
- einfo "Use the 'alsamixer' program to unmute them."
- einfo
- einfo "Version 1.0.3 and above should work with version 2.6 kernels."
- einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
- einfo
-
- linux-mod_pkg_postinst
-
- einfo "Check out the ALSA installation guide availible at the following URL:"
- einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
-
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
- # Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
- rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
- done
-
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
- fi
-}
diff --git a/media-sound/alsa-driver/files/alsa-driver-0.9.8-au-fix.patch b/media-sound/alsa-driver/files/alsa-driver-0.9.8-au-fix.patch
deleted file mode 100644
index daeba268271a..000000000000
--- a/media-sound/alsa-driver/files/alsa-driver-0.9.8-au-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur alsa-driver-0.9.8.orig/alsa-kernel/drivers/mpu401/Makefile alsa-driver-0.9.8/alsa-kernel/drivers/mpu401/Makefile
---- alsa-driver-0.9.8.orig/alsa-kernel/drivers/mpu401/Makefile 2003-06-02 05:59:40.000000000 -0700
-+++ alsa-driver-0.9.8/alsa-kernel/drivers/mpu401/Makefile 2004-02-08 01:18:47.000000000 -0800
-@@ -41,5 +41,8 @@
- obj-$(CONFIG_SND_YMFPCI) += snd-mpu401-uart.o
- obj-$(CONFIG_SND_PC98_CS4232) += snd-mpu401-uart.o
- obj-$(CONFIG_SND_SSCAPE) += snd-mpu401-uart.o
-+obj-$(CONFIG_SND_AU8810) += snd-mpu401-uart.o
-+obj-$(CONFIG_SND_AU8820) += snd-mpu401-uart.o
-+obj-$(CONFIG_SND_AU8830) += snd-mpu401-uart.o
-
- obj-m := $(sort $(obj-m))
-diff -Naur alsa-driver-0.9.8.orig/alsa-kernel/pci/ac97/Makefile alsa-driver-0.9.8/alsa-kernel/pci/ac97/Makefile
---- alsa-driver-0.9.8.orig/alsa-kernel/pci/ac97/Makefile 2003-06-17 11:43:31.000000000 -0700
-+++ alsa-driver-0.9.8/alsa-kernel/pci/ac97/Makefile 2004-02-08 01:17:58.000000000 -0800
-@@ -23,5 +23,8 @@
- obj-$(CONFIG_SND_NM256) += snd-ac97-codec.o
- obj-$(CONFIG_SND_TRIDENT) += snd-ac97-codec.o
- obj-$(CONFIG_SND_YMFPCI) += snd-ac97-codec.o
-+obj-$(CONFIG_SND_AU8810) += snd-ac97-codec.o
-+obj-$(CONFIG_SND_AU8820) += snd-ac97-codec.o
-+obj-$(CONFIG_SND_AU8830) += snd-ac97-codec.o
-
- obj-m := $(sort $(obj-m))
diff --git a/media-sound/alsa-driver/files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch b/media-sound/alsa-driver/files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch
deleted file mode 100644
index 43a462a004eb..000000000000
--- a/media-sound/alsa-driver/files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-Index: alsa-driver-1.0.10rc3/sound/ppc/beep.c
-===================================================================
---- alsa-driver-1.0.10rc3.orig/sound/ppc/beep.c
-+++ alsa-driver-1.0.10rc3/sound/ppc/beep.c
-@@ -31,14 +31,14 @@
- #include "pmac.h"
-
- struct snd_pmac_beep {
-- int running; /* boolean */
-- int volume; /* mixer volume: 0-100 */
-+ int running; /* boolean */
-+ int volume; /* mixer volume: 0-100 */
- int volume_play; /* currently playing volume */
- int hz;
- int nsamples;
- short *buf; /* allocated wave buffer */
- dma_addr_t addr; /* physical address of buffer */
-- struct input_dev *dev;
-+ struct input_dev dev;
- };
-
- /*
-@@ -210,55 +210,47 @@ static snd_kcontrol_new_t snd_pmac_beep_
- int __init snd_pmac_attach_beep(pmac_t *chip)
- {
- pmac_beep_t *beep;
-- struct input_dev *input_dev;
-- void *dmabuf;
-- int err = -ENOMEM;
--
-- beep = kzalloc(sizeof(*beep), GFP_KERNEL);
-- dmabuf = dma_alloc_coherent(&chip->pdev->dev, BEEP_BUFLEN * 4,
-- &beep->addr, GFP_KERNEL);
-- input_dev = input_allocate_device();
-- if (!beep || !dmabuf || !input_dev)
-- goto fail;
-+ int err;
-+
-+ beep = kmalloc(sizeof(*beep), GFP_KERNEL);
-+ if (! beep)
-+ return -ENOMEM;
-+
-+ memset(beep, 0, sizeof(*beep));
-+ beep->buf = dma_alloc_coherent(&chip->pdev->dev, BEEP_BUFLEN * 4,
-+ &beep->addr, GFP_KERNEL);
-+
-+ beep->dev.evbit[0] = BIT(EV_SND);
-+ beep->dev.sndbit[0] = BIT(SND_BELL) | BIT(SND_TONE);
-+ beep->dev.event = snd_pmac_beep_event;
-+ beep->dev.private = chip;
-
- /* FIXME: set more better values */
-- input_dev->name = "PowerMac Beep";
-- input_dev->phys = "powermac/beep";
-- input_dev->id.bustype = BUS_ADB;
-- input_dev->id.vendor = 0x001f;
-- input_dev->id.product = 0x0001;
-- input_dev->id.version = 0x0100;
--
-- input_dev->evbit[0] = BIT(EV_SND);
-- input_dev->sndbit[0] = BIT(SND_BELL) | BIT(SND_TONE);
-- input_dev->event = snd_pmac_beep_event;
-- input_dev->private = chip;
-- input_dev->cdev.dev = &chip->pdev->dev;
-+ beep->dev.name = "PowerMac Beep";
-+ beep->dev.phys = "powermac/beep";
-+ beep->dev.id.bustype = BUS_ADB;
-+ beep->dev.id.vendor = 0x001f;
-+ beep->dev.id.product = 0x0001;
-+ beep->dev.id.version = 0x0100;
-
-- beep->dev = input_dev;
-- beep->buf = dmabuf;
- beep->volume = BEEP_VOLUME;
- beep->running = 0;
--
-- err = snd_ctl_add(chip->card, snd_ctl_new1(&snd_pmac_beep_mixer, chip));
-- if (err < 0)
-- goto fail;
-+ if ((err = snd_ctl_add(chip->card, snd_ctl_new1(&snd_pmac_beep_mixer, chip))) < 0) {
-+ kfree(beep->buf);
-+ kfree(beep);
-+ return err;
-+ }
-
- chip->beep = beep;
-- input_register_device(beep->dev);
-+ input_register_device(&beep->dev);
-
- return 0;
--
-- fail: input_free_device(input_dev);
-- kfree(dmabuf);
-- kfree(beep);
-- return err;
- }
-
- void snd_pmac_detach_beep(pmac_t *chip)
- {
- if (chip->beep) {
-- input_unregister_device(chip->beep->dev);
-+ input_unregister_device(&chip->beep->dev);
- dma_free_coherent(&chip->pdev->dev, BEEP_BUFLEN * 4,
- chip->beep->buf, chip->beep->addr);
- kfree(chip->beep);
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10
deleted file mode 100644
index 5d0bc883e3c8..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e9e7c1ca664a14275d67185049f933f9 alsa-driver-1.0.10.tar.bz2 2194644
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10-r1 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10-r1
deleted file mode 100644
index 5d0bc883e3c8..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e9e7c1ca664a14275d67185049f933f9 alsa-driver-1.0.10.tar.bz2 2194644
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc3 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc3
deleted file mode 100644
index b87b0b3a9b6a..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4a5bae151a08cc0d6a6a768bf4a7207e alsa-driver-1.0.10rc3.tar.bz2 2191881
diff --git a/media-sound/alsa-driver/files/makefile.patch b/media-sound/alsa-driver/files/makefile.patch
deleted file mode 100644
index 8190cb78ea77..000000000000
--- a/media-sound/alsa-driver/files/makefile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.hacked 2003-05-23 11:24:05.000000000 +0100
-+++ Makefile 2003-08-05 21:19:05.809762711 +0100
-@@ -107,7 +107,7 @@
- mv -f snd.map1 snd.map
-
- .PHONY: install
--install: install-modules install-headers install-scripts check-snd-prefix
-+install: install-modules install-headers check-snd-prefix
- @if [ -L /dev/snd ]; then \
- echo "The ALSA devices were removed from /proc/asound/dev directory." ; \
- echo "Creating static device entries in /dev/snd." ; \
-@@ -146,16 +146,6 @@
- -/sbin/depmod -a -b $(DESTDIR)/ $(SYSTEM_MAP_OPT) $(kaversion)
- endif
-
--.PHONY: install-scripts
--install-scripts:
-- if [ -d $(DESTDIR)/sbin/init.d ]; then \
-- install -m 755 -g $(IGROUP) -o $(IUSER) utils/alsasound $(DESTDIR)/sbin/init.d/alsasound; \
-- elif [ -d $(DESTDIR)/etc/rc.d/init.d ]; then \
-- install -m 755 -g $(IGROUP) -o $(IUSER) utils/alsasound $(DESTDIR)/etc/rc.d/init.d/alsasound; \
-- elif [ -d $(DESTDIR)/etc/init.d ]; then \
-- install -m 755 -g $(IGROUP) -o $(IUSER) utils/alsasound $(DESTDIR)/etc/init.d/alsasound; \
-- fi
--
- .PHONY: check-snd-prefix
- check-snd-prefix:
- @ if [ x"$(DESTDIR)" = x ]; then \