summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-08-13 18:55:47 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-08-13 18:55:47 +0000
commit65239f0869a9687fb0e15e1ffac1305d32df76b7 (patch)
tree9c26eb043e42c49498b6d306b6ca3ca7fca0e078 /media-sound/alsamixergui
parentTabified. (diff)
downloadgentoo-2-65239f0869a9687fb0e15e1ffac1305d32df76b7.tar.gz
gentoo-2-65239f0869a9687fb0e15e1ffac1305d32df76b7.tar.bz2
gentoo-2-65239f0869a9687fb0e15e1ffac1305d32df76b7.zip
Fixed with latest fltk compatibility.
Closes #6217.
Diffstat (limited to 'media-sound/alsamixergui')
-rw-r--r--media-sound/alsamixergui/ChangeLog6
-rw-r--r--media-sound/alsamixergui/alsamixergui-0.9.0.1.2.ebuild27
2 files changed, 24 insertions, 9 deletions
diff --git a/media-sound/alsamixergui/ChangeLog b/media-sound/alsamixergui/ChangeLog
index e477776c1ec1..5d9be6828bd7 100644
--- a/media-sound/alsamixergui/ChangeLog
+++ b/media-sound/alsamixergui/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for media-sound/alsamixergui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/ChangeLog,v 1.2 2002/05/24 07:43:44 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/ChangeLog,v 1.3 2002/08/13 18:55:45 agenkin Exp $
*alsamixergui-0.9.0.1.2 (24 May 2002)
+ 13 Aug 2002; Arcady Genkin <agenkin@thpoon.com> alsamixergui-0.9.0.1.2.ebuild :
+
+ Hacked for compatibility with the latest fltk library.
+
24 May 2002; Arcady Genkin <agenkin@thpoon.com> alsamixergui-0.9.0.1.2.ebuild :
Initial version of the package, created by you@hanez.org (Johannes Findeisen). \ No newline at end of file
diff --git a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2.ebuild b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2.ebuild
index 25d1da12d74c..72eb9ee6bdfd 100644
--- a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2.ebuild
+++ b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2.ebuild
@@ -1,23 +1,34 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/alsamixergui-0.9.0.1.2.ebuild,v 1.3 2002/07/19 12:27:49 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/alsamixergui-0.9.0.1.2.ebuild,v 1.4 2002/08/13 18:55:47 agenkin Exp $
-# Weird version numbering.
-# I'm mapping rc1-2 into "1.2" suffix for the package.
-NATIVE_VER=0.9.0rc1-2
-S=${WORKDIR}/${PN}-${NATIVE_VER}
DESCRIPTION="AlsaMixerGui - a FLTK based amixer Frontend"
HOMEPAGE="http://www.iua.upf.es/~mdeboer/projects/alsamixergui/"
-SRC_URI="ftp://www.iua.upf.es/pub/mdeboer/projects/alsamixergui/${PN}-${NATIVE_VER}.tar.gz"
+LICENSE="GPL-2"
DEPEND=" >=media-sound/alsa-driver-0.9.0_rc1-r1
>=media-sound/alsa-utils-0.9.0_rc1
- >=x11-libs/fltk-1.0.11"
+ >=x11-libs/fltk-1.1.0_rc4"
SLOT="0"
-LICENSE="GPL-2"
KEYWORDS="x86"
+# Weird version numbering.
+# I'm mapping rc1-2 into "1.2" suffix for the package.
+NATIVE_VER=0.9.0rc1-2
+S=${WORKDIR}/${PN}-${NATIVE_VER}
+SRC_URI="ftp://www.iua.upf.es/pub/mdeboer/projects/alsamixergui/${PN}-${NATIVE_VER}.tar.gz"
+
+src_unpack() {
+ ## A temporary measure to get around incompatibility with fltk
+ ## library. See bug #6217.
+ unpack ${A}
+ cd ${S}
+ sed -e 's/^numericsort/fl_numericsort/' <configure >configure.hacked
+ mv configure.hacked configure
+ chmod 755 configure
+}
+
src_compile() {
cd ${S}
./configure || die "./configure failed"